|
@@ -10,14 +10,14 @@
|
10
|
10
|
include $(TOPDIR)/rules.mk
|
11
|
11
|
|
12
|
12
|
PKG_NAME:=ruby
|
13
|
|
-PKG_VERSION:=2.2.1
|
|
13
|
+PKG_VERSION:=2.2.2
|
14
|
14
|
PKG_RELEASE:=1
|
15
|
15
|
|
16
|
16
|
PKG_LIBVER:=2.2
|
17
|
17
|
|
18
|
18
|
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
|
19
|
19
|
PKG_SOURCE_URL:=http://cache.ruby-lang.org/pub/ruby/$(PKG_LIBVER)/
|
20
|
|
-PKG_MD5SUM:=06973777736d8e6bdad8dcaa469a9da3
|
|
20
|
+PKG_MD5SUM:=af6eb4fa7247f1f7b2e19c8e6f3e3145
|
21
|
21
|
PKG_MAINTAINER:=Luiz Angelo Daros de Luca <luizluca@gmail.com>
|
22
|
22
|
PKG_LICENSE:=BSD-2-Clause
|
23
|
23
|
PKG_LICENSE_FILES:=COPYING
|
|
@@ -804,6 +804,12 @@ HOST_CONFIGURE_ARGS += \
|
804
|
804
|
--disable-install-capi \
|
805
|
805
|
--with-static-linked-ext \
|
806
|
806
|
|
|
807
|
+# even not used, host build with restricted exts results in gems not being
|
|
808
|
+# compiling for target (probably some cross compiling problem like checking
|
|
809
|
+# host for selecting target features)
|
|
810
|
+# --with-out-ext \
|
|
811
|
+# --with-ext=thread,stringio \
|
|
812
|
+
|
807
|
813
|
CONFIGURE_ARGS += \
|
808
|
814
|
--enable-shared \
|
809
|
815
|
--enable-static \
|