Browse Source

ntripcaster: change source server, fix install location

ntripcaster developer agency (http://igs.bkg.bund.de/) no longer provides sources for download.

Created a github repository to provide sources and allow contributions.

Fixed install location for configuration files.

Signed-off-by: Nuno Goncalves <nunojpg@gmail.com>
Nuno Goncalves 9 years ago
parent
commit
35ddbb01b6
1 changed files with 14 additions and 17 deletions
  1. 14
    17
      net/ntripcaster/Makefile

+ 14
- 17
net/ntripcaster/Makefile View File

@@ -10,12 +10,16 @@ include $(TOPDIR)/rules.mk
10 10
 
11 11
 PKG_NAME:=ntripcaster
12 12
 PKG_VERSION:=0.1.5
13
-PKG_RELEASE:=1
14
-PKG_LICENSE:=GPL-2.0+
15 13
 
16
-PKG_SOURCE:=$(PKG_NAME)$(PKG_VERSION).zip
17
-PKG_SOURCE_URL:=http://igs.bkg.bund.de/root_ftp/NTRIP/software/
18
-PKG_MD5SUM:=8c85a6c31d8c5cdf2638fe103207a1fd
14
+PKG_RELEASE=$(PKG_SOURCE_VERSION)
15
+
16
+PKG_SOURCE_PROTO:=git
17
+PKG_SOURCE_URL:=https://github.com/nunojpg/ntripcaster.git
18
+PKG_SOURCE_SUBDIR:=$(PKG_NAME)-$(PKG_VERSION)
19
+PKG_SOURCE_VERSION:=03878920195cf854b38a1ea424f1cae57353fa87
20
+PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION)-$(PKG_SOURCE_VERSION).tar.gz
21
+
22
+PKG_LICENSE:=GPL-2.0+
19 23
 
20 24
 PKG_MAINTAINER:=Nuno Goncalves <nunojpg@gmail.com>
21 25
 
@@ -34,19 +38,12 @@ define Package/ntripcaster/description
34 38
   BKG Standard Ntrip Broadcaster
35 39
 endef
36 40
 
37
-define Build/Prepare
38
-	mkdir -p $(PKG_BUILD_DIR)
39
-	unzip $(DL_DIR)/$(PKG_SOURCE) -d $(PKG_BUILD_DIR)
40
-	mv $(PKG_BUILD_DIR)/$(PKG_NAME)$(PKG_VERSION)/* $(PKG_BUILD_DIR)
41
-	chmod +x $(PKG_BUILD_DIR)/configure
42
-endef
43
-
44 41
 define Package/ntripcaster/install
45
-	$(INSTALL_DIR) $(1)/usr/local/ntripcaster/bin
46
-	$(INSTALL_BIN) $(PKG_BUILD_DIR)/src/ntripcaster $(1)/usr/local/ntripcaster/bin/
47
-	$(INSTALL_DIR) $(1)/usr/local/ntripcaster/conf
48
-	$(INSTALL_DATA) $(PKG_BUILD_DIR)/conf/ntripcaster.conf.dist $(1)/usr/local/ntripcaster/conf/
49
-	$(INSTALL_DATA) $(PKG_BUILD_DIR)/conf/sourcetable.dat.dist $(1)/usr/local/ntripcaster/conf/
42
+	$(INSTALL_DIR) $(1)/usr/bin
43
+	$(INSTALL_BIN) $(PKG_BUILD_DIR)/src/ntripcaster $(1)/usr/bin/
44
+	$(INSTALL_DIR) $(1)/usr/share/ntripcaster/conf
45
+	$(INSTALL_DATA) $(PKG_BUILD_DIR)/conf/ntripcaster.conf.dist $(1)/usr/share/ntripcaster/conf/
46
+	$(INSTALL_DATA) $(PKG_BUILD_DIR)/conf/sourcetable.dat.dist $(1)/usr/share/ntripcaster/conf/
50 47
 endef
51 48
 
52 49
 $(eval $(call BuildPackage,ntripcaster))