Browse Source

mmc-utils: restore FORTIFY_SOURCE=2

The previous commit
ba4338d mmc-utils: don't set -D_FORTIFY_SOURCE in Makefile
applied the global value of FORITFY_SOURCE also to mmc-utils.
As the package was meant to be built with FORTIFY_SOURCE upstream,
restore that behaviour and make it play nice with the global setting
by undefining the macro before defining it.

Signed-off-by: Daniel Golle <daniel@makrotopia.org>
Daniel Golle 9 years ago
parent
commit
360122ed5d

utils/mmc-utils/patches/001-dont-set-fortify-source-in-makefile.patch → utils/mmc-utils/patches/001-properly-set-fortify-source-in-makefile.patch View File

@@ -5,7 +5,7 @@ Index: mmc-utils-f4eb241519f8d500ce6068a70d2389be39ac5189/Makefile
5 5
 @@ -1,5 +1,5 @@
6 6
  CC ?= gcc
7 7
 -AM_CFLAGS = -D_FILE_OFFSET_BITS=64 -D_FORTIFY_SOURCE=2
8
-+AM_CFLAGS = -D_FILE_OFFSET_BITS=64
8
++AM_CFLAGS = -D_FILE_OFFSET_BITS=64 -U_FORTIFY_SOURCE -D_FORTIFY_SOURCE=2
9 9
  CFLAGS ?= -g -O2
10 10
  objects = \
11 11
  	mmc.o \