|
@@ -1,5 +1,5 @@
|
1
|
1
|
#
|
2
|
|
-# Copyright (C) 2008-2014 OpenWrt.org
|
|
2
|
+# Copyright (C) 2008-2015 OpenWrt.org
|
3
|
3
|
#
|
4
|
4
|
# This is free software, licensed under the GNU General Public License v2.
|
5
|
5
|
# See /LICENSE for more information.
|
|
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
|
9
|
9
|
|
10
|
10
|
PKG_NAME:=linknx
|
11
|
11
|
PKG_VERSION:=0.0.1.32
|
12
|
|
-PKG_RELEASE:=4
|
|
12
|
+PKG_RELEASE:=5
|
13
|
13
|
PKG_MD5SUM:=7ecc1208f59bceb05068c752b2250b63
|
14
|
14
|
|
15
|
15
|
PKG_MAINTAINER:=Othmar Truniger <github@truniger.ch>
|
|
@@ -17,7 +17,6 @@ PKG_LICENSE:=GPL-2.0+
|
17
|
17
|
|
18
|
18
|
PKG_SOURCE_URL:=@SF/linknx
|
19
|
19
|
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
|
20
|
|
-PKG_BUILD_DEPENDS:=pthsem curl libesmtp
|
21
|
20
|
|
22
|
21
|
include $(INCLUDE_DIR)/package.mk
|
23
|
22
|
|
|
@@ -26,26 +25,19 @@ define Package/linknx
|
26
|
25
|
CATEGORY:=Network
|
27
|
26
|
TITLE:=KNX home automation platform
|
28
|
27
|
URL:=http://sourceforge.net/projects/linknx/
|
29
|
|
- DEPENDS:=pthsem +lua +luac +libstdcpp +libcurl +libesmtp
|
|
28
|
+ DEPENDS:=+pthsem +argp-standalone +lua +luac +libstdcpp +libcurl +libesmtp
|
30
|
29
|
endef
|
31
|
30
|
|
32
|
|
-define Build/Configure
|
33
|
|
- (cd $(PKG_BUILD_DIR); touch aclocal.m4 Makefile.in config.h.in configure; \
|
34
|
|
- $(SED) 's,\"2.0.4\",\"2.0.4\"\n_pth_version=\"2.0.8\",g' $(PKG_BUILD_DIR)/configure )
|
35
|
|
- $(call Build/Configure/Default,--verbose --without-pth-test --with-pth=$(STAGING_DIR) --without-log4cpp --with-lua --with-libcurl --without-mysql, \
|
36
|
|
- CXXFLAGS="$(TARGET_CFLAGS) -fno-builtin -lcrypt" \
|
37
|
|
- )
|
38
|
|
-endef
|
|
31
|
+CONFIGURE_ARGS+= \
|
|
32
|
+ --verbose \
|
|
33
|
+ --without-pth-test \
|
|
34
|
+ --without-log4cpp \
|
|
35
|
+ --with-lua \
|
|
36
|
+ --with-libcurl \
|
|
37
|
+ --without-mysql
|
39
|
38
|
|
40
|
|
-define Build/Compile
|
41
|
|
- $(MAKE) -C $(PKG_BUILD_DIR)/ \
|
42
|
|
- LIBDIR="$(TARGET_LDFLAGS)" \
|
43
|
|
- CC="$(TARGET_CC) $(TARGET_CFLAGS) $(TARGET_CPPFLAGS) " \
|
44
|
|
- LD="$(TARGET_CROSS)ld -shared" \
|
45
|
|
- LUA="$(STAGING_DIR_HOST)/bin/lua" \
|
46
|
|
- LUAC="$(STAGING_DIR_HOST)/bin/luac" \
|
47
|
|
- CFLAGS="$(TARGET_CFLAGS) -nodefaultlibs" all
|
48
|
|
-endef
|
|
39
|
+EXTRA_LDFLAGS+= \
|
|
40
|
+ -fno-builtin
|
49
|
41
|
|
50
|
42
|
define Package/linknx/install
|
51
|
43
|
$(INSTALL_DIR) $(1)/usr/bin
|