|
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
|
9
|
9
|
|
10
|
10
|
PKG_NAME:=bluez
|
11
|
11
|
PKG_VERSION:=5.30
|
12
|
|
-PKG_RELEASE:=1
|
|
12
|
+PKG_RELEASE:=2
|
13
|
13
|
|
14
|
14
|
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.xz
|
15
|
15
|
PKG_SOURCE_URL:=http://www.kernel.org/pub/linux/bluetooth/
|
|
@@ -47,7 +47,7 @@ $(call Package/bluez/Default)
|
47
|
47
|
SECTION:=libs
|
48
|
48
|
CATEGORY:=Libraries
|
49
|
49
|
TITLE+= library
|
50
|
|
- DEPENDS:=+libpthread
|
|
50
|
+ DEPENDS:=+libpthread +kmod-bluetooth
|
51
|
51
|
endef
|
52
|
52
|
|
53
|
53
|
define Package/bluez-utils
|
|
@@ -55,10 +55,18 @@ $(call Package/bluez/Default)
|
55
|
55
|
SECTION:=utils
|
56
|
56
|
CATEGORY:=Utilities
|
57
|
57
|
TITLE+= utilities
|
58
|
|
- DEPENDS:=+bluez-libs +libpthread +librt +dbus +glib2 +libical +libncurses +libreadline $(INTL_DEPENDS) $(ICONV_DEPENDS)
|
|
58
|
+ DEPENDS:=+bluez-libs +libpthread +librt +glib2 +libncurses +libreadline $(INTL_DEPENDS) $(ICONV_DEPENDS)
|
59
|
59
|
endef
|
60
|
60
|
|
61
|
|
-define Package/bluez-utils/conffiles
|
|
61
|
+define Package/bluez-daemon
|
|
62
|
+$(call Package/bluez/Default)
|
|
63
|
+ SECTION:=utils
|
|
64
|
+ CATEGORY:=Utilities
|
|
65
|
+ TITLE+= daemon
|
|
66
|
+ DEPENDS:=+bluez-libs +bluez-utils +dbus +libical $(INTL_DEPENDS) $(ICONV_DEPENDS)
|
|
67
|
+endef
|
|
68
|
+
|
|
69
|
+define Package/bluez-daemon/conffiles
|
62
|
70
|
/etc/bluetooth/main.conf
|
63
|
71
|
/etc/bluetooth/network.conf
|
64
|
72
|
/etc/bluetooth/input.conf
|
|
@@ -109,10 +117,28 @@ endef
|
109
|
117
|
|
110
|
118
|
define Package/bluez-utils/install
|
111
|
119
|
$(INSTALL_DIR) $(1)/usr/bin
|
112
|
|
- $(CP) $(PKG_INSTALL_DIR)/usr/bin/* $(1)/usr/bin/
|
|
120
|
+ $(CP) $(PKG_INSTALL_DIR)/usr/bin/bccmd $(1)/usr/bin/
|
|
121
|
+ $(CP) $(PKG_INSTALL_DIR)/usr/bin/bluemoon $(1)/usr/bin/
|
|
122
|
+ $(CP) $(PKG_INSTALL_DIR)/usr/bin/btmon $(1)/usr/bin/
|
|
123
|
+ $(CP) $(PKG_INSTALL_DIR)/usr/bin/ciptool $(1)/usr/bin/
|
|
124
|
+ $(CP) $(PKG_INSTALL_DIR)/usr/bin/hciattach $(1)/usr/bin/
|
|
125
|
+ $(CP) $(PKG_INSTALL_DIR)/usr/bin/hciconfig $(1)/usr/bin/
|
|
126
|
+ $(CP) $(PKG_INSTALL_DIR)/usr/bin/hcidump $(1)/usr/bin/
|
|
127
|
+ $(CP) $(PKG_INSTALL_DIR)/usr/bin/hcitool $(1)/usr/bin/
|
|
128
|
+ $(CP) $(PKG_INSTALL_DIR)/usr/bin/hex2hcd $(1)/usr/bin/
|
|
129
|
+ $(CP) $(PKG_INSTALL_DIR)/usr/bin/l2ping $(1)/usr/bin/
|
|
130
|
+ $(CP) $(PKG_INSTALL_DIR)/usr/bin/l2test $(1)/usr/bin/
|
|
131
|
+ $(CP) $(PKG_INSTALL_DIR)/usr/bin/rctest $(1)/usr/bin/
|
|
132
|
+ $(CP) $(PKG_INSTALL_DIR)/usr/bin/rfcomm $(1)/usr/bin/
|
|
133
|
+ $(CP) $(PKG_INSTALL_DIR)/usr/bin/sdptool $(1)/usr/bin/
|
|
134
|
+ $(INSTALL_BIN) $(PKG_BUILD_DIR)/attrib/gatttool $(1)/usr/bin/
|
|
135
|
+endef
|
|
136
|
+
|
|
137
|
+define Package/bluez-daemon/install
|
|
138
|
+ $(INSTALL_DIR) $(1)/usr/bin
|
113
|
139
|
$(CP) $(PKG_INSTALL_DIR)/usr/lib/bluetooth/bluetoothd $(1)/usr/bin/
|
|
140
|
+ $(CP) $(PKG_INSTALL_DIR)/usr/bin/bluetoothctl $(1)/usr/bin/
|
114
|
141
|
$(CP) $(PKG_INSTALL_DIR)/usr/lib/bluetooth/obexd $(1)/usr/bin/
|
115
|
|
- $(INSTALL_BIN) $(PKG_BUILD_DIR)/attrib/gatttool $(1)/usr/bin/
|
116
|
142
|
$(INSTALL_DIR) $(1)/etc/config
|
117
|
143
|
$(INSTALL_DATA) ./files/bluetooth.config $(1)/etc/config/bluetooth
|
118
|
144
|
$(INSTALL_DIR) $(1)/etc/dbus-1/system.d/
|
|
@@ -129,3 +155,4 @@ endef
|
129
|
155
|
$(eval $(call BuildPackage,bluez-examples))
|
130
|
156
|
$(eval $(call BuildPackage,bluez-libs))
|
131
|
157
|
$(eval $(call BuildPackage,bluez-utils))
|
|
158
|
+$(eval $(call BuildPackage,bluez-daemon))
|