Bläddra i källkod

toxcore: new package

This packages the Tox core as well as nTox and tox-bootstrapd.

Signed-off-by: Daniel Golle <daniel@makrotopia.org>
Daniel Golle 9 år sedan
förälder
incheckning
3a1b961956
1 ändrade filer med 170 tillägg och 0 borttagningar
  1. 170
    0
      libs/toxcore/Makefile

+ 170
- 0
libs/toxcore/Makefile Visa fil

@@ -0,0 +1,170 @@
1
+#
2
+# Copyright (C) 2009-2015 OpenWrt.org
3
+#
4
+# This is free software, licensed under the GNU General Public License v2.
5
+# See /LICENSE for more information.
6
+#
7
+
8
+include $(TOPDIR)/rules.mk
9
+
10
+PKG_NAME:=toxcore
11
+PKG_VERSION:=0.0.0
12
+PKG_RELEASE:=1
13
+
14
+PKG_SOURCE_PROTO:=git
15
+PKG_SOURCE_URL:=https://github.com/irungentoo/toxcore.git
16
+PKG_SOURCE_VERSION:=6d883f488ff59b2394982b62895d50b1d1d55bf4
17
+PKG_SOURCE_SUBDIR:=$(PKG_NAME)-$(PKG_SOURCE_VERSION)
18
+PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION)-$(PKG_SOURCE_VERSION).tar.gz
19
+PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(PKG_SOURCE_VERSION)
20
+
21
+PKG_FIXUP:=autoreconf
22
+PKG_INSTALL:=1
23
+
24
+PKG_MAINTAINER:=Daniel Golle <daniel@makrotopia.org>
25
+PKG_LICENSE:=GPL
26
+
27
+include $(INCLUDE_DIR)/package.mk
28
+
29
+define Package/toxcore/Default
30
+  SECTION:=libs
31
+  CATEGORY:=Libraries
32
+  SUBMENU:=Networking
33
+  TITLE:=Tox
34
+  URL:=https://tox.im
35
+endef
36
+
37
+define Package/toxcore/description/Default
38
+  Tox, a FOSS initiative, aims to be an easy to use, all-in-one
39
+  communication platform that ensures their users full privacy and
40
+  secure message delivery.
41
+endef
42
+
43
+define Package/libtoxcore
44
+  $(call Package/toxcore/Default)
45
+  DEPENDS:=+libsodium +librt +libpthread
46
+  TITLE+= core library
47
+endef
48
+
49
+define Package/libtoxcore/description
50
+  $(call Package/toxcore/description/Default)
51
+
52
+  core library
53
+endef
54
+
55
+define Package/libtoxav
56
+  $(call Package/toxcore/Default)
57
+  DEPENDS:=+libtoxcore +libopus +libvpx
58
+  TITLE+= A/V library
59
+endef
60
+
61
+define Package/libtoxav/description
62
+  $(call Package/toxcore/description/Default)
63
+
64
+  A/V library providing audio/video codec bindings
65
+endef
66
+
67
+define Package/libtoxdns
68
+  $(call Package/toxcore/Default)
69
+  DEPENDS:=+libtoxcore
70
+  TITLE+= dns library
71
+endef
72
+
73
+define Package/libtoxdns/description
74
+  $(call Package/toxcore/description/Default)
75
+
76
+  DNS library
77
+endef
78
+
79
+define Package/libtoxencryptsave
80
+  $(call Package/toxcore/Default)
81
+  DEPENDS:=+libtoxcore
82
+  TITLE+= encryptsave library
83
+endef
84
+
85
+define Package/libtoxencryptsave/description
86
+  $(call Package/toxcore/description/Default)
87
+
88
+  encryptsave library
89
+endef
90
+
91
+define Package/ntox
92
+  SECTION:=net
93
+  CATEGORY:=Network
94
+  SUBMENU:=Instant Messaging
95
+  DEPENDS:=+libtoxcore +libncurses
96
+  TITLE:=ntox Tox command-line client
97
+endef
98
+
99
+define Package/ntox/description
100
+  $(call Package/toxcore/description/Default)
101
+
102
+  nTox is an ncurses-based command-line client for Tox.
103
+endef
104
+
105
+define Package/tox-bootstrapd
106
+  SECTION:=net
107
+  CATEGORY:=Network
108
+  SUBMENU:=Instant Messaging
109
+  DEPENDS:=+libtoxcore +libconfig
110
+  TITLE:=Tox DHT bootstrap
111
+endef
112
+
113
+define Package/tox-dht-bootstrap/description
114
+  $(call Package/toxcore/description/Default)
115
+
116
+  This package provide the Tox DHT bootstrap service.
117
+endef
118
+
119
+CONFIGURE_ARGS+= \
120
+	--enable-daemon \
121
+	--enable-ntox \
122
+	--enable-av \
123
+	--disable-testing \
124
+	--disable-tests
125
+
126
+define Package/libtoxav/install
127
+	$(INSTALL_DIR) $(1)/usr/lib
128
+	$(CP) $(PKG_INSTALL_DIR)/usr/lib/libtoxav.*so* $(1)/usr/lib
129
+endef
130
+
131
+define Package/libtoxcore/install
132
+	$(INSTALL_DIR) $(1)/usr/lib
133
+	$(CP) $(PKG_INSTALL_DIR)/usr/lib/libtoxcore.*so* $(1)/usr/lib
134
+endef
135
+
136
+define Package/libtoxdns/install
137
+	$(INSTALL_DIR) $(1)/usr/lib
138
+	$(CP) $(PKG_INSTALL_DIR)/usr/lib/libtoxdns.*so* $(1)/usr/lib
139
+endef
140
+
141
+define Package/libtoxencryptsave/install
142
+	$(INSTALL_DIR) $(1)/usr/lib
143
+	$(CP) $(PKG_INSTALL_DIR)/usr/lib/libtoxencryptsave.*so* $(1)/usr/lib
144
+endef
145
+
146
+define Package/tox-bootstrapd/install
147
+	$(INSTALL_DIR) $(1)/usr/bin
148
+	$(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/bin/tox-bootstrapd $(1)/usr/bin
149
+endef
150
+
151
+define Package/ntox/install
152
+	$(INSTALL_DIR) $(1)/usr/bin
153
+	$(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/bin/nTox $(1)/usr/bin
154
+endef
155
+
156
+define Build/InstallDev
157
+	$(INSTALL_DIR) $(1)/usr/include/tox
158
+	$(CP) $(PKG_INSTALL_DIR)/usr/include/tox/*.h $(1)/usr/include/tox
159
+	$(INSTALL_DIR) $(1)/usr/lib
160
+	$(CP) $(PKG_INSTALL_DIR)/usr/lib/libtox* $(1)/usr/lib/
161
+	$(INSTALL_DIR) $(1)/usr/lib/pkgconfig
162
+	$(CP) $(PKG_INSTALL_DIR)/usr/lib/pkgconfig/libtoxcore.pc $(1)/usr/lib/pkgconfig/
163
+endef
164
+
165
+$(eval $(call BuildPackage,libtoxav))
166
+$(eval $(call BuildPackage,libtoxcore))
167
+$(eval $(call BuildPackage,libtoxdns))
168
+$(eval $(call BuildPackage,libtoxencryptsave))
169
+$(eval $(call BuildPackage,ntox))
170
+$(eval $(call BuildPackage,tox-bootstrapd))