Browse Source

Revert to r181, default webui to simple stream only, option for full

Signed-off-by: Ted Hess <thess@kitschensync.net>
Ted Hess 10 years ago
parent
commit
3a599044ad

+ 6
- 2
multimedia/mjpg-streamer/Config.in View File

@@ -1,3 +1,7 @@
1
+#
2
+# Copyright (C) 2014 OpenWrt.org
3
+#
4
+
1 5
 if PACKAGE_mjpg-streamer
2 6
 
3 7
 config MJPG_STREAMER_V4L2
@@ -26,7 +30,7 @@ config MJPG_STREAMER_OUTPUT_HTTP
26 30
 	default y
27 31
 
28 32
 config MJPG_STREAMER_WWW
29
-	bool "Install Web UI files (includes cambozola)"
30
-	default y
33
+	bool "Install complete Web UI files (includes cambozola)"
34
+	default n
31 35
 
32 36
 endif

+ 7
- 4
multimedia/mjpg-streamer/Makefile View File

@@ -8,9 +8,9 @@
8 8
 include $(TOPDIR)/rules.mk
9 9
 
10 10
 PKG_NAME:=mjpg-streamer
11
-PKG_REV:=182
11
+PKG_REV:=181
12 12
 PKG_VERSION:=r$(PKG_REV)
13
-PKG_RELEASE:=1
13
+PKG_RELEASE:=2
14 14
 PKG_MAINTAINER:=Roger D <rogerdammit@gmail.com>
15 15
 
16 16
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
@@ -18,6 +18,7 @@ PKG_SOURCE_URL:=https://svn.code.sf.net/p/mjpg-streamer/code/mjpg-streamer
18 18
 PKG_SOURCE_SUBDIR:=$(PKG_NAME)-$(PKG_VERSION)
19 19
 PKG_SOURCE_VERSION:=$(PKG_REV)
20 20
 PKG_SOURCE_PROTO:=svn
21
+PKG_MD5SUM:=b2bc22665733319e647ace236e283684
21 22
 
22 23
 PKG_LICENSE:=GPL-2.0
23 24
 PKG_LICENSE_FILE:=LICENSE
@@ -95,10 +96,12 @@ ifeq ($(CONFIG_MJPG_STREAMER_OUTPUT_FILE),y)
95 96
 endif
96 97
 ifeq ($(CONFIG_MJPG_STREAMER_OUTPUT_HTTP),y)
97 98
 	$(CP) $(PKG_BUILD_DIR)/output_http.so $(1)/usr/lib
98
-endif
99
-ifeq ($(CONFIG_MJPG_STREAMER_WWW),y)
100 99
 	$(INSTALL_DIR) $(1)/www/webcam
100
+    ifeq ($(CONFIG_MJPG_STREAMER_WWW),y)
101 101
 	$(INSTALL_DATA) $(PKG_BUILD_DIR)/www/* $(1)/www/webcam
102
+    else
103
+	$(INSTALL_DATA) $(PKG_BUILD_DIR)/www/stream_simple.html $(1)/www/webcam/index.html
104
+    endif
102 105
 endif
103 106
 endef
104 107
 

+ 0
- 17
multimedia/mjpg-streamer/patches/010-enable-more-plugins.patch View File

@@ -1,17 +0,0 @@
1
---- a/Makefile
2
-+++ b/Makefile
3
-@@ -33,12 +33,12 @@ APP_BINARY = mjpg_streamer
4
- 
5
- # define the names and targets of the plugins
6
- PLUGINS = input_uvc.so
7
--#PLUGINS += output_file.so
8
-+PLUGINS += output_file.so
9
- #PLUGINS += output_udp.so
10
- PLUGINS += output_http.so
11
- PLUGINS += input_testpicture.so
12
- #PLUGINS += output_autofocus.so
13
--#PLUGINS += input_file.so
14
-+PLUGINS += input_file.so
15
- # PLUGINS += input_pylon.so
16
- # PLUGINS += input_megatec.so
17
- # PLUGINS += output_mars2020.so