Browse Source

lvm2: update source and refresh patches

Signed-off-by: Daniel Golle <daniel@makrotopia.org>
Daniel Golle 9 years ago
parent
commit
3a81a9b9fa

+ 2
- 2
utils/lvm2/Makefile View File

9
 include $(TOPDIR)/rules.mk
9
 include $(TOPDIR)/rules.mk
10
 
10
 
11
 PKG_NAME:=LVM2
11
 PKG_NAME:=LVM2
12
-PKG_VERSION:=2.02.120
12
+PKG_VERSION:=2.02.121
13
 PKG_RELEASE:=1
13
 PKG_RELEASE:=1
14
 PKG_LICENSE:=GPL-2.0 LGPL-2.1
14
 PKG_LICENSE:=GPL-2.0 LGPL-2.1
15
 
15
 
16
 PKG_SOURCE:=$(PKG_NAME).$(PKG_VERSION).tgz
16
 PKG_SOURCE:=$(PKG_NAME).$(PKG_VERSION).tgz
17
 PKG_SOURCE_URL:=ftp://sources.redhat.com/pub/lvm2
17
 PKG_SOURCE_URL:=ftp://sources.redhat.com/pub/lvm2
18
-PKG_MD5SUM:=326df8542d3a2376da907e98a0888ccf
18
+PKG_MD5SUM:=702c61bf07a8fc6dc0db6e9d323d9f6d
19
 PKG_MAINTAINER:=Daniel Golle <daniel@makrotopia.org>
19
 PKG_MAINTAINER:=Daniel Golle <daniel@makrotopia.org>
20
 PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME).$(PKG_VERSION)
20
 PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME).$(PKG_VERSION)
21
 
21
 

+ 4
- 8
utils/lvm2/patches/002-const-stdio.patch View File

1
-Index: LVM2.2.02.120/lib/commands/toolcontext.c
2
-===================================================================
3
---- LVM2.2.02.120.orig/lib/commands/toolcontext.c
4
-+++ LVM2.2.02.120/lib/commands/toolcontext.c
1
+--- a/lib/commands/toolcontext.c
2
++++ b/lib/commands/toolcontext.c
5
 @@ -1637,8 +1637,10 @@ struct cmd_context *create_toolcontext(u
3
 @@ -1637,8 +1637,10 @@ struct cmd_context *create_toolcontext(u
6
  				       unsigned threaded)
4
  				       unsigned threaded)
7
  {
5
  {
31
  	if (cmd->linebuffer) {
29
  	if (cmd->linebuffer) {
32
  		/* Reset stream buffering to defaults */
30
  		/* Reset stream buffering to defaults */
33
  		if (is_valid_fd(STDIN_FILENO) &&
31
  		if (is_valid_fd(STDIN_FILENO) &&
34
-Index: LVM2.2.02.120/tools/lvmcmdline.c
35
-===================================================================
36
---- LVM2.2.02.120.orig/tools/lvmcmdline.c
37
-+++ LVM2.2.02.120/tools/lvmcmdline.c
32
+--- a/tools/lvmcmdline.c
33
++++ b/tools/lvmcmdline.c
38
 @@ -1606,6 +1606,7 @@ int lvm_split(char *str, int *argc, char
34
 @@ -1606,6 +1606,7 @@ int lvm_split(char *str, int *argc, char
39
  /* Make sure we have always valid filedescriptors 0,1,2 */
35
  /* Make sure we have always valid filedescriptors 0,1,2 */
40
  static int _check_standard_fds(void)
36
  static int _check_standard_fds(void)

+ 2
- 4
utils/lvm2/patches/003-no-mallinfo.patch View File

1
-Index: LVM2.2.02.119/lib/mm/memlock.c
2
-===================================================================
3
---- LVM2.2.02.119.orig/lib/mm/memlock.c
4
-+++ LVM2.2.02.119/lib/mm/memlock.c
1
+--- a/lib/mm/memlock.c
2
++++ b/lib/mm/memlock.c
5
 @@ -161,12 +161,15 @@ static void _allocate_memory(void)
3
 @@ -161,12 +161,15 @@ static void _allocate_memory(void)
6
           *  memory on free(), this is good enough for our purposes.
4
           *  memory on free(), this is good enough for our purposes.
7
           */
5
           */