Explorar el Código

fswebcam: import from old packages feed

 - update to latest version (v20140113)
 - add license info
 - add myself as maintainer

Signed-off-by: Nicolas Thill <nico@openwrt.org>
Nicolas Thill hace 10 años
padre
commit
3a9be2aab8
Se han modificado 1 ficheros con 50 adiciones y 0 borrados
  1. 50
    0
      multimedia/fswebcam/Makefile

+ 50
- 0
multimedia/fswebcam/Makefile Ver fichero

@@ -0,0 +1,50 @@
1
+#
2
+# Copyright (C) 2010-2014 OpenWrt.org
3
+#
4
+# This is free software, licensed under the GNU General Public License v2.
5
+# See /LICENSE for more information.
6
+#
7
+
8
+include $(TOPDIR)/rules.mk
9
+
10
+PKG_NAME:=fswebcam
11
+PKG_VERSION:=20140113
12
+PKG_RELEASE:=1
13
+
14
+PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.xz
15
+PKG_SOURCE_URL:=http://www.firestorm.cx/fswebcam/files \
16
+	http://www.sanslogic.co.uk/fswebcam/files
17
+PKG_MD5SUM:=1bfdb21904e816f100370ec8f4df986b
18
+
19
+PKG_LICENSE:=GPL-2.0
20
+PKG_LICENSE_FILE:=LICENCE
21
+PKG_MAINTAINER:=Nicolas Thill <nico@openwrt.org>
22
+
23
+PKG_INSTALL:=1
24
+
25
+include $(INCLUDE_DIR)/package.mk
26
+
27
+define Package/fswebcam
28
+  SECTION:=multimedia
29
+  CATEGORY:=Multimedia
30
+  TITLE:=fswebcam
31
+  URL:=http://www.sanslogic.co.uk/fswebcam/
32
+  DEPENDS:=+libgd
33
+endef
34
+
35
+define Package/fswebcam/description
36
+  fswebcam is a neat and simple webcam app. It captures images from a V4L1/V4L2 compatible
37
+  device or file, averages them to reduce noise and draws a caption using the GD Graphics
38
+  Library which also handles compressing the image to PNG or JPEG. The resulting image
39
+  is saved to a file or sent to stdio where it can be piped to something like ncftpput or scp.
40
+endef
41
+
42
+EXTRA_CFLAGS+= $(TARGET_CPPFLAGS)
43
+EXTRA_LDFLAGS+= $(TARGET_LDFLAGS) -Wl,-rpath-link,$(STAGING_DIR)/usr/lib
44
+
45
+define Package/fswebcam/install
46
+	$(INSTALL_DIR) $(1)/usr/bin
47
+	$(CP) $(PKG_INSTALL_DIR)/usr/bin/fswebcam $(1)/usr/bin/
48
+endef
49
+
50
+$(eval $(call BuildPackage,fswebcam))