Browse Source

Merge pull request #1615 from mhaas/stunnel-5.20

stunnel: Update from 5.14 to 5.20
Steven Barth 9 years ago
parent
commit
3b3542cc5f

+ 2
- 2
net/stunnel/Makefile View File

@@ -8,7 +8,7 @@
8 8
 include $(TOPDIR)/rules.mk
9 9
 
10 10
 PKG_NAME:=stunnel
11
-PKG_VERSION:=5.14
11
+PKG_VERSION:=5.20
12 12
 PKG_RELEASE:=1
13 13
 
14 14
 PKG_LICENSE:=GPL-2.0+
@@ -17,7 +17,7 @@ PKG_LICENSE_FILES:=COPYING COPYRIGHT.GPL
17 17
 
18 18
 PKG_SOURCE_URL:=http://stunnel.cybermirror.org/archive/5.x/
19 19
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
20
-PKG_MD5SUM:=e716501960dc6856d80f92547298f724
20
+PKG_MD5SUM:=3264375026c2b496b5d258e243222de8
21 21
 
22 22
 PKG_FIXUP:=autoreconf
23 23
 PKG_INSTALL:=1

+ 0
- 25
net/stunnel/patches/010_fix_getnameinfo.patch View File

@@ -1,25 +0,0 @@
1
---- a/src/prototypes.h
2
-+++ b/src/prototypes.h
3
-@@ -590,7 +590,7 @@ extern GETNAMEINFO s_getnameinfo;
4
- 
5
- #endif /* USE_WIN32 */
6
- 
7
--int getnameinfo(const struct sockaddr *, int, char *, int, char *, int, int);
8
-+int getnameinfo(const struct sockaddr *, socklen_t, char *, socklen_t, char *, socklen_t, unsigned int);
9
- 
10
- #endif /* !defined HAVE_GETNAMEINFO */
11
- 
12
---- a/src/resolver.c
13
-+++ b/src/resolver.c
14
-@@ -538,8 +538,9 @@ const char *s_gai_strerror(int err) {
15
- /* implementation is limited to functionality needed by stunnel */
16
- 
17
- #ifndef HAVE_GETNAMEINFO
18
--int getnameinfo(const struct sockaddr *sa, int salen,
19
--    char *host, int hostlen, char *serv, int servlen, int flags) {
20
-+int getnameinfo(const struct sockaddr *sa, socklen_t salen,
21
-+    char *host, socklen_t hostlen, char *serv, socklen_t servlen,
22
-+    unsigned int flags) {
23
- 
24
- #if defined(USE_WIN32) && !defined(_WIN32_WCE)
25
-     if(s_getnameinfo)

+ 14
- 0
net/stunnel/patches/012-cron-without-pthread-fix.patch View File

@@ -0,0 +1,14 @@
1
+Index: stunnel-5.20/src/cron.c
2
+===================================================================
3
+--- stunnel-5.20.orig/src/cron.c
4
++++ stunnel-5.20/src/cron.c
5
+@@ -46,6 +46,9 @@ NOEXPORT void cron_thread(void *arg);
6
+ #endif
7
+ #if defined(USE_PTHREAD) || defined(USE_WIN32)
8
+ NOEXPORT void cron_worker(void);
9
++#endif
10
++
11
++#ifndef OPENSSL_NO_DH
12
+ NOEXPORT void cron_dh_param(void);
13
+ #endif
14
+