Browse Source

Copy openldap package from old repository

Signed-off-by: W. Michael Petullo <mike@flyn.org>
W. Michael Petullo 10 years ago
parent
commit
3c78eaff96

+ 150
- 0
libs/openldap/Makefile View File

@@ -0,0 +1,150 @@
1
+#
2
+# Copyright (C) 2006-2012 OpenWrt.org
3
+#
4
+# This is free software, licensed under the GNU General Public License v2.
5
+# See /LICENSE for more information.
6
+#
7
+
8
+include $(TOPDIR)/rules.mk
9
+
10
+PKG_NAME:=openldap
11
+PKG_VERSION:=2.4.39
12
+PKG_RELEASE:=1
13
+
14
+PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tgz
15
+PKG_SOURCE_URL:=ftp://ftp.openldap.org/pub/OpenLDAP/openldap-release/ \
16
+	ftp://sunsite.cnlab-switch.ch/mirror/OpenLDAP/openldap-release/ \
17
+	ftp://ftp.nl.uu.net/pub/unix/db/openldap/openldap-release/ \
18
+	ftp://ftp.plig.org/pub/OpenLDAP/openldap-release/
19
+PKG_MD5SUM:=b0d5ee4b252c841dec6b332d679cf943
20
+
21
+PKG_FIXUP:=autoreconf
22
+
23
+include $(INCLUDE_DIR)/package.mk
24
+
25
+define Package/openldap/Default
26
+  TITLE:=LDAP implementation
27
+  URL:=http://www.openldap.org/
28
+  MAINTAINER:=W. Michael Petullo <mike@flyn.org>
29
+endef
30
+
31
+define Package/openldap/Default/description
32
+	OpenLDAP Software is an open source implementation of the
33
+	Lightweight Directory Access Protocol (LDAP).
34
+endef
35
+
36
+define Package/libopenldap
37
+  $(call Package/openldap/Default)
38
+  SECTION:=libs
39
+  CATEGORY:=Libraries
40
+  DEPENDS:=+libopenssl +libsasl2 +libpthread
41
+  TITLE+= (libraries)
42
+endef
43
+
44
+define Package/libopenldap/description
45
+	$(call Package/openldap/Default/description)
46
+	This package contains the shared LDAP client libraries, needed by other programs.
47
+endef
48
+
49
+define Package/libopenldap/conffiles
50
+/etc/openldap/ldap.conf
51
+endef
52
+
53
+define Package/openldap-utils
54
+  $(call Package/openldap/Default)
55
+  SECTION:=utils
56
+  CATEGORY:=Utilities
57
+  DEPENDS:=+libopenldap
58
+  TITLE+= (utilities)
59
+endef
60
+
61
+define Package/openldap-utils/description
62
+	$(call Package/openldap/Default/description)
63
+	This package contains client programs required to access LDAP servers.
64
+endef
65
+
66
+define Package/openldap-server
67
+  $(call Package/openldap/Default)
68
+  SECTION:=net
69
+  CATEGORY:=Network
70
+  DEPENDS:=+libopenldap +libuuid
71
+  TITLE+= (server)
72
+endef
73
+
74
+define Package/openldap-server/description
75
+	$(call Package/openldap/Default/description)
76
+	This package contains server programs required to provide LDAP services.
77
+endef
78
+
79
+define Package/openldap-server/conffiles
80
+/etc/openldap/slapd.conf
81
+endef
82
+
83
+TARGET_CFLAGS += $(FPIC) -lpthread
84
+
85
+CONFIGURE_ARGS += \
86
+	--enable-shared \
87
+	--enable-static \
88
+	--disable-debug \
89
+	--enable-dynamic \
90
+	--enable-syslog \
91
+	--disable-local \
92
+	--disable-slurpd \
93
+	--with-cyrus-sasl \
94
+	--without-fetch \
95
+	--with-threads \
96
+	--with-tls \
97
+	--with-yielding_select="yes" \
98
+	--without-cyrus-sasl \
99
+	--without-threads \
100
+	--without-tls \
101
+	--enable-null \
102
+	--disable-bdb \
103
+	--disable-hdb \
104
+	--disable-monitor \
105
+	--disable-relay
106
+
107
+define Build/Compile
108
+	$(MAKE) -C $(PKG_BUILD_DIR) \
109
+		DESTDIR="$(PKG_INSTALL_DIR)" \
110
+		HOSTCC="$(HOSTCC)" \
111
+		depend all install
112
+endef
113
+
114
+define Build/InstallDev
115
+	$(INSTALL_DIR) $(1)/usr/include
116
+	$(INSTALL_DATA) $(PKG_INSTALL_DIR)/usr/include/{lber,ldap}*.h $(1)/usr/include/
117
+	$(INSTALL_DIR) $(1)/usr/lib/
118
+	$(CP) $(PKG_INSTALL_DIR)/usr/lib/lib{lber,ldap}*.{a,so*} $(1)/usr/lib/
119
+endef
120
+
121
+define Package/libopenldap/install
122
+	$(INSTALL_DIR) $(1)/etc/openldap
123
+	$(INSTALL_CONF) $(PKG_INSTALL_DIR)/etc/openldap/ldap.conf $(1)/etc/openldap/
124
+	$(INSTALL_DIR) $(1)/usr/lib
125
+	$(CP) $(PKG_INSTALL_DIR)/usr/lib/lib{lber,ldap}*.so.* $(1)/usr/lib/
126
+endef
127
+
128
+define Package/openldap-utils/install
129
+	$(INSTALL_DIR) $(1)/usr/bin
130
+	$(CP) $(PKG_INSTALL_DIR)/usr/bin/ldap* $(1)/usr/bin/
131
+endef
132
+
133
+define Package/openldap-server/install
134
+	$(INSTALL_DIR) $(1)/etc/init.d
135
+	$(INSTALL_BIN) ./files/ldap.init $(1)/etc/init.d/ldap
136
+	$(INSTALL_DIR) $(1)/etc/openldap/schema
137
+	$(INSTALL_CONF) $(PKG_INSTALL_DIR)/etc/openldap/schema/* $(1)/etc/openldap/schema/
138
+	$(INSTALL_CONF) $(PKG_INSTALL_DIR)/etc/openldap/slapd.conf $(1)/etc/openldap/
139
+	$(INSTALL_DIR) $(1)/usr/sbin
140
+	# XXX: OpenLDAP installs slapd into libexecdir, not sbindir:
141
+	$(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/lib/slapd $(1)/usr/sbin/
142
+	# XXX: switch default backend to ldif, since bdb is disabled
143
+	$(SED) 's|^\(database\)\([ \t]\+\)bdb|\1\2ldif|g' \
144
+	    -e 's|^\(index\)|#\1|g' \
145
+	    $(1)/etc/openldap/slapd.conf
146
+endef
147
+
148
+$(eval $(call BuildPackage,libopenldap))
149
+$(eval $(call BuildPackage,openldap-utils))
150
+$(eval $(call BuildPackage,openldap-server))

+ 19
- 0
libs/openldap/files/ldap.init View File

@@ -0,0 +1,19 @@
1
+#!/bin/sh /etc/rc.common
2
+# Copyright (C) 2009-2011 OpenWrt.org
3
+
4
+START=60
5
+
6
+SERVICE_USE_PID=1
7
+
8
+start() {
9
+	mkdir -m 0755 -p /var/openldap-data
10
+	service_start /usr/sbin/slapd
11
+}
12
+
13
+stop() {
14
+	service_stop /usr/sbin/slapd
15
+}
16
+
17
+reload() {
18
+	service_reload /usr/sbin/slapd
19
+}

+ 323
- 0
libs/openldap/patches/001-automake-compat.patch View File

@@ -0,0 +1,323 @@
1
+--- /dev/null
2
++++ b/Makefile.am
3
+@@ -0,0 +1 @@
4
++SUBDIRS = include libraries clients servers tests doc
5
+--- a/libraries/Makefile.in
6
++++ b/libraries/Makefile.in
7
+@@ -13,6 +13,8 @@
8
+ ## top-level directory of the distribution or, alternatively, at
9
+ ## <http://www.OpenLDAP.org/license.html>.
10
+ 
11
++SHELL = @SHELL@
12
++
13
+ SUBDIRS= \
14
+ 	liblutil \
15
+ 	liblber \
16
+--- a/libraries/liblber/Makefile.in
17
++++ b/libraries/liblber/Makefile.in
18
+@@ -13,6 +13,8 @@
19
+ ## top-level directory of the distribution or, alternatively, at
20
+ ## <http://www.OpenLDAP.org/license.html>.
21
+ 
22
++SHELL = @SHELL@
23
++
24
+ LIBRARY = liblber.la
25
+ 
26
+ NT_SRCS = nt_err.c
27
+--- a/libraries/libldap/Makefile.in
28
++++ b/libraries/libldap/Makefile.in
29
+@@ -13,6 +13,8 @@
30
+ ## top-level directory of the distribution or, alternatively, at
31
+ ## <http://www.OpenLDAP.org/license.html>.
32
+ 
33
++SHELL = @SHELL@
34
++
35
+ LIBRARY = libldap.la
36
+ 
37
+ PROGRAMS = apitest dntest ftest ltest urltest
38
+--- a/libraries/libldap_r/Makefile.in
39
++++ b/libraries/libldap_r/Makefile.in
40
+@@ -13,6 +13,8 @@
41
+ ## top-level directory of the distribution or, alternatively, at
42
+ ## <http://www.OpenLDAP.org/license.html>.
43
+ 
44
++SHELL = @SHELL@
45
++
46
+ LIBRARY = libldap_r.la
47
+ 
48
+ PROGRAMS = apitest ltest
49
+--- a/libraries/liblunicode/Makefile.in
50
++++ b/libraries/liblunicode/Makefile.in
51
+@@ -13,6 +13,8 @@
52
+ ## top-level directory of the distribution or, alternatively, at
53
+ ## <http://www.OpenLDAP.org/license.html>.
54
+ 
55
++SHELL = @SHELL@
56
++
57
+ LIBRARY = liblunicode.a
58
+ 
59
+ XXDIR = $(srcdir)/ucdata/
60
+--- a/libraries/liblutil/Makefile.in
61
++++ b/libraries/liblutil/Makefile.in
62
+@@ -13,6 +13,8 @@
63
+ ## top-level directory of the distribution or, alternatively, at
64
+ ## <http://www.OpenLDAP.org/license.html>.
65
+ 
66
++SHELL = @SHELL@
67
++
68
+ LIBRARY	= liblutil.a
69
+ PROGRAM = testavl
70
+ 
71
+--- a/libraries/librewrite/Makefile.in
72
++++ b/libraries/librewrite/Makefile.in
73
+@@ -16,6 +16,8 @@
74
+ ## Copyright 2000-2001 Pierangelo Masarati <ando@sys-net.it>
75
+ ##
76
+ 
77
++SHELL = @SHELL@
78
++
79
+ SRCS = config.c context.c info.c ldapmap.c map.c params.c rule.c \
80
+ 	session.c subst.c var.c xmap.c \
81
+ 	parse.c rewrite.c
82
+--- a/clients/tools/Makefile.in
83
++++ b/clients/tools/Makefile.in
84
+@@ -13,6 +13,8 @@
85
+ ## top-level directory of the distribution or, alternatively, at
86
+ ## <http://www.OpenLDAP.org/license.html>.
87
+ 
88
++SHELL = @SHELL@
89
++
90
+ SRCS	= ldapsearch.c ldapmodify.c ldapdelete.c ldapmodrdn.c \
91
+ 		ldappasswd.c ldapwhoami.c ldapcompare.c \
92
+ 		ldapexop.c ldapurl.c common.c
93
+--- a/servers/slapd/Makefile.in
94
++++ b/servers/slapd/Makefile.in
95
+@@ -13,6 +13,8 @@
96
+ ## top-level directory of the distribution or, alternatively, at
97
+ ## <http://www.OpenLDAP.org/license.html>.
98
+ 
99
++SHELL = @SHELL@
100
++
101
+ SLAPTOOLS=slapadd slapcat slapdn slapindex slappasswd slaptest slapauth slapacl slapschema
102
+ PROGRAMS=slapd $(SLAPTOOLS)
103
+ XPROGRAMS=sslapd libbackends.a .backend liboverlays.a
104
+--- a/servers/slapd/overlays/Makefile.in
105
++++ b/servers/slapd/overlays/Makefile.in
106
+@@ -13,6 +13,8 @@
107
+ ## top-level directory of the distribution or, alternatively, at
108
+ ## <http://www.OpenLDAP.org/license.html>.
109
+ 
110
++SHELL = @SHELL@
111
++
112
+ SRCS = overlays.c \
113
+ 	accesslog.c \
114
+ 	auditlog.c \
115
+--- a/tests/progs/Makefile.in
116
++++ b/tests/progs/Makefile.in
117
+@@ -13,6 +13,8 @@
118
+ ## top-level directory of the distribution or, alternatively, at
119
+ ## <http://www.OpenLDAP.org/license.html>.
120
+ 
121
++SHELL = @SHELL@
122
++
123
+ PROGRAMS = slapd-tester slapd-search slapd-read slapd-addel slapd-modrdn \
124
+ 		slapd-modify slapd-bind slapd-mtread ldif-filter
125
+ 
126
+--- a/servers/slapd/back-bdb/Makefile.in
127
++++ b/servers/slapd/back-bdb/Makefile.in
128
+@@ -13,6 +13,8 @@
129
+ ## top-level directory of the distribution or, alternatively, at
130
+ ## <http://www.OpenLDAP.org/license.html>.
131
+ 
132
++SHELL = @SHELL@
133
++
134
+ SRCS = init.c tools.c config.c \
135
+ 	add.c bind.c compare.c delete.c modify.c modrdn.c search.c \
136
+ 	extended.c referral.c operational.c \
137
+--- a/servers/slapd/back-dnssrv/Makefile.in
138
++++ b/servers/slapd/back-dnssrv/Makefile.in
139
+@@ -18,6 +18,8 @@
140
+ #  The DNSSRV backend was written by Kurt D. Zeilenga.
141
+ #
142
+ 
143
++SHELL = @SHELL@
144
++
145
+ SRCS	= init.c bind.c search.c config.c referral.c
146
+ OBJS	= init.lo bind.lo search.lo config.lo referral.lo
147
+ 
148
+--- a/servers/slapd/back-hdb/Makefile.in
149
++++ b/servers/slapd/back-hdb/Makefile.in
150
+@@ -15,6 +15,8 @@
151
+ #
152
+ ## Copyright 2003 Howard Chu @ Symas Corp. See master COPYRIGHT file for terms.
153
+ 
154
++SHELL = @SHELL@
155
++
156
+ XXDIR = $(srcdir)/../back-bdb
157
+ 
158
+ XXSRCS = init.c tools.c config.c \
159
+--- a/servers/slapd/back-ldap/Makefile.in
160
++++ b/servers/slapd/back-ldap/Makefile.in
161
+@@ -13,6 +13,8 @@
162
+ ## top-level directory of the distribution or, alternatively, at
163
+ ## <http://www.OpenLDAP.org/license.html>.
164
+ 
165
++SHELL = @SHELL@
166
++
167
+ SRCS	= init.c config.c search.c bind.c unbind.c add.c compare.c \
168
+ 		delete.c modify.c modrdn.c extended.c chain.c \
169
+ 		distproc.c monitor.c pbind.c
170
+--- a/servers/slapd/back-ldif/Makefile.in
171
++++ b/servers/slapd/back-ldif/Makefile.in
172
+@@ -13,6 +13,8 @@
173
+ ## top-level directory of the distribution or, alternatively, at
174
+ ## <http://www.OpenLDAP.org/license.html>.
175
+ 
176
++SHELL = @SHELL@
177
++
178
+ SRCS = ldif.c
179
+ OBJS = ldif.lo
180
+ 
181
+--- a/servers/slapd/back-mdb/Makefile.in
182
++++ b/servers/slapd/back-mdb/Makefile.in
183
+@@ -13,6 +13,8 @@
184
+ ## top-level directory of the distribution or, alternatively, at
185
+ ## <http://www.OpenLDAP.org/license.html>.
186
+ 
187
++SHELL = @SHELL@
188
++
189
+ SRCS = init.c tools.c config.c \
190
+ 	add.c bind.c compare.c delete.c modify.c modrdn.c search.c \
191
+ 	extended.c operational.c \
192
+--- a/servers/slapd/back-meta/Makefile.in
193
++++ b/servers/slapd/back-meta/Makefile.in
194
+@@ -13,6 +13,8 @@
195
+ ## top-level directory of the distribution or, alternatively, at
196
+ ## <http://www.OpenLDAP.org/license.html>.
197
+ 
198
++SHELL = @SHELL@
199
++
200
+ SRCS	= init.c config.c search.c bind.c unbind.c add.c compare.c \
201
+ 		delete.c modify.c modrdn.c suffixmassage.c map.c \
202
+ 		conn.c candidates.c dncache.c
203
+--- a/servers/slapd/back-monitor/Makefile.in
204
++++ b/servers/slapd/back-monitor/Makefile.in
205
+@@ -13,6 +13,8 @@
206
+ ## top-level directory of the distribution or, alternatively, at
207
+ ## <http://www.OpenLDAP.org/license.html>.
208
+ 
209
++SHELL = @SHELL@
210
++
211
+ SRCS = init.c search.c compare.c modify.c bind.c \
212
+ 	operational.c \
213
+ 	cache.c entry.c \
214
+--- a/servers/slapd/back-ndb/Makefile.in
215
++++ b/servers/slapd/back-ndb/Makefile.in
216
+@@ -17,6 +17,8 @@
217
+ ## This work was initially developed by Howard Chu for inclusion
218
+ ## in OpenLDAP Software. This work was sponsored by MySQL.
219
+ 
220
++SHELL = @SHELL@
221
++
222
+ SRCS = init.cpp tools.cpp config.cpp ndbio.cpp \
223
+ 	add.cpp bind.cpp compare.cpp delete.cpp modify.cpp modrdn.cpp search.cpp
224
+ 
225
+--- a/servers/slapd/back-null/Makefile.in
226
++++ b/servers/slapd/back-null/Makefile.in
227
+@@ -13,6 +13,8 @@
228
+ ## top-level directory of the distribution or, alternatively, at
229
+ ## <http://www.OpenLDAP.org/license.html>.
230
+ 
231
++SHELL = @SHELL@
232
++
233
+ SRCS = null.c
234
+ OBJS = null.lo
235
+ 
236
+--- a/servers/slapd/back-passwd/Makefile.in
237
++++ b/servers/slapd/back-passwd/Makefile.in
238
+@@ -13,6 +13,8 @@
239
+ ## top-level directory of the distribution or, alternatively, at
240
+ ## <http://www.OpenLDAP.org/license.html>.
241
+ 
242
++SHELL = @SHELL@
243
++
244
+ SRCS	= search.c config.c init.c
245
+ OBJS	= search.lo config.lo init.lo
246
+ 
247
+--- a/servers/slapd/back-perl/Makefile.in
248
++++ b/servers/slapd/back-perl/Makefile.in
249
+@@ -14,6 +14,8 @@
250
+ ## top-level directory of the distribution or, alternatively, at
251
+ ## <http://www.OpenLDAP.org/license.html>.
252
+ 
253
++SHELL = @SHELL@
254
++
255
+ SRCS	= init.c search.c close.c config.c bind.c compare.c \
256
+ 		modify.c add.c modrdn.c delete.c
257
+ OBJS	= init.lo search.lo close.lo config.lo bind.lo compare.lo \
258
+--- a/servers/slapd/back-relay/Makefile.in
259
++++ b/servers/slapd/back-relay/Makefile.in
260
+@@ -13,6 +13,8 @@
261
+ ## top-level directory of the distribution or, alternatively, at
262
+ ## <http://www.OpenLDAP.org/license.html>.
263
+ 
264
++SHELL = @SHELL@
265
++
266
+ SRCS	= init.c op.c
267
+ OBJS	= init.lo op.lo
268
+ 
269
+--- a/servers/slapd/back-shell/Makefile.in
270
++++ b/servers/slapd/back-shell/Makefile.in
271
+@@ -13,6 +13,8 @@
272
+ ## top-level directory of the distribution or, alternatively, at
273
+ ## <http://www.OpenLDAP.org/license.html>.
274
+ 
275
++SHELL = @SHELL@
276
++
277
+ SRCS	= init.c config.c fork.c search.c bind.c unbind.c add.c \
278
+ 		delete.c modify.c modrdn.c compare.c result.c
279
+ OBJS	= init.lo config.lo fork.lo search.lo bind.lo unbind.lo add.lo \
280
+--- a/servers/slapd/back-sock/Makefile.in
281
++++ b/servers/slapd/back-sock/Makefile.in
282
+@@ -17,6 +17,8 @@
283
+ ## This work was initially developed by Brian Candler for inclusion
284
+ ## in OpenLDAP Software.
285
+ 
286
++SHELL = @SHELL@
287
++
288
+ SRCS	= init.c config.c opensock.c search.c bind.c unbind.c add.c \
289
+ 		delete.c modify.c modrdn.c compare.c result.c
290
+ OBJS	= init.lo config.lo opensock.lo search.lo bind.lo unbind.lo add.lo \
291
+--- a/servers/slapd/back-sql/Makefile.in
292
++++ b/servers/slapd/back-sql/Makefile.in
293
+@@ -13,6 +13,8 @@
294
+ ## top-level directory of the distribution or, alternatively, at
295
+ ## <http://www.OpenLDAP.org/license.html>.
296
+ 
297
++SHELL = @SHELL@
298
++
299
+ SRCS	= init.c config.c search.c bind.c compare.c operational.c \
300
+ 		entry-id.c schema-map.c sql-wrap.c modify.c util.c \
301
+ 		add.c delete.c modrdn.c api.c
302
+--- a/servers/slapd/shell-backends/Makefile.in
303
++++ b/servers/slapd/shell-backends/Makefile.in
304
+@@ -13,6 +13,8 @@
305
+ ## top-level directory of the distribution or, alternatively, at
306
+ ## <http://www.OpenLDAP.org/license.html>.
307
+ 
308
++SHELL = @SHELL@
309
++
310
+ PROGRAMS = passwd-shell
311
+ 
312
+ SRCS = passwd-shell.c shellutil.c
313
+--- a/servers/slapd/slapi/Makefile.in
314
++++ b/servers/slapd/slapi/Makefile.in
315
+@@ -14,6 +14,8 @@
316
+ ## top-level directory of the distribution or, alternatively, at
317
+ ## <http://www.OpenLDAP.org/license.html>.
318
+ 
319
++SHELL = @SHELL@
320
++
321
+ LIBRARY = libslapi.la
322
+ 
323
+ #all-common: $(LIBRARY) $(PROGRAMS)

+ 26
- 0
libs/openldap/patches/020-autofs-schema.patch View File

@@ -0,0 +1,26 @@
1
+--- /dev/null
2
++++ b/servers/slapd/schema/autofs.schema
3
+@@ -0,0 +1,23 @@
4
++attributetype ( 1.3.6.1.1.1.1.31 NAME 'automountMapName'
5
++	DESC 'Automount map name'
6
++	EQUALITY caseExactMatch
7
++	SYNTAX 1.3.6.1.4.1.1466.115.121.1.15 SINGLE-VALUE )
8
++
9
++attributetype ( 1.3.6.1.1.1.1.32 NAME 'automountKey'
10
++	DESC 'Automount key value'
11
++	EQUALITY caseExactMatch
12
++	SYNTAX 1.3.6.1.4.1.1466.115.121.1.15 SINGLE-VALUE )
13
++
14
++attributetype ( 1.3.6.1.1.1.1.33 NAME 'automountInformation'
15
++	DESC 'Automount information'
16
++	EQUALITY caseExactMatch
17
++	SYNTAX 1.3.6.1.4.1.1466.115.121.1.15 SINGLE-VALUE )
18
++
19
++objectclass ( 1.3.6.1.1.1.2.16 NAME 'automountMap' SUP top STRUCTURAL
20
++	MUST ( automountMapName )
21
++	MAY ( description ) )
22
++
23
++objectclass ( 1.3.6.1.1.1.2.17 NAME 'automount' SUP top STRUCTURAL
24
++	DESC 'Automount'
25
++	MUST ( automountKey $ automountInformation )
26
++	MAY description )

+ 22
- 0
libs/openldap/patches/750-no-strip.patch View File

@@ -0,0 +1,22 @@
1
+--- a/clients/tools/Makefile.in
2
++++ b/clients/tools/Makefile.in
3
+@@ -122,7 +122,7 @@ install-local:	FORCE
4
+ 	-$(MKDIR) $(DESTDIR)$(bindir)
5
+ 	@(								\
6
+ 	    for prg in $(PROGRAMS); do					\
7
+-		$(LTINSTALL) $(INSTALLFLAGS) $(STRIP) -m 755 $$prg$(EXEEXT)	\
8
++		$(LTINSTALL) $(INSTALLFLAGS) -m 755 $$prg$(EXEEXT)	\
9
+ 		    $(DESTDIR)$(bindir);				\
10
+ 	    done							\
11
+ 	)
12
+--- a/servers/slapd/Makefile.in
13
++++ b/servers/slapd/Makefile.in
14
+@@ -380,7 +380,7 @@ install-local-srv: install-slapd install
15
+ install-slapd: FORCE
16
+ 	-$(MKDIR) $(DESTDIR)$(libexecdir)
17
+ 	-$(MKDIR) $(DESTDIR)$(localstatedir)/run
18
+-	$(LTINSTALL) $(INSTALLFLAGS) $(STRIP) -m 755 \
19
++	$(LTINSTALL) $(INSTALLFLAGS) -m 755 \
20
+ 		slapd$(EXEEXT) $(DESTDIR)$(libexecdir)
21
+ 	@for i in $(SUBDIRS); do \
22
+ 	    if test -d $$i && test -f $$i/Makefile ; then \