|
@@ -0,0 +1,39 @@
|
|
1
|
+diff --git a/configure.ac b/configure.ac
|
|
2
|
+index 8d47eb9..69eeed8 100644
|
|
3
|
+--- a/configure.ac
|
|
4
|
++++ b/configure.ac
|
|
5
|
+@@ -117,7 +117,6 @@ OVS_CHECK_XENSERVER_VERSION
|
|
6
|
+ OVS_CHECK_GROFF
|
|
7
|
+ OVS_CHECK_GNU_MAKE
|
|
8
|
+ OVS_CHECK_TLS
|
|
9
|
+-OVS_CHECK_ATOMIC_LIBS
|
|
10
|
+ OVS_CHECK_GCC4_ATOMICS
|
|
11
|
+ OVS_CHECK_ATOMIC_ALWAYS_LOCK_FREE(1)
|
|
12
|
+ OVS_CHECK_ATOMIC_ALWAYS_LOCK_FREE(2)
|
|
13
|
+diff --git a/lib/netdev-linux.c b/lib/netdev-linux.c
|
|
14
|
+index 9b2e74f..70126bb 100644
|
|
15
|
+--- a/lib/netdev-linux.c
|
|
16
|
++++ b/lib/netdev-linux.c
|
|
17
|
+@@ -40,7 +40,9 @@
|
|
18
|
+ #include <netpacket/packet.h>
|
|
19
|
+ #include <net/if.h>
|
|
20
|
+ #include <net/if_arp.h>
|
|
21
|
++#if defined(__UCLIBC__) || defined(__GLIBC__)
|
|
22
|
+ #include <net/if_packet.h>
|
|
23
|
++#endif
|
|
24
|
+ #include <net/route.h>
|
|
25
|
+ #include <netinet/in.h>
|
|
26
|
+ #include <poll.h>
|
|
27
|
+diff --git a/lib/ovs-atomic.h b/lib/ovs-atomic.h
|
|
28
|
+index 9ead907..86d3341 100644
|
|
29
|
+--- a/lib/ovs-atomic.h
|
|
30
|
++++ b/lib/ovs-atomic.h
|
|
31
|
+@@ -325,8 +325,6 @@
|
|
32
|
+ #include "ovs-atomic-clang.h"
|
|
33
|
+ #elif HAVE_STDATOMIC_H
|
|
34
|
+ #include "ovs-atomic-c11.h"
|
|
35
|
+- #elif __GNUC__ >= 4 && __GNUC_MINOR__ >= 7
|
|
36
|
+- #include "ovs-atomic-gcc4.7+.h"
|
|
37
|
+ #elif __GNUC__ && defined(__x86_64__)
|
|
38
|
+ #include "ovs-atomic-x86_64.h"
|
|
39
|
+ #elif __GNUC__ && defined(__i386__)
|