Browse Source

Merge pull request #140 from roger-/motion

motion: add from old packages, add myself as maintainer
sbyx 10 years ago
parent
commit
3cc4fb7b47
2 changed files with 72 additions and 0 deletions
  1. 53
    0
      multimedia/motion/Makefile
  2. 19
    0
      multimedia/motion/patches/002-honor_cppflags.patch

+ 53
- 0
multimedia/motion/Makefile View File

@@ -0,0 +1,53 @@
1
+#
2
+# Copyright (C) 2008-2011 OpenWrt.org
3
+#
4
+# This is free software, licensed under the GNU General Public License v2.
5
+# See /LICENSE for more information.
6
+#
7
+
8
+include $(TOPDIR)/rules.mk
9
+
10
+PKG_NAME:=motion
11
+PKG_VERSION:=20110826-051001
12
+PKG_RELEASE:=2
13
+PKG_MAINTAINER:=Roger D <rogerdammit@gmail.com>
14
+
15
+PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
16
+PKG_SOURCE_URL:=http://www.lavrsen.dk/sources/motion-daily \
17
+		@SF/motion
18
+PKG_MD5SUM:=e703fce57ae2215cb05f25e3027f5818
19
+
20
+PKG_INSTALL:=1
21
+
22
+include $(INCLUDE_DIR)/package.mk
23
+
24
+define Package/motion
25
+  SECTION:=multimedia
26
+  CATEGORY:=Multimedia
27
+  DEPENDS:=+libjpeg +libpthread
28
+  TITLE:=webcam motion sensing and logging
29
+  URL:=http://www.lavrsen.dk/twiki/bin/view/Motion/WebHome
30
+endef
31
+
32
+define Package/motion/conffiles
33
+/etc/motion.conf
34
+endef
35
+
36
+CONFIGURE_ARGS+= \
37
+	--without-optimizecpu \
38
+	--without-ffmpeg \
39
+	--without-jpeg-mmx \
40
+	--without-sdl \
41
+	--without-mysql \
42
+	--without-pgsql \
43
+	--without-sqlite3 \
44
+
45
+define Package/motion/install
46
+	$(INSTALL_DIR) $(1)/etc
47
+	$(CP) $(PKG_INSTALL_DIR)/etc/motion-dist.conf $(1)/etc/motion.conf
48
+	$(INSTALL_DIR) $(1)/usr/bin
49
+	$(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/bin/motion $(1)/usr/bin/
50
+
51
+endef
52
+
53
+$(eval $(call BuildPackage,motion))

+ 19
- 0
multimedia/motion/patches/002-honor_cppflags.patch View File

@@ -0,0 +1,19 @@
1
+--- a/Makefile.in
2
++++ b/Makefile.in
3
+@@ -31,6 +31,7 @@ examplesdir = $(datadir)/@PACKAGE_NAME@-
4
+ # install.                                                                     #
5
+ ################################################################################
6
+ CFLAGS       = @CFLAGS@ -Wall -DVERSION=\"@PACKAGE_VERSION@\" -Dsysconfdir=\"$(sysconfdir)\" 
7
++CPPFLAGS     = @CPPFLAGS@
8
+ LDFLAGS      = @LDFLAGS@
9
+ LIBS         = @LIBS@ 
10
+ VIDEO_OBJ    = @VIDEO@
11
+@@ -118,7 +119,7 @@ endif
12
+ ################################################################################
13
+ $(DEPEND_FILE): *.h $(SRC)
14
+ 	@echo "Generating dependencies, please wait..."
15
+-	@$(CC) $(CFLAGS) -M $(SRC) > .tmp
16
++	@$(CC) $(CFLAGS) $(CPPFLAGS) -M $(SRC) > .tmp
17
+ 	@mv -f .tmp $(DEPEND_FILE)
18
+ 	@echo
19
+