|
@@ -0,0 +1,56 @@
|
|
1
|
+#
|
|
2
|
+# Copyright (C) 2006-2015 OpenWrt.org
|
|
3
|
+#
|
|
4
|
+# This is free software, licensed under the GNU General Public License v2.
|
|
5
|
+# See /LICENSE for more information.
|
|
6
|
+#
|
|
7
|
+
|
|
8
|
+include $(TOPDIR)/rules.mk
|
|
9
|
+
|
|
10
|
+PKG_NAME:=zope.interface
|
|
11
|
+PKG_VERSION:=4.1.3
|
|
12
|
+PKG_RELEASE:=1
|
|
13
|
+
|
|
14
|
+PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
|
|
15
|
+PKG_SOURCE_URL:=https://pypi.python.org/packages/source/z/zope.interface
|
|
16
|
+PKG_MD5SUM:=9ae3d24c0c7415deb249dd1a132f0f79
|
|
17
|
+
|
|
18
|
+PKG_BUILD_DEPENDS:=python python-setuptools
|
|
19
|
+
|
|
20
|
+PKG_LICENSE:=ZPL-2.1
|
|
21
|
+PKG_LICENSE_FILES:=LICENSE.txt
|
|
22
|
+PKG_MAINTAINER:=Jeffery To <jeffery.to@gmail.com>
|
|
23
|
+
|
|
24
|
+include $(INCLUDE_DIR)/package.mk
|
|
25
|
+$(call include_mk, python-package.mk)
|
|
26
|
+
|
|
27
|
+define Package/zope-interface
|
|
28
|
+ SECTION:=lang
|
|
29
|
+ CATEGORY:=Languages
|
|
30
|
+ SUBMENU:=Python
|
|
31
|
+ TITLE:=Zope interface
|
|
32
|
+ URL:=https://github.com/zopefoundation/zope.interface
|
|
33
|
+ DEPENDS:=+python-light
|
|
34
|
+endef
|
|
35
|
+
|
|
36
|
+define Package/zope-interface/description
|
|
37
|
+This package provides an implementation of "object interfaces" for
|
|
38
|
+Python. Interfaces are a mechanism for labeling objects as conforming to
|
|
39
|
+a given API or contract. So, this package can be considered as
|
|
40
|
+implementation of the Design By Contract methodology support in Python.
|
|
41
|
+endef
|
|
42
|
+
|
|
43
|
+define PyPackage/zope-interface/filespec
|
|
44
|
++|$(PYTHON_PKG_DIR)
|
|
45
|
+-|$(PYTHON_PKG_DIR)/zope/interface/common/tests
|
|
46
|
+-|$(PYTHON_PKG_DIR)/zope/interface/tests
|
|
47
|
+endef
|
|
48
|
+
|
|
49
|
+define Build/Compile
|
|
50
|
+ $(call Build/Compile/PyMod,, \
|
|
51
|
+ install --prefix="/usr" --root="$(PKG_INSTALL_DIR)" --no-compile, \
|
|
52
|
+ )
|
|
53
|
+endef
|
|
54
|
+
|
|
55
|
+$(eval $(call PyPackage,zope-interface))
|
|
56
|
+$(eval $(call BuildPackage,zope-interface))
|