Browse Source

linknx: fix musl compatibility

Signed-off-by: Othmar Truniger <github@truniger.ch>
Othmar Truniger 9 years ago
parent
commit
3cf6ae0fb1
3 changed files with 23 additions and 1 deletions
  1. 2
    1
      net/linknx/Makefile
  2. 10
    0
      net/linknx/patches/010-musl-compat
  3. 11
    0
      net/linknx/patches/012-fix-linknx.cpp

+ 2
- 1
net/linknx/Makefile View File

@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
9 9
 
10 10
 PKG_NAME:=linknx
11 11
 PKG_VERSION:=0.0.1.32
12
-PKG_RELEASE:=6
12
+PKG_RELEASE:=7
13 13
 PKG_MD5SUM:=7ecc1208f59bceb05068c752b2250b63
14 14
 
15 15
 PKG_MAINTAINER:=Othmar Truniger <github@truniger.ch>
@@ -18,6 +18,7 @@ PKG_LICENSE:=GPL-2.0+
18 18
 PKG_SOURCE_URL:=@SF/linknx
19 19
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
20 20
 PKG_BUILD_DEPENDS:=argp-standalone
21
+PKG_FORTIFY_SOURCE:=1
21 22
 
22 23
 include $(INCLUDE_DIR)/package.mk
23 24
 

+ 10
- 0
net/linknx/patches/010-musl-compat View File

@@ -0,0 +1,10 @@
1
+--- a/src/eibclient.c	2007-10-11 01:55:31.000000000 +0200
2
++++ b/src/eibclient.c	2015-06-27 22:18:01.433296921 +0200
3
+@@ -32,6 +32,7 @@
4
+ #include <netinet/in.h>
5
+ #include <netdb.h>
6
+ #include <errno.h>
7
++#include <string.h>
8
+ 
9
+ #include "config.h"
10
+ 

+ 11
- 0
net/linknx/patches/012-fix-linknx.cpp View File

@@ -0,0 +1,11 @@
1
+--- a/src/linknx.cpp	2012-06-04 22:12:13.000000000 +0200
2
++++ b/src/linknx.cpp	2015-06-27 22:35:23.705721355 +0200
3
+@@ -136,7 +136,7 @@
4
+     if (errno)
5
+         printf (": %s\n", strerror (errno));
6
+     else
7
+-        printf ("\n", strerror (errno));
8
++        printf ("\n");
9
+     exit (1);
10
+ }
11
+