Browse Source

add engine_pkcs11

This adds support for using PKCS#11 modules (such as opensc_pkcs11)
as an OpenSSL engine for RSA.

Signed-off-by: Daniel Golle <daniel@makrotopia.org>
Daniel Golle 10 years ago
parent
commit
3d44a5520c
1 changed files with 47 additions and 0 deletions
  1. 47
    0
      libs/engine_pkcs11/Makefile

+ 47
- 0
libs/engine_pkcs11/Makefile View File

@@ -0,0 +1,47 @@
1
+#
2
+# Copyright (C) 2011-2014 OpenWrt.org
3
+#
4
+# This is free software, licensed under the GNU General Public License v2.
5
+# See /LICENSE for more information.
6
+#
7
+
8
+include $(TOPDIR)/rules.mk
9
+
10
+PKG_NAME:=engine_pkcs11
11
+PKG_VERSION:=20131021
12
+PKG_RELEASE:=1
13
+PKG_MAINTAINER:=Daniel Golle <daniel@makrotopia.org>
14
+
15
+PKG_RELEASE=$(PKG_SOURCE_VERSION)
16
+
17
+PKG_SOURCE_PROTO:=git
18
+PKG_SOURCE_URL:=https://github.com/OpenSC/engine_pkcs11.git
19
+PKG_SOURCE_SUBDIR:=$(PKG_NAME)-$(PKG_VERSION)
20
+PKG_SOURCE_VERSION:=5abdc7e0d6d519d2514e3eccc116b335bc427254
21
+PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
22
+PKG_FIXUP:=libtool
23
+
24
+PKG_CONFIG_DEPENDS:=CONFIG_OPENSSL_ENGINE
25
+
26
+PKG_INSTALL:=1
27
+
28
+include $(INCLUDE_DIR)/package.mk
29
+
30
+define Package/engine_pkcs11
31
+  SECTION:=libs
32
+  CATEGORY:=Libraries
33
+  TITLE:=PKCS#11 OpenSSL engine
34
+  URL:=https://www.opensc-project.org/opensc/wiki/
35
+  DEPENDS:=+libopenssl +libp11
36
+endef
37
+
38
+define Package/engine_pkcs11/description
39
+  engine_pkcs11 is an implementation of OpenSSL engine interface.
40
+endef
41
+
42
+define Package/engine_pkcs11/install
43
+	$(INSTALL_DIR) $(1)/usr/lib/engines
44
+	$(CP) $(PKG_INSTALL_DIR)/usr/lib/engines/engine_pkcs11.so $(1)/usr/lib/engines/
45
+endef
46
+
47
+$(eval $(call BuildPackage,engine_pkcs11))