Browse Source

perl-inline: New package

Signed-off-by: Marcel Denia <naoir@gmx.net>
Marcel Denia 9 years ago
parent
commit
3d673e73b8
1 changed files with 65 additions and 0 deletions
  1. 65
    0
      lang/perl-inline/Makefile

+ 65
- 0
lang/perl-inline/Makefile View File

@@ -0,0 +1,65 @@
1
+#
2
+# Copyright (C) 2015 OpenWrt.org
3
+#
4
+# This is free software, licensed under the GNU General Public License v2.
5
+# See /LICENSE for more information.
6
+#
7
+
8
+include $(TOPDIR)/rules.mk
9
+
10
+PKG_NAME:=perl-inline
11
+PKG_VERSION:=0.80
12
+PKG_RELEASE:=1
13
+
14
+PKG_SOURCE_URL:=http://www.cpan.org/authors/id/I/IN/INGY
15
+PKG_SOURCE:=Inline-$(PKG_VERSION).tar.gz
16
+PKG_MD5SUM:=510bbac46e727bcaf240b7feac2646c9
17
+
18
+PKG_LICENSE:=GPL-1.0+ Artistic-1.0-Perl
19
+PKG_MAINTAINER:=Marcel Denia <naoir@gmx.net>
20
+
21
+PKG_BUILD_DIR:=$(BUILD_DIR)/perl/Inline-$(PKG_VERSION)
22
+HOST_BUILD_DIR:=$(BUILD_DIR_HOST)/perl/Inline-$(PKG_VERSION)
23
+
24
+HOST_BUILD_DEPENDS:=perl/host
25
+
26
+include $(INCLUDE_DIR)/package.mk
27
+include $(INCLUDE_DIR)/host-build.mk
28
+include ../perl/perlmod.mk
29
+
30
+define Package/perl-inline
31
+  SUBMENU:=Perl
32
+  SECTION:=lang
33
+  CATEGORY:=Languages
34
+  TITLE:=Write subroutines in other languages
35
+  URL:=http://search.cpan.org/dist/Inline/
36
+  DEPENDS:=perl +perlbase-base +perlbase-config +perlbase-cwd +perlbase-digest +perlbase-essential +perlbase-fcntl +perlbase-file
37
+endef
38
+
39
+define Build/Configure
40
+        $(call perlmod/Configure,,)
41
+endef
42
+
43
+define Build/Compile
44
+        $(call perlmod/Compile,,)
45
+endef
46
+
47
+define Package/perl-inline/install
48
+        $(call perlmod/Install,$(1),Inline.pm Inline auto/Inline)
49
+endef
50
+
51
+define Host/Configure
52
+	$(call perlmod/host/Configure,,,)
53
+endef
54
+
55
+define Host/Compile
56
+	$(call perlmod/host/Compile,,)
57
+endef
58
+
59
+define Host/Install
60
+	$(call perlmod/host/Install,$(1),)
61
+endef
62
+
63
+
64
+$(eval $(call BuildPackage,perl-inline))
65
+$(eval $(call HostBuild))