Browse Source

python-pyasn1-modules: new package

From the README:

This is a small but growing collection of ASN.1 data structures
expressed in Python terms using pyasn1 data model.

Signed-off-by: Jeffery To <jeffery.to@gmail.com>
Jeffery To 9 years ago
parent
commit
3e113ebecb
1 changed files with 46 additions and 0 deletions
  1. 46
    0
      lang/python-pyasn1-modules/Makefile

+ 46
- 0
lang/python-pyasn1-modules/Makefile View File

@@ -0,0 +1,46 @@
1
+#
2
+# Copyright (C) 2015 OpenWrt.org
3
+#
4
+# This is free software, licensed under the GNU General Public License v2.
5
+# See /LICENSE for more information.
6
+#
7
+
8
+include $(TOPDIR)/rules.mk
9
+
10
+PKG_NAME:=pyasn1-modules
11
+PKG_VERSION:=0.0.8
12
+PKG_RELEASE:=1
13
+
14
+PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
15
+PKG_SOURCE_URL:=https://pypi.python.org/packages/source/p/pyasn1-modules
16
+PKG_MD5SUM:=178129bc7fbf07215c25230c5f053f81
17
+
18
+PKG_BUILD_DEPENDS:=python python-setuptools
19
+
20
+PKG_LICENSE:=BSD-2-Clause
21
+PKG_LICENSE_FILES:=LICENSE.txt
22
+PKG_MAINTAINER:=Jeffery To <jeffery.to@gmail.com>
23
+
24
+include $(INCLUDE_DIR)/package.mk
25
+$(call include_mk, python-package.mk)
26
+
27
+define Package/python-pyasn1-modules
28
+	SECTION:=lang
29
+	CATEGORY:=Languages
30
+	SUBMENU:=Python
31
+	TITLE:=python-pyasn1-modules
32
+	URL:=http://sourceforge.net/projects/pyasn1/
33
+	DEPENDS:=+python-light +python-pyasn1
34
+endef
35
+
36
+define Package/python-pyasn1-modules/description
37
+This is a small but growing collection of ASN.1 data structures
38
+expressed in Python terms using pyasn1 data model.
39
+endef
40
+
41
+define Build/Compile
42
+	$(call Build/Compile/PyMod,,install --prefix="/usr" --root="$(PKG_INSTALL_DIR)")
43
+endef
44
+
45
+$(eval $(call PyPackage,python-pyasn1-modules))
46
+$(eval $(call BuildPackage,python-pyasn1-modules))