Browse Source

Merge pull request #749 from roger-/master

libuvc: add package
Ted Hess 10 years ago
parent
commit
3e3fa470f8
1 changed files with 53 additions and 0 deletions
  1. 53
    0
      libs/libuvc/Makefile

+ 53
- 0
libs/libuvc/Makefile View File

@@ -0,0 +1,53 @@
1
+#
2
+# Copyright (C) 2014 OpenWrt.org
3
+#
4
+# This is free software, licensed under the GNU General Public License v2.
5
+# See /LICENSE for more information.
6
+
7
+include $(TOPDIR)/rules.mk
8
+
9
+PKG_NAME:=libuvc
10
+
11
+PKG_VERSION=0.0.5-20140812-$(PKG_SOURCE_VERSION)
12
+PKG_RELEASE:=1
13
+PKG_MAINTAINER:=Roger D <rogerdammit@gmail.com>
14
+
15
+PKG_SOURCE_PROTO:=git
16
+PKG_SOURCE_URL:=https://github.com/ktossell/libuvc.git
17
+PKG_SOURCE_VERSION:=2c6403405872aa865999b95ba15944295adf6c38
18
+
19
+PKG_SOURCE_SUBDIR:=$(PKG_NAME)-$(PKG_VERSION)
20
+PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
21
+PKG_LICENSE:=BSD
22
+
23
+PKG_INSTALL:=1
24
+CMAKE_INSTALL:=1
25
+
26
+include $(INCLUDE_DIR)/package.mk
27
+include $(INCLUDE_DIR)/cmake.mk
28
+
29
+define Package/libuvc
30
+	SECTION:=libs
31
+	CATEGORY:=Libraries
32
+	TITLE:=libuvc
33
+	DEPENDS:=+libusb-1.0 +libjpeg
34
+       URL:=https://int80k.com/libuvc
35
+endef
36
+
37
+define Package/libuvc/description
38
+ This package contains libuvc is a cross-platform library for USB video devices, 
39
+ built atop libusb.
40
+endef
41
+
42
+define Package/libuvc/install
43
+	$(INSTALL_DIR) $(1)/usr/lib
44
+	$(CP) $(PKG_INSTALL_DIR)/usr/lib/libuvc.so* $(1)/usr/lib/
45
+endef
46
+
47
+define Build/InstallDev
48
+	$(INSTALL_DIR) $(1)/usr/{include,lib}
49
+	$(CP) $(PKG_INSTALL_DIR)/usr/include/* $(1)/usr/include/
50
+	$(CP) $(PKG_INSTALL_DIR)/usr/lib/libuvc.so* $(1)/usr/lib/
51
+endef
52
+
53
+$(eval $(call BuildPackage,libuvc))