Browse Source

lang/perl: Strip encoding pragma

The "encoding" pragma is officially deprecated.
Makes HTML::Parser/HTML::Entities work.

Signed-off-by: Marcel Denia <naoir@gmx.net>
Marcel Denia 10 years ago
parent
commit
3e7876c22f
1 changed files with 2 additions and 2 deletions
  1. 2
    2
      lang/perl/perlmod.mk

+ 2
- 2
lang/perl/perlmod.mk View File

@@ -89,8 +89,8 @@ define perlmod/Install
89 89
 	@echo "---> Stripping modules in: $(strip $(1))$(PERL_SITELIB)"
90 90
 	find $(strip $(1))$(PERL_SITELIB) -name \*.pm -or -name \*.pl | \
91 91
 	xargs -r sed -i \
92
-		-e '/^=\(head\|pod\|item\|over\|back\)/,/^=cut/d' \
93
-		-e '/^=\(head\|pod\|item\|over\|back\)/,$$$$d' \
92
+		-e '/^=\(head\|pod\|item\|over\|back\|encoding\)/,/^=cut/d' \
93
+		-e '/^=\(head\|pod\|item\|over\|back\|encoding\)/,$$$$d' \
94 94
 		-e '/^#$$$$/d' \
95 95
 		-e '/^#[^!"'"'"']/d'
96 96
 endef