|
@@ -0,0 +1,82 @@
|
|
1
|
+#
|
|
2
|
+# Copyright (C) 2007-2011 OpenWrt.org
|
|
3
|
+#
|
|
4
|
+# This is free software, licensed under the GNU General Public License v2.
|
|
5
|
+# See /LICENSE for more information.
|
|
6
|
+#
|
|
7
|
+
|
|
8
|
+include $(TOPDIR)/rules.mk
|
|
9
|
+
|
|
10
|
+PKG_NAME:=fcgi
|
|
11
|
+PKG_VERSION:=2.4.0
|
|
12
|
+PKG_RELEASE:=1
|
|
13
|
+
|
|
14
|
+PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
|
|
15
|
+PKG_SOURCE_URL:=http://www.fastcgi.com/dist/
|
|
16
|
+PKG_MD5SUM:=d15060a813b91383a9f3c66faf84867e
|
|
17
|
+
|
|
18
|
+PKG_FIXUP:=libtool-ucxx
|
|
19
|
+
|
|
20
|
+PKG_MAINTAINER:=Jacob Siverskog <jacob@teenageengineering.com>
|
|
21
|
+
|
|
22
|
+PKG_INSTALL:=1
|
|
23
|
+
|
|
24
|
+include $(INCLUDE_DIR)/uclibc++.mk
|
|
25
|
+include $(INCLUDE_DIR)/package.mk
|
|
26
|
+
|
|
27
|
+define Package/fcgi/Default
|
|
28
|
+ SECTION:=libs
|
|
29
|
+ CATEGORY:=Libraries
|
|
30
|
+ URL:=http://www.fastcgi.com/
|
|
31
|
+endef
|
|
32
|
+
|
|
33
|
+define Package/fcgi
|
|
34
|
+ $(call Package/fcgi/Default)
|
|
35
|
+ MENU:=1
|
|
36
|
+ DEPENDS:= +libpthread
|
|
37
|
+ TITLE:=Shared library of FastCGI
|
|
38
|
+endef
|
|
39
|
+
|
|
40
|
+define Package/fcgixx
|
|
41
|
+ $(call Package/fcgi/Default)
|
|
42
|
+ DEPENDS:=fcgi $(CXX_DEPENDS)
|
|
43
|
+ TITLE:=Shared library of FastCGI++
|
|
44
|
+endef
|
|
45
|
+
|
|
46
|
+define Package/fcgi/description
|
|
47
|
+ FastCGI is a language independent, scalable, open extension to
|
|
48
|
+ CGI that provides high performance without the limitations of
|
|
49
|
+ server specific APIs.
|
|
50
|
+endef
|
|
51
|
+
|
|
52
|
+TARGET_CFLAGS += $(FPIC)
|
|
53
|
+
|
|
54
|
+CONFIGURE_ARGS += \
|
|
55
|
+ --enable-shared \
|
|
56
|
+ --enable-static \
|
|
57
|
+
|
|
58
|
+CONFIGURE_VARS += \
|
|
59
|
+ LIBS="-lm" \
|
|
60
|
+
|
|
61
|
+define Build/InstallDev
|
|
62
|
+ $(INSTALL_DIR) $(1)/usr/include
|
|
63
|
+ $(CP) $(PKG_INSTALL_DIR)/usr/include/fastcgi.h $(1)/usr/include/
|
|
64
|
+ $(CP) $(PKG_INSTALL_DIR)/usr/include/fcgi{app,_config,misc,o,os,_stdio}.h $(1)/usr/include/
|
|
65
|
+ $(INSTALL_DIR) $(1)/usr/lib
|
|
66
|
+ $(CP) $(PKG_INSTALL_DIR)/usr/lib/libfcgi{,++}.{a,so*} $(1)/usr/lib/
|
|
67
|
+endef
|
|
68
|
+
|
|
69
|
+define Package/fcgi/install
|
|
70
|
+ $(INSTALL_DIR) $(1)/usr/bin
|
|
71
|
+ $(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/bin/cgi-fcgi $(1)/usr/bin/
|
|
72
|
+ $(INSTALL_DIR) $(1)/usr/lib
|
|
73
|
+ $(CP) $(PKG_INSTALL_DIR)/usr/lib/libfcgi.so.* $(1)/usr/lib/
|
|
74
|
+endef
|
|
75
|
+
|
|
76
|
+define Package/fcgixx/install
|
|
77
|
+ $(INSTALL_DIR) $(1)/usr/lib
|
|
78
|
+ $(CP) $(PKG_INSTALL_DIR)/usr/lib/libfcgi++.so.* $(1)/usr/lib/
|
|
79
|
+endef
|
|
80
|
+
|
|
81
|
+$(eval $(call BuildPackage,fcgi))
|
|
82
|
+$(eval $(call BuildPackage,fcgixx))
|