Browse Source

Merge pull request #1102 from openwrt/revert-1083-noip

Revert "new package: noip"
Steven Barth 10 years ago
parent
commit
3f403f8802

+ 0
- 59
net/noip/Makefile View File

@@ -1,59 +0,0 @@
1
-#
2
-# Copyright (C) 2015 OpenWrt.org
3
-#
4
-# This is free software, licensed under the GNU General Public License v2.
5
-# See /LICENSE for more information.
6
-#
7
-
8
-include $(TOPDIR)/rules.mk
9
-
10
-PKG_NAME:=noip
11
-PKG_REV:=1
12
-PKG_VERSION:=2.1.9-1
13
-PKG_RELEASE:=1
14
-
15
-PKG_SOURCE:=noip-duc-linux.tar.gz
16
-PKG_SOURCE_URL=http://www.noip.com/client/linux/
17
-PKG_MD5SUM:=3b0f5f2ff8637c73ab337be403252a60
18
-PKG_MAINTAINER:="Lawrence D'Anna <larry@elder-gods.org>"
19
-
20
-PKG_LICENSE:=GPLv2
21
-PKG_LICENSE_FILES:=COPYING
22
-
23
-PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(PKG_VERSION)
24
-
25
-include $(INCLUDE_DIR)/package.mk
26
-
27
-define Package/noip
28
-  SECTION:=net
29
-  CATEGORY:=Network
30
-  DEPENDS:=
31
-  TITLE:=noip.com client
32
-  URL:=http://noip.com
33
-endef
34
-
35
-define Package/noip/description
36
-	This is the ip address update client for noip.com
37
-endef
38
-
39
-define Build/Configure
40
-endef
41
-
42
-define Build/Compile
43
-	$(MAKE) -C $(PKG_BUILD_DIR) \
44
-		PREFIX="" \
45
-		DESTDIR="$(PKG_INSTALL_DIR)" \
46
-		BINDIR="$(PKG_INSTALL_DIR)/usr/bin"  \
47
-		CFLAGS="$(TARGET_CFLAGS)" \
48
-		CC="$(TARGET_CC) $(TARGET_CFLAGS)" -O $(TARGET_CPPFLAGS) \
49
-		LD="$(TARGET_CC) $(TARGET_LDFLAGS)" \
50
-		install
51
-endef
52
-
53
-define Package/noip/install
54
-	$(INSTALL_DIR) $(1)/usr/bin/
55
-	$(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/bin/* $(1)/usr/bin/
56
-	$(CP) ./files/* $(1)/
57
-endef
58
-
59
-$(eval $(call BuildPackage,noip))

+ 0
- 17
net/noip/files/etc/init.d/noip View File

@@ -1,17 +0,0 @@
1
-#!/bin/sh /etc/rc.common
2
-START=99
3
-
4
-BIN=noip2
5
-
6
-start() {
7
-    $BIN 
8
-}
9
-
10
-stop() {
11
-    $BIN -K `pgrep $BIN`
12
-}
13
-
14
-reload() {
15
-    stop
16
-    start         
17
-}

+ 0
- 2
net/noip/files/etc/no-ip2.conf View File

@@ -1,2 +0,0 @@
1
-# run this to autoconfigure:
2
-# noip2 -C -c /etc/no-ip2.conf 

+ 0
- 13
net/noip/patches/001-Makefile-DESTDIR.patch View File

@@ -1,13 +0,0 @@
1
---- a/Makefile
2
-+++ b/Makefile
3
-@@ -3,8 +3,8 @@ CC=gcc
4
- PKG=noip-2.1.tgz
5
- 
6
- PREFIX=/usr/local
7
--CONFDIR=${PREFIX}/etc
8
--BINDIR=${PREFIX}/bin
9
-+CONFDIR=${DESTDIR}/${PREFIX}/etc
10
-+BINDIR=${DESTDIR}/${PREFIX}/bin
11
- 
12
- # these defines are for Linux
13
- LIBS=

+ 0
- 14
net/noip/patches/002-Makefile-dont-run.patch View File

@@ -1,14 +0,0 @@
1
---- a/Makefile
2
-+++ b/Makefile
3
-@@ -28,8 +28,9 @@ install: ${TGT} 
4
- 	if [ ! -d ${BINDIR} ]; then mkdir -p ${BINDIR};fi
5
- 	if [ ! -d ${CONFDIR} ]; then mkdir -p ${CONFDIR};fi
6
- 	cp ${TGT} ${BINDIR}/${TGT}
7
--	${BINDIR}/${TGT} -C -c /tmp/no-ip2.conf
8
--	mv /tmp/no-ip2.conf ${CONFDIR}/no-ip2.conf
9
-+	echo "# run this to autoconfigure:" >no-ip2.conf
10
-+	echo "# ${TGT} -C -c /etc/no-ip2.conf " >>no-ip2.conf
11
-+	mv no-ip2.conf ${CONFDIR}/no-ip2.conf
12
- 
13
- package: ${TGT}
14
- 	rm  -f *.bak