Browse Source

sshfs: import from oldpackages feed

 - update to latest 2.5
 - add license info
 - add maintainer

Signed-off-by: Zoltan HERPAI <wigyori@uid0.hu>
Zoltan HERPAI 10 years ago
parent
commit
3fa281e56e
1 changed files with 62 additions and 0 deletions
  1. 62
    0
      net/sshfs/Makefile

+ 62
- 0
net/sshfs/Makefile View File

@@ -0,0 +1,62 @@
1
+#
2
+# Copyright (C) 2015 OpenWrt.org
3
+#
4
+# This is free software, licensed under the GNU General Public License v2.
5
+# See /LICENSE for more information.
6
+#
7
+
8
+include $(TOPDIR)/rules.mk
9
+
10
+PKG_NAME:=sshfs
11
+PKG_VERSION:=2.5
12
+PKG_RELEASE:=1
13
+
14
+PKG_LICENSE:=GPL-2.0
15
+PKG_MAINTAINER:=Zoltan HERPAI <wigyori@uid0.hu>
16
+
17
+PKG_SOURCE:=$(PKG_NAME)-fuse-$(PKG_VERSION).tar.gz
18
+PKG_SOURCE_URL:=@SF/fuse
19
+PKG_MD5SUM:=17494910db8383a366b1301e5f5148a9
20
+
21
+PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-fuse-$(PKG_VERSION)
22
+
23
+include $(INCLUDE_DIR)/package.mk
24
+include $(INCLUDE_DIR)/nls.mk
25
+
26
+define Package/sshfs
27
+  TITLE:=SSHFS
28
+  DEPENDS:=+libfuse +fuse-utils +glib2 +libpthread
29
+  SECTION:=net
30
+  CATEGORY:=Network
31
+  SUBMENU:=Filesystem
32
+  URL:=http://fuse.sourceforge.net/
33
+endef
34
+
35
+define Package/sshfs/description
36
+	Mount remote system over sftp.
37
+endef
38
+
39
+CONFIGURE_VARS += \
40
+	SSHFS_CFLAGS=" \
41
+		-D_FILE_OFFSET_BITS=64 \
42
+		-I$(STAGING_DIR)/usr/include/glib-2.0 \
43
+		-I$(STAGING_DIR)/usr/lib/glib-2.0/include \
44
+		-I$(STAGING_DIR)/usr/include/fuse" \
45
+	SSHFS_LIBS=" \
46
+		-lglib-2.0 -liconv $(if $(INTL_FULL),-lintl) -lfuse -pthread -lgthread-2.0 \
47
+		-L$(STAGING_DIR)/usr/lib"
48
+
49
+define Build/Compile
50
+	$(MAKE) -C $(PKG_BUILD_DIR) \
51
+		ARCH="$(LINUX_KARCH)" \
52
+		CROSS_COMPILE="$(TARGET_CROSS)" \
53
+		DESTDIR="$(PKG_INSTALL_DIR)" \
54
+		all install
55
+endef
56
+
57
+define Package/sshfs/install
58
+	$(INSTALL_DIR) $(1)/usr/bin
59
+	$(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/bin/sshfs $(1)/usr/bin/
60
+endef
61
+
62
+$(eval $(call BuildPackage,sshfs))