Browse Source

python-pip: add site-wide pip.conf with defaults

Signed-off-by: Alexandru Ardelean <ardeleanalex@gmail.com>
Alexandru Ardelean 9 years ago
parent
commit
3fe1374238
2 changed files with 7 additions and 3 deletions
  1. 4
    3
      lang/python-pip/Makefile
  2. 3
    0
      lang/python-pip/files/pip.conf

+ 4
- 3
lang/python-pip/Makefile View File

@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
9 9
 
10 10
 PKG_NAME:=python-pip
11 11
 PKG_VERSION:=7.1.2
12
-PKG_RELEASE:=2
12
+PKG_RELEASE:=3
13 13
 
14 14
 PKG_SOURCE:=pip-$(PKG_VERSION).tar.gz
15 15
 PKG_SOURCE_URL:=https://pypi.python.org/packages/source/p/pip/
@@ -48,8 +48,9 @@ define PyPackage/python-pip/filespec
48 48
 endef
49 49
 
50 50
 define PyPackage/python-pip/install
51
-	$(INSTALL_DIR) $(1)/usr/bin
52
-	$(CP) $(PKG_INSTALL_DIR)/usr/bin/* $(1)/usr/bin
51
+	$(INSTALL_DIR) $(1)/usr/bin $(1)/etc
52
+	$(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/bin/* $(1)/usr/bin
53
+	$(INSTALL_CONF) ./files/pip.conf $(1)/etc/
53 54
 endef
54 55
 
55 56
 $(eval $(call PyPackage,python-pip))

+ 3
- 0
lang/python-pip/files/pip.conf View File

@@ -0,0 +1,3 @@
1
+[global]
2
+cache-dir=/tmp/.cache
3
+log-file=/tmp/pip-log.txt