소스 검색

libzmq upgrade to 4.1.1

lzmq upgrade to 0.4.3

Signed-off-by: Dirk Chang <dirk@kooiot.com>
Dirk Chang 9 년 전
부모
커밋
3ff4d6dda5

+ 4
- 4
lang/lzmq/Makefile 파일 보기

@@ -8,14 +8,14 @@
8 8
 include $(TOPDIR)/rules.mk
9 9
 
10 10
 PKG_NAME:=lzmq
11
-PKG_VERSION:=0.4.2
12
-PKG_RELEASE:=2
11
+PKG_VERSION:=0.4.3
12
+PKG_RELEASE:=1
13 13
 PKG_MAINTAINER:=Dirk Chang <dirk@kooiot.com>
14 14
 PKG_LICENSE:=MIT
15 15
 
16 16
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
17
-PKG_SOURCE_URL:=https://codeload.github.com/zeromq/lzmq/tar.gz/v0.4.2?
18
-PKG_MD5SUM:=ec9e15bd1495f4c87959fe22a368523d
17
+PKG_SOURCE_URL:=https://codeload.github.com/zeromq/lzmq/tar.gz/v$(PKG_VERSION)?
18
+PKG_MD5SUM:=c4e51a60a5a26987bdce59e45d674a9e
19 19
 
20 20
 include $(INCLUDE_DIR)/package.mk
21 21
 include $(INCLUDE_DIR)/cmake.mk

+ 8
- 2
libs/zmq/Makefile 파일 보기

@@ -10,8 +10,8 @@
10 10
 include $(TOPDIR)/rules.mk
11 11
 
12 12
 PKG_NAME:=zeromq
13
-PKG_VERSION:=4.0.5
14
-PKG_RELEASE:=2
13
+PKG_VERSION:=4.1.1
14
+PKG_RELEASE:=1
15 15
 PKG_MAINTAINER:=Dirk Chang <dirk@kooiot.com>
16 16
 PKG_LICENSE:=GPL-3.0+
17 17
 PKG_LICENSE_FILES:=LICENCE.txt
@@ -58,6 +58,12 @@ CONFIGURE_ARGS += \
58 58
 	--enable-static \
59 59
 	--enable-shared
60 60
 
61
+ifneq ($(CONFIG_PACKAGE_libsodium),)
62
+  CONFIGURE_ARGS+= --with-libsodium
63
+else
64
+  CONFIGURE_ARGS+= --without-libsodium
65
+endif
66
+
61 67
 # add make variable overrides here
62 68
 MAKE_FLAGS +=
63 69
 

+ 2
- 2
libs/zmq/patches/disable_pedantic_on_linux_with_ulibc++.patch 파일 보기

@@ -1,5 +1,5 @@
1
---- zeromq-4.0.4_org/configure.ac	2014-06-04 10:19:35.140061796 +0800
2
-+++ zeromq-4.0.4/configure.ac	2014-06-04 11:08:17.231997926 +0800
1
+--- a/configure.ac	2014-06-04 10:19:35.140061796 +0800
2
++++ b/configure.ac	2014-06-04 11:08:17.231997926 +0800
3 3
 @@ -127,8 +127,10 @@
4 4
      *linux*)
5 5
          # Define on Linux to enable all library features. Define if using a gnu compiler

+ 41
- 0
libs/zmq/patches/map_with_const_string_with_ublic++.patch 파일 보기

@@ -0,0 +1,41 @@
1
+--- a/src/metadata.hpp	2015-06-17 21:39:33.629934688 +0800
2
++++ b/src/metadata.hpp	2014-10-14 22:07:36.000000000 +0800
3
+@@ -31,7 +31,7 @@
4
+     {
5
+         public:
6
+ 
7
+-            typedef std::map <std::string, const std::string> dict_t;
8
++            typedef std::map <std::string, std::string> dict_t;
9
+ 
10
+             metadata_t (const dict_t &dict);
11
+             virtual ~metadata_t ();
12
+--- a/src/socket_base.cpp	2015-06-17 21:42:26.289413233 +0800
13
++++ b/src/socket_base.cpp	2015-06-02 18:31:00.000000000 +0800
14
+@@ -20,6 +20,7 @@
15
+ #include <new>
16
+ #include <string>
17
+ #include <algorithm>
18
++#include <ctype.h>
19
+ 
20
+ #include "platform.hpp"
21
+ 
22
+--- a/src/stream_engine.cpp	2015-06-17 21:57:29.599443517 +0800
23
++++ b/src/stream_engine.cpp	2015-06-02 18:31:00.000000000 +0800
24
+@@ -198,7 +198,7 @@
25
+             //  Compile metadata.
26
+             typedef metadata_t::dict_t properties_t;
27
+             properties_t properties;
28
+-            properties.insert(std::make_pair("Peer-Address", peer_address));
29
++            properties.insert(std::make_pair<std::string, std::string>("Peer-Address", peer_address));
30
+             zmq_assert (metadata == NULL);
31
+             metadata = new (std::nothrow) metadata_t (properties);
32
+         }
33
+@@ -805,7 +805,7 @@
34
+ 
35
+     //  If we have a peer_address, add it to metadata
36
+     if (!peer_address.empty()) {
37
+-        properties.insert(std::make_pair("Peer-Address", peer_address));
38
++        properties.insert(std::make_pair<std::string, std::string>("Peer-Address", peer_address));
39
+     }
40
+ 
41
+     //  Add ZAP properties.

+ 2
- 2
libs/zmq/patches/streamoff_missing_with_ulibc++.patch 파일 보기

@@ -1,5 +1,5 @@
1
---- zeromq-4.0.4_org/src/blob.hpp	2014-06-04 10:19:12.680062287 +0800
2
-+++ zeromq-4.0.4/src/blob.hpp	2014-06-04 10:30:31.168047457 +0800
1
+--- a/src/blob.hpp	2014-06-04 10:19:12.680062287 +0800
2
++++ b/src/blob.hpp	2014-06-04 10:30:31.168047457 +0800
3 3
 @@ -21,6 +21,7 @@
4 4
  #define __ZMQ_BLOB_HPP_INCLUDED__
5 5
  

+ 0
- 10
libs/zmq/patches/tools_gcc_fix.patch 파일 보기

@@ -1,10 +0,0 @@
1
-diff -ruNa zeromq-4.0.4_org/tools/Makefile.am zeromq-4.0.4/tools/Makefile.am
2
---- zeromq-4.0.4_org/tools/Makefile.am	2014-06-03 20:01:12.392379933 +0800
3
-+++ zeromq-4.0.4/tools/Makefile.am	2014-06-03 19:59:18.616382420 +0800
4
-@@ -1,5 +1,5 @@
5
- EXTRA_DIST = curve_keygen.c 
6
-+CFLAGS += -std=c99
7
--
8
- INCLUDES = -I$(top_srcdir)/include
9
- 
10
- bin_PROGRAMS = curve_keygen