Sfoglia il codice sorgente

Import of oldpackages/libs/gdbm

Signed-off-by: Marcel Denia <naoir@gmx.net>
Marcel Denia 10 anni fa
parent
commit
40a5ed3d99
1 ha cambiato i file con 59 aggiunte e 0 eliminazioni
  1. 59
    0
      libs/gdbm/Makefile

+ 59
- 0
libs/gdbm/Makefile Vedi File

@@ -0,0 +1,59 @@
1
+#
2
+# Copyright (C) 2006-2013 OpenWrt.org
3
+#
4
+# This is free software, licensed under the GNU General Public License v2.
5
+# See /LICENSE for more information.
6
+#
7
+
8
+include $(TOPDIR)/rules.mk
9
+
10
+PKG_NAME:=gdbm
11
+PKG_VERSION:=1.10
12
+PKG_RELEASE:=1
13
+
14
+PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
15
+PKG_SOURCE_URL:=@GNU/gdbm
16
+PKG_MD5SUM:=88770493c2559dc80b561293e39d3570
17
+
18
+PKG_LICENSE:=GPLv3
19
+PKG_LICENSE_FILES:=COPYING
20
+
21
+PKG_FIXUP:=autoreconf
22
+PKG_BUILD_PARALLEL:=0
23
+
24
+include $(INCLUDE_DIR)/package.mk
25
+
26
+define Package/libgdbm
27
+  SECTION:=libs
28
+  CATEGORY:=Libraries
29
+  TITLE:=GNU database manager
30
+  URL:=http://www.gnu.org/software/gdbm/
31
+endef
32
+
33
+TARGET_CFLAGS += $(FPIC)
34
+
35
+CONFIGURE_ARGS += \
36
+	--enable-shared \
37
+	--enable-static \
38
+
39
+define Build/Compile
40
+	+$(MAKE) $(PKG_JOBS) -C $(PKG_BUILD_DIR) \
41
+		BINOWN=`id -u` \
42
+		BINGRP=`id -g` \
43
+		DESTDIR="$(PKG_INSTALL_DIR)" \
44
+		all install
45
+endef
46
+
47
+define Build/InstallDev
48
+	$(INSTALL_DIR) $(1)/usr/include
49
+	$(CP) $(PKG_INSTALL_DIR)/usr/include/gdbm.h $(1)/usr/include/
50
+	$(INSTALL_DIR) $(1)/usr/lib
51
+	$(CP) $(PKG_INSTALL_DIR)/usr/lib/libgdbm.{a,so*} $(1)/usr/lib/
52
+endef
53
+
54
+define Package/libgdbm/install
55
+	$(INSTALL_DIR) $(1)/usr/lib
56
+	$(CP) $(PKG_INSTALL_DIR)/usr/lib/libgdbm.so.* $(1)/usr/lib/
57
+endef
58
+
59
+$(eval $(call BuildPackage,libgdbm))