Browse Source

Merge pull request #124 from Naoir/perl-modules

perl-*: Import from oldpackages, update to latest upstream, fix, add myself as maintainer
sbyx 10 years ago
parent
commit
40bc0fafb3

+ 48
- 0
lang/perl-compress-bzip2/Makefile View File

@@ -0,0 +1,48 @@
1
+#
2
+# Copyright (C) 2014 OpenWrt.org
3
+#
4
+# This is free software, licensed under the GNU General Public License v2.
5
+# See /LICENSE for more information.
6
+#
7
+
8
+include $(TOPDIR)/rules.mk
9
+
10
+PKG_NAME:=perl-compress-bzip2
11
+PKG_VERSION:=2.17
12
+PKG_RELEASE:=1
13
+
14
+PKG_SOURCE_URL:=http://www.cpan.org/authors/id/R/RU/RURBAN/
15
+PKG_SOURCE:=Compress-Bzip2-$(PKG_VERSION).tar.gz
16
+PKG_MD5SUM:=d8b809f6efe3edb33f81d608c932b2ef
17
+
18
+PKG_LICENSE:=GPLv1+ ARTISTIC
19
+PKG_MAINTAINER:=Marcel Denia <naoir@gmx.net>
20
+
21
+PKG_BUILD_DIR:=$(BUILD_DIR)/perl/Compress-Bzip2-$(PKG_VERSION)
22
+
23
+include $(INCLUDE_DIR)/package.mk
24
+include ../perl/perlmod.mk
25
+
26
+define Package/perl-compress-bzip2
27
+  SUBMENU:=Perl
28
+  SECTION:=lang
29
+  CATEGORY:=Languages
30
+  TITLE:=Perl interface to bzip2 compression library
31
+  URL:=http://search.cpan.org/dist/Compress-Bzip2/
32
+  DEPENDS:=perl +libbz2
33
+endef
34
+
35
+define Build/Configure
36
+	$(call perlmod/Configure,,BUILD_BZLIB=0)
37
+endef
38
+
39
+define Build/Compile
40
+	$(call perlmod/Compile,,)
41
+endef
42
+
43
+define Package/perl-compress-bzip2/install
44
+	$(call perlmod/Install,$(1),Compress auto/Compress)
45
+endef
46
+
47
+
48
+$(eval $(call BuildPackage,perl-compress-bzip2))

+ 48
- 0
lang/perl-dbi/Makefile View File

@@ -0,0 +1,48 @@
1
+#
2
+# Copyright (C) 2014 OpenWrt.org
3
+#
4
+# This is free software, licensed under the GNU General Public License v2.
5
+# See /LICENSE for more information.
6
+#
7
+
8
+include $(TOPDIR)/rules.mk
9
+
10
+PKG_NAME:=perl-dbi
11
+PKG_VERSION:=1.631
12
+PKG_RELEASE:=1
13
+
14
+PKG_SOURCE_URL:=http://www.cpan.org/authors/id/T/TI/TIMB/
15
+PKG_SOURCE:=DBI-$(PKG_VERSION).tar.gz
16
+PKG_MD5SUM:=444d3c305e86597e11092b517794a840
17
+
18
+PKG_LICENSE:=GPLv1+ ARTISTIC
19
+PKG_MAINTAINER:=Marcel Denia <naoir@gmx.net>
20
+
21
+PKG_BUILD_DIR:=$(BUILD_DIR)/perl/DBI-$(PKG_VERSION)
22
+
23
+include $(INCLUDE_DIR)/package.mk
24
+include ../perl/perlmod.mk
25
+
26
+define Package/perl-dbi
27
+  SUBMENU:=Perl
28
+  SECTION:=lang
29
+  CATEGORY:=Languages
30
+  TITLE:=Database independent interface for Perl
31
+  URL:=http://search.cpan.org/dist/DBI/
32
+  DEPENDS:=perl +perlbase-essential
33
+endef
34
+
35
+define Build/Configure
36
+	$(call perlmod/Configure,,)
37
+endef
38
+
39
+define Build/Compile
40
+	$(call perlmod/Compile,,)
41
+endef
42
+
43
+define Package/perl-dbi/install
44
+	$(call perlmod/Install,$(1),DB* auto/DBI,DBI/W32ODBC.pm auto/DBI/*.h)
45
+endef
46
+
47
+
48
+$(eval $(call BuildPackage,perl-dbi))

+ 48
- 0
lang/perl-html-parser/Makefile View File

@@ -0,0 +1,48 @@
1
+#
2
+# Copyright (C) 2014 OpenWrt.org
3
+#
4
+# This is free software, licensed under the GNU General Public License v2.
5
+# See /LICENSE for more information.
6
+#
7
+
8
+include $(TOPDIR)/rules.mk
9
+
10
+PKG_NAME:=perl-html-parser
11
+PKG_VERSION:=3.71
12
+PKG_RELEASE:=1
13
+
14
+PKG_SOURCE_URL:=http://www.cpan.org/authors/id/G/GA/GAAS/
15
+PKG_SOURCE:=HTML-Parser-$(PKG_VERSION).tar.gz
16
+PKG_MD5SUM:=9128a45893097dfa3bf03301b19c5efe
17
+
18
+PKG_LICENSE:=GPLv1+ ARTISTIC
19
+PKG_MAINTAINER:=Marcel Denia <naoir@gmx.net>
20
+
21
+PKG_BUILD_DIR:=$(BUILD_DIR)/perl/HTML-Parser-$(PKG_VERSION)
22
+
23
+include $(INCLUDE_DIR)/package.mk
24
+include ../perl/perlmod.mk
25
+
26
+define Package/perl-html-parser
27
+  SUBMENU:=Perl
28
+  SECTION:=lang
29
+  CATEGORY:=Languages
30
+  TITLE:=A collection of modules that parse HTML text documents
31
+  URL:=http://search.cpan.org/dist/HTML-Parser/
32
+  DEPENDS:=perl +perl-html-tagset +perl-uri
33
+endef
34
+
35
+define Build/Configure
36
+	$(call perlmod/Configure,,)
37
+endef
38
+
39
+define Build/Compile
40
+	$(call perlmod/Compile,,)
41
+endef
42
+
43
+define Package/perl-html-parser/install
44
+	$(call perlmod/Install,$(1),HTML auto/HTML)
45
+endef
46
+
47
+
48
+$(eval $(call BuildPackage,perl-html-parser))

+ 48
- 0
lang/perl-html-tagset/Makefile View File

@@ -0,0 +1,48 @@
1
+#
2
+# Copyright (C) 2014 OpenWrt.org
3
+#
4
+# This is free software, licensed under the GNU General Public License v2.
5
+# See /LICENSE for more information.
6
+#
7
+
8
+include $(TOPDIR)/rules.mk
9
+
10
+PKG_NAME:=perl-html-tagset
11
+PKG_VERSION:=3.20
12
+PKG_RELEASE:=1
13
+
14
+PKG_SOURCE_URL:=http://www.cpan.org/authors/id/P/PE/PETDANCE/
15
+PKG_SOURCE:=HTML-Tagset-$(PKG_VERSION).tar.gz
16
+PKG_MD5SUM:=d2bfa18fe1904df7f683e96611e87437
17
+
18
+PKG_LICENSE:=GPLv1+ ARTISTIC
19
+PKG_MAINTAINER:=Marcel Denia <naoir@gmx.net>
20
+
21
+PKG_BUILD_DIR:=$(BUILD_DIR)/perl/HTML-Tagset-$(PKG_VERSION)
22
+
23
+include $(INCLUDE_DIR)/package.mk
24
+include ../perl/perlmod.mk
25
+
26
+define Package/perl-html-tagset
27
+  SUBMENU:=Perl
28
+  SECTION:=lang
29
+  CATEGORY:=Languages
30
+  TITLE:=Data tables pertaining to HTML
31
+  URL:=http://search.cpan.org/dist/HTML-Tagset/
32
+  DEPENDS:=perl
33
+endef
34
+
35
+define Build/Configure
36
+	$(call perlmod/Configure,,)
37
+endef
38
+
39
+define Build/Compile
40
+	$(call perlmod/Compile,,)
41
+endef
42
+
43
+define Package/perl-html-tagset/install
44
+	$(call perlmod/Install,$(1),HTML)
45
+endef
46
+
47
+
48
+$(eval $(call BuildPackage,perl-html-tagset))

+ 49
- 0
lang/perl-html-tree/Makefile View File

@@ -0,0 +1,49 @@
1
+#
2
+# Copyright (C) 2014 OpenWrt.org
3
+#
4
+# This is free software, licensed under the GNU General Public License v2.
5
+# See /LICENSE for more information.
6
+#
7
+
8
+include $(TOPDIR)/rules.mk
9
+
10
+PKG_NAME:=perl-html-tree
11
+PKG_VERSION:=3.23
12
+PKG_RELEASE:=2
13
+PKG_MD5SUM:=6352f50be402301f79b580dd235d7762
14
+
15
+PKG_SOURCE_URL:=http://www.cpan.org/authors/id/P/PE/PETEK/
16
+PKG_SOURCE:=HTML-Tree-$(PKG_VERSION).tar.gz
17
+PKG_MD5SUM:=6352f50be402301f79b580dd235d7762
18
+
19
+PKG_LICENSE:=GPLv1+ ARTISTIC
20
+PKG_MAINTAINER:=Marcel Denia <naoir@gmx.net>
21
+
22
+PKG_BUILD_DIR:=$(BUILD_DIR)/perl/HTML-Tree-$(PKG_VERSION)
23
+
24
+include $(INCLUDE_DIR)/package.mk
25
+include ../perl/perlmod.mk
26
+
27
+define Package/perl-html-tree
28
+  SUBMENU:=Perl
29
+  SECTION:=lang
30
+  CATEGORY:=Languages
31
+  TITLE:=represent and create HTML syntax trees
32
+  URL:=http://search.cpan.org/dist/HTML-Tree/
33
+  DEPENDS:=perl +perl-html-parser +perl-html-tagset
34
+endef
35
+
36
+define Build/Configure
37
+	$(call perlmod/Configure,,)
38
+endef
39
+
40
+define Build/Compile
41
+	$(call perlmod/Compile,,)
42
+endef
43
+
44
+define Package/perl-html-tree/install
45
+	$(call perlmod/Install,$(1),HTML)
46
+endef
47
+
48
+
49
+$(eval $(call BuildPackage,perl-html-tree))

+ 48
- 0
lang/perl-lockfile-simple/Makefile View File

@@ -0,0 +1,48 @@
1
+#
2
+# Copyright (C) 2014 OpenWrt.org
3
+#
4
+# This is free software, licensed under the GNU General Public License v2.
5
+# See /LICENSE for more information.
6
+#
7
+
8
+include $(TOPDIR)/rules.mk
9
+
10
+PKG_NAME:=perl-lockfile-simple
11
+PKG_VERSION:=0.208
12
+PKG_RELEASE:=1
13
+
14
+PKG_SOURCE_URL:=http://www.cpan.org/authors/id/S/SC/SCHWIGON/lockfile-simple/
15
+PKG_SOURCE:=LockFile-Simple-$(PKG_VERSION).tar.gz
16
+PKG_MD5SUM:=4421283b4f32549e5299963734170044
17
+
18
+PKG_LICENSE:=GPLv2+ ARTISTIC
19
+PKG_MAINTAINER:=Marcel Denia <naoir@gmx.net>
20
+
21
+PKG_BUILD_DIR:=$(BUILD_DIR)/perl/LockFile-Simple-$(PKG_VERSION)
22
+
23
+include $(INCLUDE_DIR)/package.mk
24
+include ../perl/perlmod.mk
25
+
26
+define Package/perl-lockfile-simple
27
+  SUBMENU:=Perl
28
+  SECTION:=lang
29
+  CATEGORY:=Languages
30
+  TITLE:=Simple advisory file locking
31
+  URL:=http://search.cpan.org/dist/LockFile-Simple/
32
+  DEPENDS:=perl
33
+endef
34
+
35
+define Build/Configure
36
+	$(call perlmod/Configure,,)
37
+endef
38
+
39
+define Build/Compile
40
+	$(call perlmod/Compile,,)
41
+endef
42
+
43
+define Package/perl-lockfile-simple/install
44
+	$(call perlmod/Install,$(1),LockFile auto/LockFile)
45
+endef
46
+
47
+
48
+$(eval $(call BuildPackage,perl-lockfile-simple))

+ 48
- 0
lang/perl-net-telnet/Makefile View File

@@ -0,0 +1,48 @@
1
+#
2
+# Copyright (C) 2011-2014 OpenWrt.org
3
+#
4
+# This is free software, licensed under the GNU General Public License v2.
5
+# See /LICENSE for more information.
6
+#
7
+
8
+include $(TOPDIR)/rules.mk
9
+
10
+PKG_NAME:=perl-net-telnet
11
+PKG_VERSION:=3.04
12
+PKG_RELEASE:=1
13
+
14
+PKG_SOURCE_URL:=http://www.cpan.org/authors/id/J/JR/JROGERS/
15
+PKG_SOURCE:=Net-Telnet-$(PKG_VERSION).tar.gz
16
+PKG_MD5SUM:=d2514080116c1b0fa5f96295c84538e3
17
+
18
+PKG_LICENSE:=GPLv1+ ARTISTIC
19
+PKG_MAINTAINER:=Marcel Denia <naoir@gmx.net>
20
+
21
+PKG_BUILD_DIR:=$(BUILD_DIR)/perl/Net-Telnet-$(PKG_VERSION)
22
+
23
+include $(INCLUDE_DIR)/package.mk
24
+include ../perl/perlmod.mk
25
+
26
+define Package/perl-net-telnet
27
+  SUBMENU:=Perl
28
+  SECTION:=lang
29
+  CATEGORY:=Languages
30
+  TITLE:=Telnet client
31
+  URL:=http://search.cpan.org/dist/Net-Telnet/
32
+  DEPENDS:=perl
33
+endef
34
+
35
+define Build/Configure
36
+	$(call perlmod/Configure,,)
37
+endef
38
+
39
+define Build/Compile
40
+	$(call perlmod/Compile,,)
41
+endef
42
+
43
+define Package/perl-net-telnet/install
44
+	$(call perlmod/Install,$(1),Net auto/Net)
45
+endef
46
+
47
+
48
+$(eval $(call BuildPackage,perl-net-telnet))

+ 48
- 0
lang/perl-test-harness/Makefile View File

@@ -0,0 +1,48 @@
1
+#
2
+# Copyright (C) 2014 OpenWrt.org
3
+#
4
+# This is free software, licensed under the GNU General Public License v2.
5
+# See /LICENSE for more information.
6
+#
7
+
8
+include $(TOPDIR)/rules.mk
9
+
10
+PKG_NAME:=perl-test-harness
11
+PKG_VERSION:=3.32
12
+PKG_RELEASE:=1
13
+
14
+PKG_SOURCE_URL:=http://www.cpan.org/authors/id/L/LE/LEONT/
15
+PKG_SOURCE:=Test-Harness-$(PKG_VERSION).tar.gz
16
+PKG_MD5SUM:=a1241b628dc80f5271ed9235c211e55c
17
+
18
+PKG_LICENSE:=GPLv1+ ARTISTIC
19
+PKG_MAINTAINER:=Marcel Denia <naoir@gmx.net>
20
+
21
+PKG_BUILD_DIR:=$(BUILD_DIR)/perl/Test-Harness-$(PKG_VERSION)
22
+
23
+include $(INCLUDE_DIR)/package.mk
24
+include ../perl/perlmod.mk
25
+
26
+define Package/perl-test-harness
27
+  SUBMENU:=Perl
28
+  SECTION:=lang
29
+  CATEGORY:=Languages
30
+  TITLE:=Perl Test Harness
31
+  URL:=http://search.cpan.org/dist/Test-Harness/
32
+  DEPENDS:=perl
33
+endef
34
+
35
+define Build/Configure
36
+	$(call perlmod/Configure,,)
37
+endef
38
+
39
+define Build/Compile
40
+	$(call perlmod/Compile,,)
41
+endef
42
+
43
+define Package/perl-test-harness/install
44
+	$(call perlmod/Install,$(1),App auto/Test TAP Test)
45
+endef
46
+
47
+
48
+$(eval $(call BuildPackage,perl-test-harness))

+ 48
- 0
lang/perl-uri/Makefile View File

@@ -0,0 +1,48 @@
1
+#
2
+# Copyright (C) 2014 OpenWrt.org
3
+#
4
+# This is free software, licensed under the GNU General Public License v2.
5
+# See /LICENSE for more information.
6
+#
7
+
8
+include $(TOPDIR)/rules.mk
9
+
10
+PKG_NAME:=perl-uri
11
+PKG_VERSION:=1.64
12
+PKG_RELEASE:=1
13
+
14
+PKG_SOURCE_URL:=http://www.cpan.org/authors/id/E/ET/ETHER/
15
+PKG_SOURCE:=URI-$(PKG_VERSION).tar.gz
16
+PKG_MD5SUM:=975b2282bc8f0fd72a6dae5cefc33824
17
+
18
+PKG_LICENSE:=GPLv1+ ARTISTIC
19
+PKG_MAINTAINER:=Marcel Denia <naoir@gmx.net>
20
+
21
+PKG_BUILD_DIR:=$(BUILD_DIR)/perl/URI-$(PKG_VERSION)
22
+
23
+include $(INCLUDE_DIR)/package.mk
24
+include ../perl/perlmod.mk
25
+
26
+define Package/perl-uri
27
+  SUBMENU:=Perl
28
+  SECTION:=lang
29
+  CATEGORY:=Languages
30
+  TITLE:=Manipulates and accesses URI strings
31
+  URL:=http://search.cpan.org/dist/URI/
32
+  DEPENDS:=perl
33
+endef
34
+
35
+define Build/Configure
36
+	$(call perlmod/Configure,,)
37
+endef
38
+
39
+define Build/Compile
40
+	$(call perlmod/Compile,,)
41
+endef
42
+
43
+define Package/perl-uri/install
44
+	$(call perlmod/Install,$(1),URI URI.pm)
45
+endef
46
+
47
+
48
+$(eval $(call BuildPackage,perl-uri))

+ 49
- 0
lang/perl-www-curl/Makefile View File

@@ -0,0 +1,49 @@
1
+#
2
+# Copyright (C) 2014 OpenWrt.org
3
+#
4
+# This is free software, licensed under the GNU General Public License v2.
5
+# See /LICENSE for more information.
6
+#
7
+
8
+include $(TOPDIR)/rules.mk
9
+
10
+PKG_NAME:=perl-www-curl
11
+PKG_VERSION:=4.17
12
+PKG_RELEASE:=1
13
+
14
+PKG_SOURCE_URL:=http://www.cpan.org/authors/id/S/SZ/SZBALINT/
15
+PKG_SOURCE:=WWW-Curl-$(PKG_VERSION).tar.gz
16
+PKG_MD5SUM:=997ac81cd6b03b30b36f7cd930474845
17
+
18
+PKG_LICENSE:=GPLv1+ ARTISTIC
19
+PKG_LICENSE_FILES:=LICENSE
20
+PKG_MAINTAINER:=Marcel Denia <naoir@gmx.net>
21
+
22
+PKG_BUILD_DIR:=$(BUILD_DIR)/perl/WWW-Curl-$(PKG_VERSION)
23
+
24
+include $(INCLUDE_DIR)/package.mk
25
+include ../perl/perlmod.mk
26
+
27
+define Package/perl-www-curl
28
+  SUBMENU:=Perl
29
+  SECTION:=lang
30
+  CATEGORY:=Languages
31
+  TITLE:=Perl bindings to libcurl
32
+  URL:=http://search.cpan.org/dist/WWW-Curl/
33
+  DEPENDS:=perl +libcurl
34
+endef
35
+
36
+define Build/Configure
37
+	$(call perlmod/Configure,$(STAGING_DIR)/usr/include,)
38
+endef
39
+
40
+define Build/Compile
41
+	$(call perlmod/Compile,,)
42
+endef
43
+
44
+define Package/perl-www-curl/install
45
+	$(call perlmod/Install,$(1),WWW/Curl WWW/Curl.pm auto/WWW/Curl)
46
+endef
47
+
48
+
49
+$(eval $(call BuildPackage,perl-www-curl))

+ 74
- 0
lang/perl-www-curl/patches/100-perl-www-curl_disable_curl-config_hack.patch View File

@@ -0,0 +1,74 @@
1
+--- a/Makefile.PL
2
++++ b/Makefile.PL
3
+@@ -12,31 +12,31 @@ no_index		directory => 'template';
4
+ repository		'http://github.com/szbalint/WWW--Curl';
5
+ # This is a hack. If you have libcurl installed, just specify curl.h below
6
+ # and comment out this line.
7
+-if ($^O ne 'MSWin32') {
8
+-    if (!$ENV{CURL_CONFIG}) {
9
+-	    requires_external_bin	'curl-config';
10
+-    }
11
+-} else {
12
+-	print	"Sorry, no automated install is available on Windows,\n".
13
+-		"please see the README.Win32 file on instructions for a manual install.\n";
14
+-	exit(0);
15
+-}
16
+-
17
+-my $curl_config = $ENV{CURL_CONFIG} || 'curl-config';
18
+-
19
+-my $vernum = `${curl_config} --vernum`; chomp $vernum;
20
+-my $version = `${curl_config} --version`; chomp $version; 
21
+-
22
+-my $minimum_ver = hex("070a08");
23
+-
24
+-if ($vernum && hex($vernum) <= $minimum_ver) {
25
+-	print	"Your currently installed libcurl version - $version - is too old.\n".
26
+-		"This module doesn't seek compatibility with versions older than 7.10.8\n".
27
+-		"Proceed manually if you know what you're doing.\n";
28
+-	exit(0);
29
+-}
30
+-
31
+-print "The version is $version\n";
32
++#if ($^O ne 'MSWin32') {
33
++#    if (!$ENV{CURL_CONFIG}) {
34
++#	    requires_external_bin	'curl-config';
35
++#    }
36
++#} else {
37
++#	print	"Sorry, no automated install is available on Windows,\n".
38
++#		"please see the README.Win32 file on instructions for a manual install.\n";
39
++#	exit(0);
40
++#}
41
++#
42
++#my $curl_config = $ENV{CURL_CONFIG} || 'curl-config';
43
++#
44
++#my $vernum = `${curl_config} --vernum`; chomp $vernum;
45
++#my $version = `${curl_config} --version`; chomp $version; 
46
++#
47
++#my $minimum_ver = hex("070a08");
48
++#
49
++#if ($vernum && hex($vernum) <= $minimum_ver) {
50
++#	print	"Your currently installed libcurl version - $version - is too old.\n".
51
++#		"This module doesn't seek compatibility with versions older than 7.10.8\n".
52
++#		"Proceed manually if you know what you're doing.\n";
53
++#	exit(0);
54
++#}
55
++#
56
++#print "The version is $version\n";
57
+ 
58
+ my @includes = qw();
59
+ my ($cflags,$lflags, $ldflags) = ('','','');
60
+@@ -58,10 +58,10 @@ if ($^O ne 'MSWin32') {
61
+ # Get curl to tell us where it is, if we can.
62
+ #
63
+ 
64
+-if ($^O ne 'MSWin32') {
65
+-	$cflags = `${curl_config} --cflags`;
66
+-	$lflags = `${curl_config} --libs`;
67
+-}
68
++#if ($^O ne 'MSWin32') {
69
++#	$cflags = `${curl_config} --cflags`;
70
++#	$lflags = `${curl_config} --libs`;
71
++#}
72
+ 
73
+ # can't find link flags, make some guesses
74
+ if (!defined($lflags)) {

+ 11
- 0
lang/perl-www-curl/patches/200-fix_default_lflags.patch View File

@@ -0,0 +1,11 @@
1
+--- a/Makefile.PL
2
++++ b/Makefile.PL
3
+@@ -39,7 +39,7 @@ repository		'http://github.com/szbalint/
4
+ #print "The version is $version\n";
5
+ 
6
+ my @includes = qw();
7
+-my ($cflags,$lflags, $ldflags) = ('','','');
8
++my ($cflags,$lflags, $ldflags) = ('','-lcurl','');
9
+ 
10
+ # You may need to specify where to find curl.h on your platform
11
+ # These are guesses only, in case curl-config is not telling us.

+ 48
- 0
lang/perl-www-mechanize/Makefile View File

@@ -0,0 +1,48 @@
1
+#
2
+# Copyright (C) 2010-2014 OpenWrt.org
3
+#
4
+# This is free software, licensed under the GNU General Public License v2.
5
+# See /LICENSE for more information.
6
+#
7
+
8
+include $(TOPDIR)/rules.mk
9
+
10
+PKG_NAME:=perl-www-mechanize
11
+PKG_VERSION:=1.73
12
+PKG_RELEASE:=1
13
+
14
+PKG_SOURCE:=WWW-Mechanize-$(PKG_VERSION).tar.gz
15
+PKG_SOURCE_URL:=http://www.cpan.org/authors/id/E/ET/ETHER/
16
+PKG_MD5SUM:=de0a9c528c12793c881151301bc14d1a
17
+
18
+PKG_LICENSE:=GPLv1+ ARTISTIC
19
+PKG_MAINTAINER:=Marcel Denia <naoir@gmx.net>
20
+
21
+PKG_BUILD_DIR:=$(BUILD_DIR)/perl/WWW-Mechanize-$(PKG_VERSION)
22
+
23
+include $(INCLUDE_DIR)/package.mk
24
+include ../perl/perlmod.mk
25
+
26
+define Package/perl-www-mechanize
27
+  SUBMENU:=Perl
28
+  SECTION:=lang
29
+  CATEGORY:=Languages
30
+  TITLE:=Perl WWW Mechanize
31
+  URL:=http://search.cpan.org/dist/WWW-Mechanize/
32
+  DEPENDS:=perl +perl-www
33
+endef
34
+
35
+define Build/Configure
36
+	$(call perlmod/Configure,$(STAGING_DIR)/usr/include,)
37
+endef
38
+
39
+define Build/Compile
40
+	$(call perlmod/Compile,,)
41
+endef
42
+
43
+define Package/perl-www-mechanize/install
44
+	$(call perlmod/Install,$(1),WWW/Mechanize WWW/Mechanize.pm)
45
+endef
46
+
47
+
48
+$(eval $(call BuildPackage,perl-www-mechanize))

+ 48
- 0
lang/perl-www/Makefile View File

@@ -0,0 +1,48 @@
1
+#
2
+# Copyright (C) 2013-2014 OpenWrt.org
3
+#
4
+# This is free software, licensed under the GNU General Public License v2.
5
+# See /LICENSE for more information.
6
+#
7
+
8
+include $(TOPDIR)/rules.mk
9
+
10
+PKG_NAME:=perl-www
11
+PKG_VERSION:=5.837
12
+PKG_RELEASE:=1
13
+
14
+PKG_SOURCE_URL:=http://www.cpan.org/authors/id/G/GA/GAAS/
15
+PKG_SOURCE:=libwww-perl-$(PKG_VERSION).tar.gz
16
+PKG_MD5SUM:=9bbf1bce482b0bac98bb4f04253c03d0
17
+
18
+PKG_LICENSE:=GPLv1+ ARTISTIC
19
+PKG_MAINTAINER:=Marcel Denia <naoir@gmx.net>
20
+
21
+PKG_BUILD_DIR:=$(BUILD_DIR)/perl/libwww-perl-$(PKG_VERSION)
22
+
23
+include $(INCLUDE_DIR)/package.mk
24
+include ../perl/perlmod.mk
25
+
26
+define Package/perl-www
27
+  SUBMENU:=Perl
28
+  SECTION:=lang
29
+  CATEGORY:=Languages
30
+  TITLE:=WWW client/server library for Perl (aka LWP)
31
+  URL:=http://search.cpan.org/dist/libwww-perl/
32
+  DEPENDS:=perl +perl-html-parser +perl-html-tagset +perl-uri
33
+endef
34
+
35
+define Build/Configure
36
+	$(call perlmod/Configure,-n,)
37
+endef
38
+
39
+define Build/Compile
40
+	$(call perlmod/Compile,,)
41
+endef
42
+
43
+define Package/perl-www/install
44
+	$(call perlmod/Install,$(1),File HTML HTTP LWP LWP.pm Net WWW)
45
+endef
46
+
47
+
48
+$(eval $(call BuildPackage,perl-www))