|
@@ -0,0 +1,55 @@
|
|
1
|
+#
|
|
2
|
+# Copyright (C) 2015 OpenWrt.org
|
|
3
|
+#
|
|
4
|
+# This is free software, licensed under the GNU General Public License v2.
|
|
5
|
+# See /LICENSE for more information.
|
|
6
|
+#
|
|
7
|
+
|
|
8
|
+include $(TOPDIR)/rules.mk
|
|
9
|
+
|
|
10
|
+PKG_NAME:=libfastjson
|
|
11
|
+PKG_VERSION:=0.99.2
|
|
12
|
+PKG_RELEASE:=1
|
|
13
|
+
|
|
14
|
+PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
|
|
15
|
+PKG_SOURCE_PROTO:=git
|
|
16
|
+PKG_SOURCE_SUBDIR:=$(PKG_NAME)-$(PKG_VERSION)
|
|
17
|
+PKG_SOURCE_URL:=https://github.com/rsyslog/libfastjson.git
|
|
18
|
+PKG_SOURCE_VERSION:=v$(PKG_VERSION)
|
|
19
|
+
|
|
20
|
+PKG_MAINTAINER:=Dov Murik <dmurik@us.ibm.com>
|
|
21
|
+PKG_LICENSE:=MIT
|
|
22
|
+PKG_LICENSE_FILE:=COPYING
|
|
23
|
+
|
|
24
|
+PKG_FIXUP:=autoreconf
|
|
25
|
+PKG_INSTALL:=1
|
|
26
|
+
|
|
27
|
+include $(INCLUDE_DIR)/package.mk
|
|
28
|
+
|
|
29
|
+define Package/libfastjson
|
|
30
|
+ SECTION:=libs
|
|
31
|
+ CATEGORY:=Libraries
|
|
32
|
+ TITLE:=A fast JSON library for C
|
|
33
|
+ URL:=https://github.com/rsyslog/libfastjson
|
|
34
|
+endef
|
|
35
|
+
|
|
36
|
+define Package/libfastjson/description
|
|
37
|
+ libfastjson - A fast JSON library for C
|
|
38
|
+endef
|
|
39
|
+
|
|
40
|
+TARGET_CFLAGS += $(FPIC)
|
|
41
|
+
|
|
42
|
+define Build/InstallDev
|
|
43
|
+ $(INSTALL_DIR) $(1)/usr/include
|
|
44
|
+ $(CP) $(PKG_INSTALL_DIR)/usr/include/* $(1)/usr/include/
|
|
45
|
+
|
|
46
|
+ $(INSTALL_DIR) $(1)/usr/lib
|
|
47
|
+ $(CP) $(PKG_INSTALL_DIR)/usr/lib/* $(1)/usr/lib/
|
|
48
|
+endef
|
|
49
|
+
|
|
50
|
+define Package/libfastjson/install
|
|
51
|
+ $(INSTALL_DIR) $(1)/usr/lib
|
|
52
|
+ $(CP) $(PKG_INSTALL_DIR)/usr/lib/libfastjson.so* $(1)/usr/lib/
|
|
53
|
+endef
|
|
54
|
+
|
|
55
|
+$(eval $(call BuildPackage,libfastjson))
|