Преглед изворни кода

gnunet: update source and fix build with musl

Signed-off-by: Daniel Golle <daniel@makrotopia.org>
Daniel Golle пре 9 година
родитељ
комит
4116e327af

+ 2
- 2
net/gnunet/Makefile Прегледај датотеку

@@ -8,9 +8,9 @@
8 8
 include $(TOPDIR)/rules.mk
9 9
 
10 10
 PKG_NAME:=gnunet
11
-PKG_SOURCE_VERSION:=35865
11
+PKG_SOURCE_VERSION:=35933
12 12
 PKG_VERSION:=0.10.1-svn$(PKG_SOURCE_VERSION)
13
-PKG_RELEASE:=2
13
+PKG_RELEASE:=1
14 14
 
15 15
 # ToDo:
16 16
 #  - break-out transports

+ 2
- 4
net/gnunet/patches/010-cross-compile-fixes.patch Прегледај датотеку

@@ -1,7 +1,5 @@
1
-Index: gnunet-0.10.1/configure.ac
2
-===================================================================
3
---- gnunet-0.10.1.orig/configure.ac
4
-+++ gnunet-0.10.1/configure.ac
1
+--- a/configure.ac
2
++++ b/configure.ac
5 3
 @@ -194,7 +194,7 @@ AM_CONDITIONAL(GNU, test "$build_target"
6 4
  AC_MSG_RESULT([$build_target])
7 5
  AC_SUBST(build_target)

+ 6
- 12
net/gnunet/patches/011-no-fpu-includes.patch Прегледај датотеку

@@ -1,7 +1,5 @@
1
-Index: gnunet-0.10.1/src/dht/gnunet-service-dht_neighbours.c
2
-===================================================================
3
---- gnunet-0.10.1.orig/src/dht/gnunet-service-dht_neighbours.c
4
-+++ gnunet-0.10.1/src/dht/gnunet-service-dht_neighbours.c
1
+--- a/src/dht/gnunet-service-dht_neighbours.c
2
++++ b/src/dht/gnunet-service-dht_neighbours.c
5 3
 @@ -45,7 +45,6 @@
6 4
  #include "gnunet-service-dht_neighbours.h"
7 5
  #include "gnunet-service-dht_nse.h"
@@ -10,10 +8,8 @@ Index: gnunet-0.10.1/src/dht/gnunet-service-dht_neighbours.c
10 8
  #include "dht.h"
11 9
  
12 10
  #define LOG_TRAFFIC(kind,...) GNUNET_log_from (kind, "dht-traffic",__VA_ARGS__)
13
-Index: gnunet-0.10.1/src/dht/gnunet-service-wdht_neighbours.c
14
-===================================================================
15
---- gnunet-0.10.1.orig/src/dht/gnunet-service-wdht_neighbours.c
16
-+++ gnunet-0.10.1/src/dht/gnunet-service-wdht_neighbours.c
11
+--- a/src/dht/gnunet-service-wdht_neighbours.c
12
++++ b/src/dht/gnunet-service-wdht_neighbours.c
17 13
 @@ -44,7 +44,6 @@
18 14
  #include "gnunet-service-wdht_datacache.h"
19 15
  #include "gnunet-service-wdht_neighbours.h"
@@ -22,10 +18,8 @@ Index: gnunet-0.10.1/src/dht/gnunet-service-wdht_neighbours.c
22 18
  #include <stdlib.h>
23 19
  #include <string.h>
24 20
  #include "dht.h"
25
-Index: gnunet-0.10.1/src/dht/gnunet-service-xdht_neighbours.c
26
-===================================================================
27
---- gnunet-0.10.1.orig/src/dht/gnunet-service-xdht_neighbours.c
28
-+++ gnunet-0.10.1/src/dht/gnunet-service-xdht_neighbours.c
21
+--- a/src/dht/gnunet-service-xdht_neighbours.c
22
++++ b/src/dht/gnunet-service-xdht_neighbours.c
29 23
 @@ -41,7 +41,6 @@
30 24
  #include "gnunet-service-xdht_datacache.h"
31 25
  #include "gnunet-service-xdht_neighbours.h"

+ 16
- 32
net/gnunet/patches/012-work-around-bad-workarounds.patch Прегледај датотеку

@@ -1,7 +1,5 @@
1
-Index: gnunet-0.10.1-svn35844/m4/libgnurl.m4
2
-===================================================================
3
---- gnunet-0.10.1-svn35844.orig/m4/libgnurl.m4
4
-+++ gnunet-0.10.1-svn35844/m4/libgnurl.m4
1
+--- a/m4/libgnurl.m4
2
++++ b/m4/libgnurl.m4
5 3
 @@ -146,7 +146,7 @@ AC_DEFUN([LIBGNURL_CHECK_CONFIG],
6 4
             _libgnurl_save_libs=$LIBS
7 5
             LIBS="$LIBGNURL $LIBS"
@@ -11,10 +9,8 @@ Index: gnunet-0.10.1-svn35844/m4/libgnurl.m4
11 9
  /* Try and use a few common options to force a failure if we are
12 10
     missing symbols or can't link. */
13 11
  int x;
14
-Index: gnunet-0.10.1-svn35844/src/gns/gnunet-gns-proxy.c
15
-===================================================================
16
---- gnunet-0.10.1-svn35844.orig/src/gns/gnunet-gns-proxy.c
17
-+++ gnunet-0.10.1-svn35844/src/gns/gnunet-gns-proxy.c
12
+--- a/src/gns/gnunet-gns-proxy.c
13
++++ b/src/gns/gnunet-gns-proxy.c
18 14
 @@ -29,7 +29,7 @@
19 15
   */
20 16
  #include "platform.h"
@@ -24,10 +20,8 @@ Index: gnunet-0.10.1-svn35844/src/gns/gnunet-gns-proxy.c
24 20
  #include <gnutls/gnutls.h>
25 21
  #include <gnutls/x509.h>
26 22
  #include <gnutls/abstract.h>
27
-Index: gnunet-0.10.1-svn35844/src/gns/test_gns_proxy.c
28
-===================================================================
29
---- gnunet-0.10.1-svn35844.orig/src/gns/test_gns_proxy.c
30
-+++ gnunet-0.10.1-svn35844/src/gns/test_gns_proxy.c
23
+--- a/src/gns/test_gns_proxy.c
24
++++ b/src/gns/test_gns_proxy.c
31 25
 @@ -24,7 +24,7 @@
32 26
   * @author Martin Schanzenbach
33 27
   */
@@ -37,10 +31,8 @@ Index: gnunet-0.10.1-svn35844/src/gns/test_gns_proxy.c
37 31
  #include <microhttpd.h>
38 32
  #include "gnunet_namestore_service.h"
39 33
  #include "gnunet_gns_service.h"
40
-Index: gnunet-0.10.1-svn35844/src/hostlist/gnunet-daemon-hostlist_client.c
41
-===================================================================
42
---- gnunet-0.10.1-svn35844.orig/src/hostlist/gnunet-daemon-hostlist_client.c
43
-+++ gnunet-0.10.1-svn35844/src/hostlist/gnunet-daemon-hostlist_client.c
34
+--- a/src/hostlist/gnunet-daemon-hostlist_client.c
35
++++ b/src/hostlist/gnunet-daemon-hostlist_client.c
44 36
 @@ -29,7 +29,7 @@
45 37
  #include "gnunet_statistics_service.h"
46 38
  #include "gnunet_transport_service.h"
@@ -50,10 +42,8 @@ Index: gnunet-0.10.1-svn35844/src/hostlist/gnunet-daemon-hostlist_client.c
50 42
  
51 43
  
52 44
  /**
53
-Index: gnunet-0.10.1-svn35844/src/pt/test_gns_vpn.c
54
-===================================================================
55
---- gnunet-0.10.1-svn35844.orig/src/pt/test_gns_vpn.c
56
-+++ gnunet-0.10.1-svn35844/src/pt/test_gns_vpn.c
45
+--- a/src/pt/test_gns_vpn.c
46
++++ b/src/pt/test_gns_vpn.c
57 47
 @@ -24,7 +24,7 @@
58 48
   * @author Martin Schanzenbach
59 49
   */
@@ -63,10 +53,8 @@ Index: gnunet-0.10.1-svn35844/src/pt/test_gns_vpn.c
63 53
  #include <microhttpd.h>
64 54
  #include "gnunet_identity_service.h"
65 55
  #include "gnunet_namestore_service.h"
66
-Index: gnunet-0.10.1-svn35844/src/pt/test_gnunet_vpn.c
67
-===================================================================
68
---- gnunet-0.10.1-svn35844.orig/src/pt/test_gnunet_vpn.c
69
-+++ gnunet-0.10.1-svn35844/src/pt/test_gnunet_vpn.c
56
+--- a/src/pt/test_gnunet_vpn.c
57
++++ b/src/pt/test_gnunet_vpn.c
70 58
 @@ -24,7 +24,7 @@
71 59
   * @author Christian Grothoff
72 60
   */
@@ -76,10 +64,8 @@ Index: gnunet-0.10.1-svn35844/src/pt/test_gnunet_vpn.c
76 64
  #include <microhttpd.h>
77 65
  #include "gnunet_vpn_service.h"
78 66
  #include "gnunet_testing_lib.h"
79
-Index: gnunet-0.10.1-svn35844/src/transport/plugin_transport_http.h
80
-===================================================================
81
---- gnunet-0.10.1-svn35844.orig/src/transport/plugin_transport_http.h
82
-+++ gnunet-0.10.1-svn35844/src/transport/plugin_transport_http.h
67
+--- a/src/transport/plugin_transport_http.h
68
++++ b/src/transport/plugin_transport_http.h
83 69
 @@ -41,7 +41,7 @@
84 70
  #include "gnunet_os_lib.h"
85 71
  #include "gnunet_nat_lib.h"
@@ -89,10 +75,8 @@ Index: gnunet-0.10.1-svn35844/src/transport/plugin_transport_http.h
89 75
  
90 76
  
91 77
  #define DEBUG_HTTP GNUNET_EXTRA_LOGGING
92
-Index: gnunet-0.10.1-svn35844/src/transport/plugin_transport_http_client.c
93
-===================================================================
94
---- gnunet-0.10.1-svn35844.orig/src/transport/plugin_transport_http_client.c
95
-+++ gnunet-0.10.1-svn35844/src/transport/plugin_transport_http_client.c
78
+--- a/src/transport/plugin_transport_http_client.c
79
++++ b/src/transport/plugin_transport_http_client.c
96 80
 @@ -49,7 +49,7 @@
97 81
  #include "gnunet_protocols.h"
98 82
  #include "gnunet_transport_plugin.h"

+ 77
- 0
net/gnunet/patches/100-musl-malloc.patch Прегледај датотеку

@@ -0,0 +1,77 @@
1
+--- a/src/util/gnunet-service-resolver.c
2
++++ b/src/util/gnunet-service-resolver.c
3
+@@ -603,7 +603,7 @@ main (int argc, char *const *argv)
4
+   return ret;
5
+ }
6
+ 
7
+-#ifdef LINUX
8
++#if defined(LINUX) && defined(__GLIBC__)
9
+ #include <malloc.h>
10
+ 
11
+ /**
12
+--- a/src/arm/gnunet-service-arm.c
13
++++ b/src/arm/gnunet-service-arm.c
14
+@@ -1563,7 +1563,7 @@ main (int argc, char *const *argv)
15
+ }
16
+ 
17
+ 
18
+-#ifdef LINUX
19
++#if defined(LINUX) && defined(__GLIBC__)
20
+ #include <malloc.h>
21
+ 
22
+ /**
23
+--- a/src/nse/gnunet-service-nse.c
24
++++ b/src/nse/gnunet-service-nse.c
25
+@@ -1629,7 +1629,7 @@ main (int argc,
26
+ }
27
+ 
28
+ 
29
+-#ifdef LINUX
30
++#if defined(LINUX) && defined(__GLIBC__)
31
+ #include <malloc.h>
32
+ 
33
+ /**
34
+--- a/src/regex/gnunet-daemon-regexprofiler.c
35
++++ b/src/regex/gnunet-daemon-regexprofiler.c
36
+@@ -382,7 +382,7 @@ main (int argc, char *const *argv)
37
+ }
38
+ 
39
+ 
40
+-#ifdef LINUX
41
++#if defined(LINUX) && defined(__GLIBC__)
42
+ #include <malloc.h>
43
+ 
44
+ /**
45
+--- a/src/revocation/gnunet-service-revocation.c
46
++++ b/src/revocation/gnunet-service-revocation.c
47
+@@ -933,7 +933,7 @@ main (int argc,
48
+ }
49
+ 
50
+ 
51
+-#ifdef LINUX
52
++#if defined(LINUX) && defined(__GLIBC__)
53
+ #include <malloc.h>
54
+ 
55
+ 
56
+--- a/src/statistics/gnunet-service-statistics.c
57
++++ b/src/statistics/gnunet-service-statistics.c
58
+@@ -1077,7 +1077,7 @@ main (int argc, char *const *argv)
59
+                               &run, NULL)) ? 0 : 1;
60
+ }
61
+ 
62
+-#ifdef LINUX
63
++#if defined(LINUX) && defined(__GLIBC__)
64
+ #include <malloc.h>
65
+ 
66
+ /**
67
+--- a/src/topology/gnunet-daemon-topology.c
68
++++ b/src/topology/gnunet-daemon-topology.c
69
+@@ -1327,7 +1327,7 @@ main (int argc, char *const *argv)
70
+ }
71
+ 
72
+ 
73
+-#ifdef LINUX
74
++#if defined(LINUX) && defined(__GLIBC__)
75
+ #include <malloc.h>
76
+ 
77
+ /**

+ 11
- 0
net/gnunet/patches/101-include-byteswap.patch Прегледај датотеку

@@ -0,0 +1,11 @@
1
+--- a/src/include/gnunet_common.h
2
++++ b/src/include/gnunet_common.h
3
+@@ -49,6 +49,8 @@
4
+ #include <stdarg.h>
5
+ #endif
6
+ 
7
++#include <byteswap.h>
8
++
9
+ #ifdef __cplusplus
10
+ extern "C"
11
+ {