|
@@ -0,0 +1,67 @@
|
|
1
|
+#
|
|
2
|
+# Copyright (C) 2006-2014 OpenWrt.org
|
|
3
|
+#
|
|
4
|
+# This is free software, licensed under the GNU General Public License v2.
|
|
5
|
+# See /LICENSE for more information.
|
|
6
|
+#
|
|
7
|
+
|
|
8
|
+include $(TOPDIR)/rules.mk
|
|
9
|
+
|
|
10
|
+PKG_NAME:=gdbm
|
|
11
|
+PKG_VERSION:=1.11
|
|
12
|
+PKG_RELEASE:=1
|
|
13
|
+
|
|
14
|
+PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
|
|
15
|
+PKG_SOURCE_URL:=@GNU/gdbm
|
|
16
|
+PKG_MD5SUM:=72c832680cf0999caedbe5b265c8c1bd
|
|
17
|
+
|
|
18
|
+PKG_LICENSE:=GPLv3
|
|
19
|
+PKG_LICENSE_FILES:=COPYING
|
|
20
|
+PKG_MAINTAINER:=Marcel Denia <naoir@gmx.net>
|
|
21
|
+
|
|
22
|
+PKG_FIXUP:=autoreconf
|
|
23
|
+PKG_REMOVE_FILES:=Makefile compat/Makefile doc/Makefile export/Makefile src/Makefile tests/Makefile
|
|
24
|
+PKG_BUILD_PARALLEL:=0
|
|
25
|
+
|
|
26
|
+include $(INCLUDE_DIR)/package.mk
|
|
27
|
+
|
|
28
|
+define Package/libgdbm
|
|
29
|
+ SECTION:=libs
|
|
30
|
+ CATEGORY:=Libraries
|
|
31
|
+ TITLE:=GNU database manager
|
|
32
|
+ URL:=http://www.gnu.org/software/gdbm/
|
|
33
|
+endef
|
|
34
|
+
|
|
35
|
+define Package/libgdbm/description
|
|
36
|
+ GNU database manager library
|
|
37
|
+ GNU dbm is a set of database routines that use extendible hashing and
|
|
38
|
+ works similar to the standard UNIX dbm routines.
|
|
39
|
+endef
|
|
40
|
+
|
|
41
|
+TARGET_CFLAGS += $(FPIC)
|
|
42
|
+
|
|
43
|
+CONFIGURE_ARGS += \
|
|
44
|
+ --enable-shared \
|
|
45
|
+ --enable-static \
|
|
46
|
+
|
|
47
|
+define Build/Compile
|
|
48
|
+ +$(MAKE) $(PKG_JOBS) -C $(PKG_BUILD_DIR) \
|
|
49
|
+ BINOWN=`id -u` \
|
|
50
|
+ BINGRP=`id -g` \
|
|
51
|
+ DESTDIR="$(PKG_INSTALL_DIR)" \
|
|
52
|
+ all install
|
|
53
|
+endef
|
|
54
|
+
|
|
55
|
+define Build/InstallDev
|
|
56
|
+ $(INSTALL_DIR) $(1)/usr/include
|
|
57
|
+ $(CP) $(PKG_INSTALL_DIR)/usr/include/gdbm.h $(1)/usr/include/
|
|
58
|
+ $(INSTALL_DIR) $(1)/usr/lib
|
|
59
|
+ $(CP) $(PKG_INSTALL_DIR)/usr/lib/libgdbm.{a,so*} $(1)/usr/lib/
|
|
60
|
+endef
|
|
61
|
+
|
|
62
|
+define Package/libgdbm/install
|
|
63
|
+ $(INSTALL_DIR) $(1)/usr/lib
|
|
64
|
+ $(CP) $(PKG_INSTALL_DIR)/usr/lib/libgdbm.so.* $(1)/usr/lib/
|
|
65
|
+endef
|
|
66
|
+
|
|
67
|
+$(eval $(call BuildPackage,libgdbm))
|