|
@@ -0,0 +1,70 @@
|
|
1
|
+#
|
|
2
|
+# Copyright (C) 2015 OpenWrt.org
|
|
3
|
+#
|
|
4
|
+# This is free software, licensed under the GNU General Public License v2.
|
|
5
|
+# See /LICENSE for more information.
|
|
6
|
+#
|
|
7
|
+
|
|
8
|
+include $(TOPDIR)/rules.mk
|
|
9
|
+
|
|
10
|
+PKG_NAME:=crelay
|
|
11
|
+PKG_VERSION:=0.8-081415
|
|
12
|
+PKG_RELEASE:=1
|
|
13
|
+
|
|
14
|
+PKG_SOURCE_PROTO:=git
|
|
15
|
+PKG_SOURCE_URL:=https://github.com/ondrej1024/crelay
|
|
16
|
+PKG_SOURCE_VERSION:=037360cf143d705ea97b32ae22460f346ad2586f
|
|
17
|
+PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
|
|
18
|
+PKG_SOURCE_SUBDIR:=$(PKG_NAME)-$(PKG_VERSION)
|
|
19
|
+
|
|
20
|
+PKG_MAINTAINER:=Ted Hess <thess@kitschensync.net>
|
|
21
|
+PKG_LICENSE:=GPL-2.0
|
|
22
|
+PKG_LICENSE_FILES:=LICENSE
|
|
23
|
+
|
|
24
|
+include $(INCLUDE_DIR)/package.mk
|
|
25
|
+
|
|
26
|
+define Package/crelay
|
|
27
|
+ SECTION:=utils
|
|
28
|
+ CATEGORY:=Utilities
|
|
29
|
+ TITLE:=USB relay remote control daemon
|
|
30
|
+ URL:=http://github.com/ondrej1024/crelay
|
|
31
|
+ DEPENDS:=+libftdi1 +hidapi +libusb-1.0
|
|
32
|
+endef
|
|
33
|
+
|
|
34
|
+define Package/crelay/description
|
|
35
|
+ crelay is used to control different relay cards in a unified manner. It provides
|
|
36
|
+ several interfaces for controlling the relays locally or remotely by a web browser
|
|
37
|
+ or a smartphone. The card which is detected first will be used. A WebUI control is
|
|
38
|
+ availble on port 8000 (default)
|
|
39
|
+ .
|
|
40
|
+ Currently supported relay cards:
|
|
41
|
+ - Conrad USB 4-channel relay card
|
|
42
|
+ - Sainsmart USB 4-channel relay card
|
|
43
|
+ - Generic GPIO relays
|
|
44
|
+ - HID API compatible relay card
|
|
45
|
+endef
|
|
46
|
+
|
|
47
|
+define Build/Configure
|
|
48
|
+endef
|
|
49
|
+
|
|
50
|
+TARGET_CFLAGS+= \
|
|
51
|
+ -D_GNU_SOURCE \
|
|
52
|
+ -I$(STAGING_DIR)/usr/include/libftdi1 \
|
|
53
|
+ -I$(STAGING_DIR)/usr/include/hidapi
|
|
54
|
+
|
|
55
|
+
|
|
56
|
+define Build/Compile
|
|
57
|
+ $(MAKE) -C $(PKG_BUILD_DIR)/src \
|
|
58
|
+ CC="$(TARGET_CC)" \
|
|
59
|
+ CFLAGS="$(TARGET_CFLAGS) $(EXTRA_CFLAGS) $(TARGET_CPPFLAGS) $(EXTRA_CPPFLAGS)" \
|
|
60
|
+ LDFLAGS="$(TARGET_LDFLAGS) $(EXTRA_LDFLAGS)"
|
|
61
|
+endef
|
|
62
|
+
|
|
63
|
+define Package/crelay/install
|
|
64
|
+ $(INSTALL_DIR) $(1)/usr/bin
|
|
65
|
+ $(INSTALL_BIN) $(PKG_BUILD_DIR)/src/crelay $(1)/usr/bin/
|
|
66
|
+ $(INSTALL_DIR) $(1)/etc/init.d
|
|
67
|
+ $(INSTALL_BIN) ./files/crelay.init $(1)/etc/init.d/crelay
|
|
68
|
+endef
|
|
69
|
+
|
|
70
|
+$(eval $(call BuildPackage,crelay))
|