Browse Source

keepalived: import from old packages feed

 - update to latest version (v1.2.15)
 - add license info
 - add myself as maintainer

Signed-off-by: Nicolas Thill <nico@openwrt.org>
Nicolas Thill 10 years ago
parent
commit
460237b52e
2 changed files with 82 additions and 0 deletions
  1. 68
    0
      net/keepalived/Makefile
  2. 14
    0
      net/keepalived/files/keepalived.init

+ 68
- 0
net/keepalived/Makefile View File

@@ -0,0 +1,68 @@
1
+#
2
+# Copyright (C) 2006-2015 OpenWrt.org
3
+#
4
+# This is free software, licensed under the GNU General Public License v2.
5
+# See /LICENSE for more information.
6
+#
7
+
8
+include $(TOPDIR)/rules.mk
9
+
10
+PKG_NAME:=keepalived
11
+PKG_VERSION:=1.2.15
12
+PKG_RELEASE:=1
13
+
14
+PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
15
+PKG_SOURCE_URL:= http://www.keepalived.org/software
16
+PKG_MD5SUM:=d85fcb8e564ea03b0ca7b2357bf30c51
17
+
18
+PKG_LICENSE:=GPL-2.0+
19
+PKG_LICENSE_FILES:=COPYING
20
+PKG_MAINTAINER:=Nicolas Thill <nico@openwrt.org>
21
+
22
+PKG_INSTALL:=1
23
+
24
+include $(INCLUDE_DIR)/package.mk
25
+include $(INCLUDE_DIR)/kernel.mk
26
+
27
+define Package/keepalived
28
+  SECTION:=net
29
+  CATEGORY:=Network
30
+  TITLE:=Failover and monitoring daemon for LVS clusters
31
+  URL:=http://www.keepalived.org/
32
+  DEPENDS:=+libnl +libopenssl
33
+endef
34
+
35
+define Package/keepalived/description
36
+ Failover and monitoring daemon for Linux Virtual Server (LVS) clusters.
37
+endef
38
+
39
+define Package/keepalived/conffiles
40
+/etc/keepalived/keepalived.conf
41
+endef
42
+
43
+CONFIGURE_ARGS+= \
44
+	--enable-vrrp \
45
+	--enable-fwmark \
46
+	--enable-sha1 \
47
+	--disable-lvs \
48
+	--disable-lvs-syncd \
49
+	--disable-snmp \
50
+	--disable-debug \
51
+	--disable-profile \
52
+	--with-kernel-dir="$(LINUX_DIR)/$(LINUX_UAPI_DIR)"
53
+
54
+MAKE_FLAGS += \
55
+		STRIP="/bin/true" \
56
+
57
+define Package/keepalived/install
58
+	$(INSTALL_DIR) $(1)/usr/sbin
59
+	$(CP) $(PKG_INSTALL_DIR)/usr/sbin/keepalived $(1)/usr/sbin/
60
+	$(INSTALL_DIR) $(1)/usr/bin
61
+	$(CP) $(PKG_INSTALL_DIR)/usr/bin/genhash $(1)/usr/bin/
62
+	$(INSTALL_DIR) $(1)/etc/keepalived
63
+	$(CP) $(PKG_INSTALL_DIR)/etc/keepalived/keepalived.conf $(1)/etc/keepalived/
64
+	$(INSTALL_DIR) $(1)/etc/init.d
65
+	$(INSTALL_BIN) ./files/keepalived.init $(1)/etc/init.d/keepalived
66
+endef
67
+
68
+$(eval $(call BuildPackage,keepalived))

+ 14
- 0
net/keepalived/files/keepalived.init View File

@@ -0,0 +1,14 @@
1
+#!/bin/sh /etc/rc.common
2
+# Copyright (C) 2007-2015 OpenWrt.org
3
+
4
+START=70
5
+
6
+SERVICE_USE_PID=1
7
+
8
+start() {
9
+	service_start /usr/sbin/keepalived
10
+}
11
+
12
+stop() {
13
+	service_stop /usr/sbin/keepalived
14
+}