Ver código fonte

openvswitch: work-around kernel architecture detection

caught on build-bot:
make -C /store/buildbot/slave/ramips/build/build_dir/target-mipsel_24kec+dsp_musl-1.1.11/linux-ramips_rt305x/linux-3.18.21 M=/store/buildbot/slave/ramips/build/build_dir/target-mipsel_24kec+dsp_musl-1.1.11/openvswitch-2.4.0/datapath/linux modules
make[7]: Entering directory `/store/buildbot/slave/ramips/build/build_dir/target-mipsel_24kec+dsp_musl-1.1.11/linux-ramips_rt305x/linux-3.18.21'
Makefile:610: arch/mipsel/Makefile: No such file or directory

Declare LINUX_KARCH to package's build-system to resolv this.

Signed-off-by: Daniel Golle <daniel@makrotopia.org>
Daniel Golle 9 anos atrás
pai
commit
46c7831304
1 arquivos alterados com 3 adições e 0 exclusões
  1. 3
    0
      net/openvswitch/Makefile

+ 3
- 0
net/openvswitch/Makefile Ver arquivo

@@ -116,6 +116,9 @@ CONFIGURE_ARGS += --enable-shared
116 116
 
117 117
 TARGET_CFLAGS += -flto -std=gnu99
118 118
 
119
+CONFIGURE_VARS += KARCH=$(LINUX_KARCH)
120
+MAKE_FLAGS += ARCH="$(LINUX_KARCH)"
121
+
119 122
 define Package/openvswitch/install
120 123
 	$(INSTALL_DIR) $(1)/etc/openvswitch
121 124