Browse Source

mc: update to 4.8.15

bump version to 4.8.15
fix charset / utf-8 support
fix different warnings during startup
merge all configuration files in /etc/mc
enable internal editor & charset support by default

Signed-off-by: Dirk Brenken <dirk@brenken.org>
Dirk Brenken 9 years ago
parent
commit
46d99ac2f4
2 changed files with 32 additions and 28 deletions
  1. 4
    5
      utils/mc/Config.in
  2. 28
    23
      utils/mc/Makefile

+ 4
- 5
utils/mc/Config.in View File

@@ -10,10 +10,10 @@ config MC_DIFFVIEWER
10 10
 
11 11
 config MC_EDITOR
12 12
 	bool "Enable internal editor"
13
-	default n
13
+	default y
14 14
 	help
15 15
            This option enables the built-in file editor.
16
-           Disabled by default.
16
+           Enabled by default.
17 17
 
18 18
 config MC_SUBSHELL
19 19
 	bool "Enable concurrent subshell"
@@ -41,12 +41,11 @@ config MC_BACKGROUND
41 41
 
42 42
 config MC_CHARSET
43 43
 	bool "Enable charset support"
44
-	default n
44
+	default y
45 45
 	help
46 46
            This option adds support for selecting character set of the text in
47 47
            the internal viewer and editor and converting it on the fly.
48
-           The implementation is currently incomplete.
49
-           Disabled by default.
48
+           Enabled by default.
50 49
 
51 50
 config MC_VFS
52 51
 	bool "Enable virtual filesystem support"

+ 28
- 23
utils/mc/Makefile View File

@@ -8,15 +8,14 @@
8 8
 include $(TOPDIR)/rules.mk
9 9
 
10 10
 PKG_NAME:=mc
11
-PKG_VERSION:=4.8.14
12
-PKG_RELEASE:=1.3
13
-PKG_MAINTAINER:=Dirk Brenken <dibdot@gmail.com>
11
+PKG_VERSION:=4.8.15
12
+PKG_RELEASE:=1
13
+PKG_MAINTAINER:=Dirk Brenken <dirk@brenken.org>
14 14
 PKG_LICENSE:=GPL-3.0+
15 15
 
16 16
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.xz
17 17
 PKG_SOURCE_URL:=http://ftp.midnight-commander.org/
18
-PKG_MD5SUM:=fbdaddb9edcf8925dcf3231331a8720b
19
-
18
+PKG_MD5SUM:=7c1935433866fdf59a3c2d9b7dae81ad
20 19
 PKG_BUILD_PARALLEL:=1
21 20
 PKG_FIXUP:=autoreconf
22 21
 
@@ -33,29 +32,32 @@ PKG_CONFIG_DEPENDS := \
33 32
 include $(INCLUDE_DIR)/package.mk
34 33
 include $(INCLUDE_DIR)/nls.mk
35 34
 
36
-define Package/mc
37
-  SECTION:=utils
38
-  CATEGORY:=Utilities
39
-  DEPENDS:=+glib2 +libncurses +libmount +MC_VFS:libssh2 $(LIBRPC_DEPENDS) $(ICONV_DEPENDS)
40
-  TITLE:=Midnight Commander - a powerful visual file manager
41
-  URL:=http://www.midnight-commander.org/
42
-  MENU:=1
35
+define Package/$(PKG_NAME)
36
+	SECTION:=utils
37
+	CATEGORY:=Utilities
38
+	DEPENDS:=+glib2 +libncurses +libmount +MC_VFS:libssh2 $(LIBRPC_DEPENDS) $(ICONV_DEPENDS)
39
+	TITLE:=Midnight Commander - a powerful visual file manager
40
+	URL:=http://www.midnight-commander.org/
41
+	MENU:=1
43 42
 endef
44 43
 
45
-define Package/mc/config
44
+define Package/$(PKG_NAME)/config
46 45
 	source "$(SOURCE)/Config.in"
47 46
 endef
48 47
 
49
-define Package/mc/description
50
- GNU Midnight Commander is a visual file manager,
51
- licensed under GNU General Public License and therefore qualifies as Free Software.
52
- It's a feature rich full-screen text mode application that allows you to copy,
53
- move and delete files and whole directory trees, search for files
54
- and run commands in the subshell. Internal viewer and editor are included.
48
+define Package/$(PKG_NAME)/description
49
+GNU Midnight Commander is a visual file manager,
50
+licensed under GNU General Public License and therefore qualifies as Free Software.
51
+It's a feature rich full-screen text mode application that allows you to copy,
52
+move and delete files and whole directory trees, search for files
53
+and run commands in the subshell. Internal viewer and editor are included.
54
+
55 55
 endef
56 56
 
57 57
 CONFIGURE_ARGS += \
58 58
 	--disable-doxygen-doc \
59
+	--with-homedir=/etc/mc \
60
+	--with-included-gettext \
59 61
 	--with-screen=ncurses \
60 62
 	--without-gpm-mouse \
61 63
 	--without-x \
@@ -98,10 +100,13 @@ CONFIGURE_ARGS += \
98 100
 	--disable-vfs
99 101
 endif
100 102
 
101
-define Package/mc/install
103
+define Package/$(PKG_NAME)/install
102 104
 	$(INSTALL_DIR) $(1)/usr/bin
103 105
 	$(INSTALL_BIN) $(PKG_BUILD_DIR)/src/mc $(1)/usr/bin
104 106
 	$(INSTALL_DIR) $(1)/etc/mc
107
+	$(INSTALL_DATA) $(PKG_BUILD_DIR)/misc/mc.charsets $(1)/etc/mc
108
+	$(INSTALL_DATA) $(PKG_BUILD_DIR)/misc/mc.keymap $(1)/etc/mc	
109
+	$(INSTALL_DATA) $(PKG_BUILD_DIR)/misc/mc.ext $(1)/etc/mc	
105 110
 ifeq ($(CONFIG_MC_DIFFVIEWER),y)
106 111
 	ln -sf mc $(1)/usr/bin/mcdiff
107 112
 endif
@@ -111,12 +116,12 @@ endif
111 116
 	$(INSTALL_DATA) $(PKG_BUILD_DIR)/misc/mc.menu $(1)/etc/mc
112 117
 	$(INSTALL_DIR) $(1)/etc/mc/skins
113 118
 	$(INSTALL_DATA) $(PKG_BUILD_DIR)/misc/skins/default.ini $(1)/etc/mc/skins
114
-	$(INSTALL_DIR) $(1)/root/.mc/cedit/Syntax
119
+	$(INSTALL_DIR) $(1)/etc/mc/mcedit/Syntax
115 120
 endef
116 121
 
117
-define Package/mc/conffiles
122
+define Package/$(PKG_NAME)/conffiles
118 123
 /etc/mc/mc.menu
119 124
 /etc/mc/skins/default.ini
120 125
 endef
121 126
 
122
-$(eval $(call BuildPackage,mc))
127
+$(eval $(call BuildPackage,$(PKG_NAME)))