Browse Source

sox: fix build dependencies and configure args as originally intended

Signed-off-by: Ted Hess <thess@kitschensync.net>
Ted Hess 10 years ago
parent
commit
476041c026
1 changed files with 7 additions and 6 deletions
  1. 7
    6
      sound/sox/Makefile

+ 7
- 6
sound/sox/Makefile View File

@@ -10,7 +10,7 @@ include $(TOPDIR)/rules.mk
10 10
 
11 11
 PKG_NAME:=sox
12 12
 PKG_VERSION:=14.4.1
13
-PKG_RELEASE:=1
13
+PKG_RELEASE:=2
14 14
 
15 15
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
16 16
 PKG_SOURCE_URL:=@SF/sox
@@ -29,7 +29,9 @@ TARGET_LDFLAGS+= \
29 29
 define Package/sox
30 30
   SECTION:=sound
31 31
   CATEGORY:=Sound
32
-  DEPENDS:=+BUILD_PATENTED:lame-lib +BUILD_PATENTED:libmad +BUILD_PATENTED:libid3tag +libvorbis +libvorbisidec +libgsm +alsa-lib +libsndfile +libflac +libmagic +libpng +libao +libffmpeg
32
+  DEPENDS:=+BUILD_PATENTED:lame-lib +BUILD_PATENTED:libmad +BUILD_PATENTED:libid3tag \
33
+		+libvorbis +libvorbisidec +alsa-lib +libsndfile +libflac \
34
+		+libmagic +libpng +libffmpeg
33 35
   TITLE:=Sox is a general purpose sound converter/player/recorder
34 36
   URL:=http://sox.sourceforge.net/
35 37
   MAINTAINER:=Hamish Guthrie <hcg@openwrt.org>
@@ -45,10 +47,9 @@ endef
45 47
 
46 48
 define Build/Configure
47 49
 	$(call Build/Configure/Default, \
48
-		--disable-external-gsm \
49
-		--disable-oss \
50
-		--enable-alsa \
51
-		--disable-libao \
50
+		--without-oss \
51
+		--without-ao \
52
+		--with-alsa \
52 53
 		--without-libltdl \
53 54
 		--with-ogg \
54 55
 		--with-flac \