Browse Source

python-pyopenssl: update to 16.0.0

Signed-off-by: Jeffery To <jeffery.to@gmail.com>
Jeffery To 9 years ago
parent
commit
478e0e6e66
2 changed files with 3 additions and 30 deletions
  1. 3
    3
      lang/python-pyopenssl/Makefile
  2. 0
    27
      lang/python-pyopenssl/patches/001-omit-tests.patch

+ 3
- 3
lang/python-pyopenssl/Makefile View File

@@ -1,5 +1,5 @@
1 1
 #
2
-# Copyright (C) 2015 OpenWrt.org
2
+# Copyright (C) 2015-2016 OpenWrt.org
3 3
 #
4 4
 # This is free software, licensed under the GNU General Public License v2.
5 5
 # See /LICENSE for more information.
@@ -8,12 +8,12 @@
8 8
 include $(TOPDIR)/rules.mk
9 9
 
10 10
 PKG_NAME:=pyOpenSSL
11
-PKG_VERSION:=0.15.1
11
+PKG_VERSION:=16.0.0
12 12
 PKG_RELEASE:=1
13 13
 
14 14
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
15 15
 PKG_SOURCE_URL:=https://pypi.python.org/packages/source/p/pyOpenSSL
16
-PKG_MD5SUM:=f447644afcbd5f0a1f47350fec63a4c6
16
+PKG_MD5SUM:=9587d813dcf656e9f2760e41a3682dc3
17 17
 
18 18
 PKG_BUILD_DEPENDS:=python python-setuptools
19 19
 

+ 0
- 27
lang/python-pyopenssl/patches/001-omit-tests.patch View File

@@ -1,27 +0,0 @@
1
-diff --git a/setup.py b/setup.py
2
-index c376f87..6444fac 100755
3
---- a/setup.py
4
-+++ b/setup.py
5
-@@ -22,14 +22,7 @@ setup(name='pyOpenSSL', version=__version__,
6
-                      'OpenSSL.rand',
7
-                      'OpenSSL.crypto',
8
-                      'OpenSSL.SSL',
9
--                     'OpenSSL.version',
10
--                     'OpenSSL.test.__init__',
11
--                     'OpenSSL.test.util',
12
--                     'OpenSSL.test.test_crypto',
13
--                     'OpenSSL.test.test_rand',
14
--                     'OpenSSL.test.test_ssl',
15
--                     'OpenSSL.test.test_tsafe',
16
--                     'OpenSSL.test.test_util',],
17
-+                     'OpenSSL.version',],
18
-       description = 'Python wrapper module around the OpenSSL library',
19
-       author = 'Jean-Paul Calderone',
20
-       author_email = 'exarkun@twistedmatrix.com',
21
-@@ -74,5 +67,4 @@ High-level wrapper around a subset of the OpenSSL library, includes
22
-         'Topic :: Security :: Cryptography',
23
-         'Topic :: Software Development :: Libraries :: Python Modules',
24
-         'Topic :: System :: Networking',
25
--        ],
26
--      test_suite="OpenSSL")
27
-+        ])