Pārlūkot izejas kodu

gcc: work around wrongly detected sys/sdt.h header.

The build system somehow detects /usr/include/sys/sdt.h, which is part of systemtap-sdt-devel
package in the host environment but not present in the SDK.

This patch simply disables the check for sys/sdt.h, enabling building of this package when
systemtap-sdt-devel is installed in the host environment.

Signed-off-by: Christian Beier <dontmind@freeshell.org>
Christian Beier 10 gadus atpakaļ
vecāks
revīzija
480452dce8

+ 45
- 0
devel/gcc/patches/020-disable-check-for-sys-sdt-h.patch Parādīt failu

@@ -0,0 +1,45 @@
1
+diff --git a/gcc/configure b/gcc/configure
2
+index 3793681..bcda752 100755
3
+--- a/gcc/configure
4
++++ b/gcc/configure
5
+@@ -26876,19 +26876,6 @@ $as_echo "#define TARGET_LIBC_PROVIDES_SSP 1" >>confdefs.h
6
+ 
7
+ fi
8
+ 
9
+-# Test for <sys/sdt.h> on the target.
10
+-
11
+-{ $as_echo "$as_me:${as_lineno-$LINENO}: checking sys/sdt.h in the target C library" >&5
12
+-$as_echo_n "checking sys/sdt.h in the target C library... " >&6; }
13
+-have_sys_sdt_h=no
14
+-if test -f $target_header_dir/sys/sdt.h; then
15
+-  have_sys_sdt_h=yes
16
+-
17
+-$as_echo "#define HAVE_SYS_SDT_H 1" >>confdefs.h
18
+-
19
+-fi
20
+-{ $as_echo "$as_me:${as_lineno-$LINENO}: result: $have_sys_sdt_h" >&5
21
+-$as_echo "$have_sys_sdt_h" >&6; }
22
+ 
23
+ # Check if TFmode long double should be used by default or not.
24
+ # Some glibc targets used DFmode long double, but with glibc 2.4
25
+diff --git a/gcc/configure.ac b/gcc/configure.ac
26
+index 3ee1d67..e321218 100644
27
+--- a/gcc/configure.ac
28
++++ b/gcc/configure.ac
29
+@@ -4796,16 +4796,6 @@ if test x$gcc_cv_libc_provides_ssp = xyes; then
30
+ 	    [Define if your target C library provides stack protector support])
31
+ fi
32
+ 
33
+-# Test for <sys/sdt.h> on the target.
34
+-GCC_TARGET_TEMPLATE([HAVE_SYS_SDT_H])
35
+-AC_MSG_CHECKING(sys/sdt.h in the target C library)
36
+-have_sys_sdt_h=no
37
+-if test -f $target_header_dir/sys/sdt.h; then
38
+-  have_sys_sdt_h=yes
39
+-  AC_DEFINE(HAVE_SYS_SDT_H, 1,
40
+-            [Define if your target C library provides sys/sdt.h])
41
+-fi
42
+-AC_MSG_RESULT($have_sys_sdt_h)
43
+ 
44
+ # Check if TFmode long double should be used by default or not.
45
+ # Some glibc targets used DFmode long double, but with glibc 2.4