Browse Source

Import argp-standalone from oldpackages, update copyright, and license info

Signed-off-by: Ted Hess <thess@kitschensync.net>
Ted Hess 10 years ago
parent
commit
4920a44067

+ 47
- 0
libs/argp-standalone/Makefile View File

@@ -0,0 +1,47 @@
1
+#
2
+# Copyright (C) 2007-2014 OpenWrt.org
3
+#
4
+# This is free software, licensed under the GNU General Public License v2.
5
+# See /LICENSE for more information.
6
+#
7
+
8
+include $(TOPDIR)/rules.mk
9
+
10
+PKG_NAME:=argp-standalone
11
+PKG_VERSION:=1.3
12
+PKG_RELEASE:=1
13
+
14
+PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
15
+PKG_SOURCE_URL:=http://www.lysator.liu.se/~nisse/misc/
16
+PKG_MD5SUM:=720704bac078d067111b32444e24ba69
17
+
18
+PKG_LICENSE:=LGPL-2.1
19
+PKG_LICENSE:=Makefile.am
20
+
21
+include $(INCLUDE_DIR)/package.mk
22
+
23
+define Package/argp-standalone
24
+  SECTION:=libs
25
+  CATEGORY:=Libraries
26
+  TITLE:=Hierarchial argument parsing broken out from glibc
27
+  URL:=http://www.lysator.liu.se/~nisse/misc/
28
+endef
29
+
30
+define Package/argp-standalone/description
31
+  GNU libc hierarchial argument parsing library broken out from glibc.
32
+endef
33
+
34
+MAKE_FLAGS += \
35
+	CFLAGS="$(TARGET_CFLAGS) $(FPIC)"
36
+
37
+
38
+define Build/InstallDev
39
+	$(INSTALL_DIR) $(1)/usr/include
40
+	$(CP)   $(PKG_BUILD_DIR)/argp.h \
41
+		$(1)/usr/include/
42
+	$(INSTALL_DIR) $(1)/usr/lib
43
+	$(CP)   $(PKG_BUILD_DIR)/libargp.a \
44
+		$(1)/usr/lib/
45
+endef
46
+
47
+$(eval $(call BuildPackage,argp-standalone))

+ 79
- 0
libs/argp-standalone/patches/001-throw-in-funcdef.patch View File

@@ -0,0 +1,79 @@
1
+# --- T2-COPYRIGHT-NOTE-BEGIN ---
2
+# This copyright note is auto-generated by ./scripts/Create-CopyPatch.
3
+# 
4
+# T2 SDE: package/.../rng-tools/throw-in-funcdef.patch.argp-standalone
5
+# Copyright (C) 2006 The T2 SDE Project
6
+# 
7
+# More information can be found in the files COPYING and README.
8
+# 
9
+# This patch file is dual-licensed. It is available under the license the
10
+# patched project is licensed under, as long as it is an OpenSource license
11
+# as defined at http://www.opensource.org/ (e.g. BSD, X11) or under the terms
12
+# of the GNU General Public License as published by the Free Software
13
+# Foundation; either version 2 of the License, or (at your option) any later
14
+# version.
15
+# --- T2-COPYRIGHT-NOTE-END ---
16
+
17
+
18
+No __THROW in function implementation.
19
+	--jsaw
20
+
21
+--- argp-standalone-1.4-test2/argp.h.orig	2006-01-06 02:29:59.000000000 +0100
22
++++ argp-standalone-1.4-test2/argp.h	2006-01-06 02:41:10.000000000 +0100
23
+@@ -560,17 +560,17 @@
24
+ # endif
25
+ 
26
+ # ifndef ARGP_EI
27
+-#  define ARGP_EI extern __inline__
28
++#  define ARGP_EI extern inline
29
+ # endif
30
+ 
31
+ ARGP_EI void
32
+-__argp_usage (__const struct argp_state *__state) __THROW
33
++__argp_usage (__const struct argp_state *__state)
34
+ {
35
+   __argp_state_help (__state, stderr, ARGP_HELP_STD_USAGE);
36
+ }
37
+ 
38
+ ARGP_EI int
39
+-__option_is_short (__const struct argp_option *__opt) __THROW
40
++__option_is_short (__const struct argp_option *__opt)
41
+ {
42
+   if (__opt->flags & OPTION_DOC)
43
+     return 0;
44
+@@ -582,7 +582,7 @@
45
+ }
46
+ 
47
+ ARGP_EI int
48
+-__option_is_end (__const struct argp_option *__opt) __THROW
49
++__option_is_end (__const struct argp_option *__opt)
50
+ {
51
+   return !__opt->key && !__opt->name && !__opt->doc && !__opt->group;
52
+ }
53
+--- argp-standalone-1.4-test2/argp-parse.c.orig	2006-01-06 02:47:48.000000000 +0100
54
++++ argp-standalone-1.4-test2/argp-parse.c	2006-01-06 02:48:16.000000000 +0100
55
+@@ -1290,13 +1290,13 @@
56
+ /* Defined here, in case a user is not inlining the definitions in
57
+  * argp.h */
58
+ void
59
+-__argp_usage (__const struct argp_state *__state) __THROW
60
++__argp_usage (__const struct argp_state *__state)
61
+ {
62
+   __argp_state_help (__state, stderr, ARGP_HELP_STD_USAGE);
63
+ }
64
+ 
65
+ int
66
+-__option_is_short (__const struct argp_option *__opt) __THROW
67
++__option_is_short (__const struct argp_option *__opt) 
68
+ {
69
+   if (__opt->flags & OPTION_DOC)
70
+     return 0;
71
+@@ -1310,7 +1310,7 @@
72
+ }
73
+ 
74
+ int
75
+-__option_is_end (__const struct argp_option *__opt) __THROW
76
++__option_is_end (__const struct argp_option *__opt) 
77
+ {
78
+   return !__opt->key && !__opt->name && !__opt->doc && !__opt->group;
79
+ }