|
@@ -0,0 +1,49 @@
|
|
1
|
+#
|
|
2
|
+# Copyright (C) 2006-2014 OpenWrt.org
|
|
3
|
+#
|
|
4
|
+# This is free software, licensed under the GNU General Public License v2.
|
|
5
|
+# See /LICENSE for more information.
|
|
6
|
+#
|
|
7
|
+
|
|
8
|
+include $(TOPDIR)/rules.mk
|
|
9
|
+
|
|
10
|
+PKG_NAME:=zile
|
|
11
|
+PKG_VERSION:=2.3.24
|
|
12
|
+PKG_RELEASE:=1
|
|
13
|
+
|
|
14
|
+PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
|
|
15
|
+PKG_SOURCE_URL:=@GNU/zile
|
|
16
|
+PKG_MD5SUM:=fe77d801ba69e0fb9b4914a04b9ff506
|
|
17
|
+PKG_MAINTAINER:=Ted Hess <thess@kitschensync.net>
|
|
18
|
+
|
|
19
|
+PKG_LICENSE:=GPL-3.0+
|
|
20
|
+PKG_LICENSE_FILE:=COPYING
|
|
21
|
+
|
|
22
|
+PKG_INSTALL:=1
|
|
23
|
+
|
|
24
|
+include $(INCLUDE_DIR)/package.mk
|
|
25
|
+
|
|
26
|
+define Package/zile
|
|
27
|
+ SECTION:=utils
|
|
28
|
+ CATEGORY:=Utilities
|
|
29
|
+ DEPENDS:=+libncursesw
|
|
30
|
+ TITLE:=very small emacs-like editor
|
|
31
|
+ URL:=http://www.gnu.org/software/zile/
|
|
32
|
+ SUBMENU:=Editors
|
|
33
|
+endef
|
|
34
|
+
|
|
35
|
+define Package/zile/description
|
|
36
|
+ Zile is a small Emacs clone. Zile is a customizable, self-documenting
|
|
37
|
+ real-time display editor. Zile was written to be as similar as possible
|
|
38
|
+ to Emacs; every Emacs user should feel at home with Zile.
|
|
39
|
+endef
|
|
40
|
+
|
|
41
|
+CONFIGURE_VARS += \
|
|
42
|
+ gl_cv_func_getopt_gnu=yes
|
|
43
|
+
|
|
44
|
+define Package/zile/install
|
|
45
|
+ $(INSTALL_DIR) $(1)/usr/bin
|
|
46
|
+ $(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/bin/$(PKG_NAME) $(1)/usr/bin/
|
|
47
|
+endef
|
|
48
|
+
|
|
49
|
+$(eval $(call BuildPackage,zile))
|