瀏覽代碼

bind: build fix: remove autoconf AR cruft

This patch removes some autoconf goo which is causing bind to use the host's ar
instead the ar from the toolchain.  If they're both elf platforms this is fine,
but it's no good if host is darwin.

Signed-off-by: Lawrence D'Anna <larry@elder-gods.org>
Lawrence D'Anna 10 年之前
父節點
當前提交
4a02aa766f
共有 1 個文件被更改,包括 29 次插入0 次删除
  1. 29
    0
      net/bind/patches/002-autoconf-ar-fix.patch

+ 29
- 0
net/bind/patches/002-autoconf-ar-fix.patch 查看文件

@@ -0,0 +1,29 @@
1
+--- a/configure.in
2
++++ b/configure.in
3
+@@ -93,26 +93,11 @@ esac
4
+ #
5
+ AC_CONFIG_FILES([make/rules make/includes])
6
+ 
7
+-AC_PATH_PROG(AR, ar)
8
+-ARFLAGS="cruv"
9
+-AC_SUBST(AR)
10
+-AC_SUBST(ARFLAGS)
11
+-
12
+ # The POSIX ln(1) program.  Non-POSIX systems may substitute
13
+ # "copy" or something.
14
+ LN=ln
15
+ AC_SUBST(LN)
16
+ 
17
+-case "$AR" in
18
+-	"")
19
+-		AC_MSG_ERROR([
20
+-ar program not found.  Please fix your PATH to include the directory in
21
+-which ar resides, or set AR in the environment with the full path to ar.
22
+-])
23
+-
24
+-		;;
25
+-esac
26
+-
27
+ #
28
+ # Etags.
29
+ #