Browse Source

Import libowfat

Signed-off-by: Daniel Golle <daniel@makrotopia.org>
Daniel Golle 10 years ago
parent
commit
4a5b047c08
1 changed files with 59 additions and 0 deletions
  1. 59
    0
      libs/libowfat/Makefile

+ 59
- 0
libs/libowfat/Makefile View File

@@ -0,0 +1,59 @@
1
+#
2
+# Copyright (C) 2010-2014 OpenWrt.org
3
+#
4
+# This is free software, licensed under the GNU General Public License v2.
5
+# See /LICENSE for more information.
6
+#
7
+
8
+include $(TOPDIR)/rules.mk
9
+
10
+LOWFAT_VERSION=0.28
11
+
12
+PKG_NAME:=libowfat
13
+PKG_VERSION:=$(LOWFAT_VERSION)
14
+PKG_RELEASE:=2
15
+
16
+PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
17
+PKG_SOURCE_URL:=http://dl.fefe.de
18
+PKG_MD5SUM:=6bbee9a86506419657d87123b7a6f2c1
19
+PKG_MAINTAINER:=Daniel Golle <daniel@makrotopia.org>
20
+
21
+include $(INCLUDE_DIR)/package.mk
22
+
23
+# set to 1 to enable debugging
24
+DEBUG=
25
+
26
+define Package/libowfat
27
+  SECTION:=libs
28
+  CATEGORY:=Libraries
29
+  TITLE:=reimplemented libdjb under GPL
30
+  URL:=http://www.fefe.de/libowfat/
31
+endef
32
+
33
+define Build/Configure
34
+endef
35
+
36
+TARGET_CFLAGS += $(FPIC)
37
+LOWFAT_MAKEOPTS = $(TARGET_CONFIGURE_OPTS) \
38
+	CFLAGS="$(TARGET_CFLAGS) -I$(PKG_BUILD_DIR) -I$(STAGING_DIR)/usr/include" \
39
+	DEBUG="$(DEBUG)" \
40
+	VERSION="$(LOWFAT_VERSION)" \
41
+	OS="Linux"
42
+
43
+# work around a nasty gcc bug
44
+ifneq ($(CONFIG_GCC_VERSION_4_2_4),)
45
+  LOWFAT_MAKEOPTS += WOPTS=""
46
+endif
47
+
48
+define Build/Compile
49
+	$(MAKE) -C $(PKG_BUILD_DIR) $(LOWFAT_MAKEOPTS)
50
+endef
51
+
52
+define Build/InstallDev
53
+	mkdir -p $(1)/usr/include/libowfat
54
+	$(CP) $(PKG_BUILD_DIR)/*.h $(1)/usr/include/libowfat
55
+	$(INSTALL_DIR) $(1)/usr/lib
56
+	$(CP) $(PKG_BUILD_DIR)/*.a $(1)/usr/lib
57
+endef
58
+
59
+$(eval $(call BuildPackage,libowfat))