Bladeren bron

libxml2: add host compile

Several packages may depend on host compiled packages during
the build time (such as the new LTS versions of telephony packages).

This commit adds an option to use the libxml2 to be built as
a host package. Usage would be following:

	PKG_BUILD_DEPENDS:=libxml2/host

Signed-off-by: Jiri Slachta <slachta@cesnet.cz>
Jiri Slachta 10 jaren geleden
bovenliggende
commit
4b3cf1a604
1 gewijzigde bestanden met toevoegingen van 35 en 1 verwijderingen
  1. 35
    1
      libs/libxml2/Makefile

+ 35
- 1
libs/libxml2/Makefile Bestand weergeven

@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
9 9
 
10 10
 PKG_NAME:=libxml2
11 11
 PKG_VERSION:=2.9.2
12
-PKG_RELEASE:=1
12
+PKG_RELEASE:=2
13 13
 
14 14
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
15 15
 PKG_SOURCE_URL:=http://gd.tuwien.ac.at/languages/libxml/ \
@@ -26,6 +26,7 @@ PKG_FIXUP:=autoreconf
26 26
 PKG_INSTALL:=1
27 27
 PKG_BUILD_PARALLEL:=1
28 28
 
29
+include $(INCLUDE_DIR)/host-build.mk
29 30
 include $(INCLUDE_DIR)/package.mk
30 31
 
31 32
 define Package/libxml2
@@ -74,6 +75,38 @@ CONFIGURE_ARGS += \
74 75
 	--with-zlib \
75 76
 	--without-lzma
76 77
 
78
+HOST_CONFIGURE_ARGS += \
79
+	--enable-shared \
80
+	--enable-static \
81
+	--with-c14n \
82
+	--without-catalog \
83
+	--with-debug \
84
+	--without-docbook \
85
+	--with-html \
86
+	--without-ftp \
87
+	--without-http \
88
+	--without-iconv \
89
+	--without-iso8859x \
90
+	--without-legacy \
91
+	--with-output \
92
+	--without-pattern \
93
+	--without-push \
94
+	--without-python \
95
+	--with-reader \
96
+	--without-readline \
97
+	--without-regexps \
98
+	--with-sax1 \
99
+	--with-schemas \
100
+	--with-threads \
101
+	--with-tree \
102
+	--with-valid \
103
+	--with-writer \
104
+	--with-xinclude \
105
+	--with-xpath \
106
+	--with-xptr \
107
+	--with-zlib \
108
+	--without-lzma
109
+
77 110
 define Build/InstallDev
78 111
 	$(INSTALL_DIR) $(2)/bin
79 112
 	$(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/bin/xml2-config $(2)/bin/
@@ -97,4 +130,5 @@ define Package/libxml2/install
97 130
 	$(CP) $(PKG_INSTALL_DIR)/usr/lib/libxml2.so* $(1)/usr/lib/
98 131
 endef
99 132
 
133
+$(eval $(call HostBuild))
100 134
 $(eval $(call BuildPackage,libxml2))