Ver código fonte

seafile: build against libevhtp 1.1 instead of 1.2

This fixes multiple issues like upload/download problems on seahub
and also makes it possible to use the new HTTP syncing feature
which doesn't work with libevhtp 1.2.10 at all.
Gergely Kiss 9 anos atrás
pai
commit
4b897fe764

+ 4
- 3
net/seafile-server/Makefile Ver arquivo

@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
9 9
 
10 10
 PKG_NAME:=seafile-server
11 11
 PKG_VERSION:=4.1.2
12
-PKG_RELEASE=$(PKG_SOURCE_VERSION)
12
+PKG_RELEASE=$(PKG_SOURCE_VERSION)-2
13 13
 PKG_LICENSE:=GPL-3.0
14 14
 
15 15
 PKG_SOURCE_PROTO:=git
@@ -31,7 +31,7 @@ define Package/seafile-server
31 31
     URL:=http://seafile.com/
32 32
     DEPENDS:=+shadow-useradd +libarchive +libopenssl +glib2 +libsearpc +seafile-ccnet +seafile-seahub \
33 33
 		+sqlite3-cli +python-mysql +jansson +libevent2 +libevent2-openssl +zlib +libzdb +libsqlite3 \
34
-		+libmysqlclient +libevhtp +libpthread +libuuid \
34
+		+libmysqlclient +libpthread +libuuid \
35 35
 		+bash +sudo +procps +procps-pkill $(ICONV_DEPENDS)
36 36
     EXTRA_DEPENDS:=seafile-ccnet (=4.1.2-a73109f09af4ecc49cdc4c57cdde51b38e15c31a), seafile-seahub (=4.1.2-3fb1288f920de03a4e2e6a06b60671ce98971742)
37 37
 endef
@@ -54,7 +54,8 @@ CONFIGURE_ARGS += --disable-riak \
54 54
 		    --disable-console
55 55
 
56 56
 PKG_BUILD_DEPENDS:=vala/host \
57
-		    libsearpc/host
57
+		    libsearpc/host \
58
+		    libevhtp-1.1
58 59
 
59 60
 TARGET_LDFLAGS += -Wl,-rpath-link=$(STAGING_DIR)/usr/lib -liconv \
60 61
 		    -L$(STAGING_DIR)/usr/lib/mysql -lmysqlclient -lz

+ 17
- 0
net/seafile-server/patches/050-libevhtp-search-path-fix.patch Ver arquivo

@@ -0,0 +1,17 @@
1
+diff -rupN seafile-server-4.1.2.orig/server/Makefile.am seafile-server-4.1.2/server/Makefile.am
2
+--- seafile-server-4.1.2.orig/server/Makefile.am	2015-05-02 11:04:11.000000000 +0200
3
++++ seafile-server-4.1.2/server/Makefile.am	2015-06-14 01:28:55.924834806 +0200
4
+@@ -4,6 +4,7 @@ AM_CFLAGS = -DPKGDATADIR=\"$(pkgdatadir)
5
+ 	-DPACKAGE_DATA_DIR=\""$(pkgdatadir)"\" \
6
+ 	-DSEAFILE_SERVER \
7
+ 	-DFULL_FEATURE \
8
++	-I$(STAGING_DIR)/usr/include/libevhtp-1.1 \
9
+ 	-I$(top_srcdir)/include \
10
+ 	-I$(top_srcdir)/lib \
11
+ 	-I$(top_builddir)/lib \
12
+@@ -122,4 +123,4 @@ seaf_server_LDADD = @CCNET_LIBS@ \
13
+ 	@SEARPC_LIBS@ @JANSSON_LIBS@ @ZDB_LIBS@ @CURL_LIBS@ ${LIB_WS32} @ZLIB_LIBS@ \
14
+ 	@LIBARCHIVE_LIBS@
15
+ 
16
+-seaf_server_LDFLAGS = @STATIC_COMPILE@ @SERVER_PKG_RPATH@
17
++seaf_server_LDFLAGS = @STATIC_COMPILE@ @SERVER_PKG_RPATH@ -L$(STAGING_DIR)/usr/lib/libevhtp-1.1