Browse Source

mosquitto: properly separate the passwd utility

Building both variants improperly tried to include the passwd utility
for the non-ssl variant, as the variable was set for the ssl variant.

Use properly separated install tasks to install additional files, rather
than hacking around inside the single target.

Signed-off-by: Karl Palsson <karlp@remake.is>
Karl Palsson 9 years ago
parent
commit
4c35fd1a80
1 changed files with 12 additions and 5 deletions
  1. 12
    5
      net/mosquitto/Makefile

+ 12
- 5
net/mosquitto/Makefile View File

@@ -145,12 +145,9 @@ endef
145 145
 
146 146
 Package/$(PKG_NAME)-nossl/conffiles = $(Package/$(PKG_NAME)/conffiles)
147 147
 
148
-define Package/$(PKG_NAME)/install
148
+define Package/mosquitto/install/default
149 149
 	$(INSTALL_DIR) $(1)/usr/sbin
150 150
 	$(INSTALL_BIN) $(PKG_BUILD_DIR)/src/mosquitto $(1)/usr/sbin/mosquitto
151
-ifeq ($(CONFIG_MOSQUITTO_PASSWD),y)
152
-	$(INSTALL_BIN) $(PKG_BUILD_DIR)/src/mosquitto_passwd $(1)/usr/sbin
153
-endif
154 151
 	$(INSTALL_DIR) $(1)/etc/mosquitto
155 152
 	$(INSTALL_CONF) $(PKG_BUILD_DIR)/mosquitto.conf $(1)/etc/mosquitto/mosquitto.conf
156 153
 	$(INSTALL_DIR) $(1)/etc/init.d
@@ -158,8 +155,18 @@ endif
158 155
 	$(INSTALL_DIR) $(1)/usr/bin
159 156
 	$(INSTALL_BIN) ./files/mosquitto.uci.convert $(1)/usr/bin
160 157
 endef
161
-Package/$(PKG_NAME)-nossl/install = $(Package/$(PKG_NAME)/install)
162 158
 
159
+define Package/mosquitto-nossl/install
160
+	$(call Package/mosquitto/install/default,$(1))
161
+endef
162
+
163
+define Package/mosquitto/install
164
+	$(call Package/mosquitto/install/default,$(1))
165
+ifeq ($(CONFIG_MOSQUITTO_PASSWD),y)
166
+	$(INSTALL_DIR) $(1)/usr/bin
167
+	$(INSTALL_BIN) $(PKG_BUILD_DIR)/src/mosquitto_passwd $(1)/usr/bin
168
+endif
169
+endef
163 170
 
164 171
 define Package/mosquitto-client/install
165 172
 	$(INSTALL_DIR) $(1)/usr/bin