瀏覽代碼

lang/perl: Add hack to make perl always use miniperl during build

Signed-off-by: Marcel Denia <naoir@gmx.net>
Marcel Denia 10 年之前
父節點
當前提交
4c57844f0f
共有 1 個文件被更改,包括 27 次插入0 次删除
  1. 27
    0
      lang/perl/patches/300-always_use_miniperl.patch

+ 27
- 0
lang/perl/patches/300-always_use_miniperl.patch 查看文件

@@ -0,0 +1,27 @@
1
+--- a/Makefile.SH
2
++++ b/Makefile.SH
3
+@@ -315,22 +315,11 @@ MINIPERL = \$(LDLIBPTH) ./miniperl\$(EXE
4
+ 
5
+ !GROK!THIS!
6
+ 
7
+-case "$usecrosscompile$perl" in
8
+-define?*)
9
+-	$spitshell >>$Makefile <<!GROK!THIS!
10
+-# Macros to invoke a copy of our fully operational perl during the build.
11
+-PERL_EXE = perl\$(EXE_EXT)
12
+-RUN_PERL = \$(LDLIBPTH) \$(RUN) $perl\$(EXE_EXT)
13
+-!GROK!THIS!
14
+-	;;
15
+-*)
16
+-	$spitshell >>$Makefile <<!GROK!THIS!
17
++$spitshell >>$Makefile <<!GROK!THIS!
18
+ # Macros to invoke a copy of our fully operational perl during the build.
19
+ PERL_EXE = perl\$(EXE_EXT)
20
+-RUN_PERL = \$(LDLIBPTH) \$(RUN) ./perl\$(EXE_EXT) -Ilib
21
++RUN_PERL = \$(LDLIBPTH) \$(RUN) ./miniperl\$(EXE_EXT) -Ilib
22
+ !GROK!THIS!
23
+-	;;
24
+-esac
25
+ 
26
+ $spitshell >>$Makefile <<!GROK!THIS!
27
+ # Macros to run our tests