Browse Source

mc: move to github

Signed-off-by: Dirk Brenken <dibdot@gmail.com>
Dirk Brenken 10 years ago
parent
commit
4d24d41805
2 changed files with 117 additions and 0 deletions
  1. 20
    0
      utils/mc/Config.in
  2. 97
    0
      utils/mc/Makefile

+ 20
- 0
utils/mc/Config.in View File

@@ -0,0 +1,20 @@
1
+menu "Configuration"
2
+	depends on PACKAGE_mc
3
+
4
+config MC_DIFF_VIEWER
5
+	bool "Compile with diff viewer"
6
+	default n
7
+
8
+config MC_EDITOR
9
+	bool "Enable internal editor"
10
+	default n
11
+
12
+config MC_SUBSHELL
13
+	bool "Compile in concurrent subshell"
14
+	default n
15
+
16
+config MC_DISABLE_VFS
17
+	bool "Disable VFS"
18
+	default y
19
+
20
+endmenu

+ 97
- 0
utils/mc/Makefile View File

@@ -0,0 +1,97 @@
1
+#
2
+# Copyright (C) 2006-2014 OpenWrt.org
3
+#
4
+# This is free software, licensed under the GNU General Public License v2.
5
+# See /LICENSE for more information.
6
+#
7
+
8
+include $(TOPDIR)/rules.mk
9
+
10
+PKG_NAME:=mc
11
+PKG_VERSION:=4.8.13
12
+PKG_RELEASE:=1
13
+PKG_MAINTAINER:=Dirk Brenken <dibdot@gmail.com>
14
+PKG_LICENSE:=GPL-3.0+
15
+
16
+PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.xz
17
+PKG_SOURCE_URL:=http://ftp.midnight-commander.org/
18
+PKG_MD5SUM:=d967caa12765eb86e52a6a63ca202500
19
+
20
+PKG_BUILD_PARALLEL:=1
21
+PKG_FIXUP:=autoreconf
22
+
23
+include $(INCLUDE_DIR)/package.mk
24
+include $(INCLUDE_DIR)/nls.mk
25
+
26
+define Package/mc
27
+  SECTION:=utils
28
+  CATEGORY:=Utilities
29
+  DEPENDS:=+glib2 +libncurses $(LIBRPC_DEPENDS) $(ICONV_DEPENDS)
30
+  TITLE:=Midnight Commander - a powerful visual file manager
31
+  URL:=http://www.midnight-commander.org/
32
+  MENU:=1
33
+endef
34
+
35
+define Package/mc/config
36
+	source "$(SOURCE)/Config.in"
37
+endef
38
+
39
+define Package/mc/description
40
+ GNU Midnight Commander is a visual file manager, 
41
+ licensed under GNU General Public License and therefore qualifies as Free Software.
42
+ It's a feature rich full-screen text mode application that allows you to copy, 
43
+ move and delete files and whole directory trees, search for files 
44
+ and run commands in the subshell. Internal viewer and editor are included. 
45
+endef
46
+
47
+CONFIGURE_ARGS += \
48
+	--enable-utf8 \
49
+	--disable-doxygen-doc \
50
+	--disable-vfs-sftp \
51
+	--with-screen=ncurses \
52
+	--without-gpm-mouse \
53
+	--without-x \
54
+	ac_cv_search_addwstr=no
55
+
56
+ifeq ($(CONFIG_MC_DIFF_VIEWER),n)
57
+CONFIGURE_ARGS += \
58
+	--without-diff-viewer
59
+endif
60
+
61
+ifeq ($(CONFIG_MC_EDITOR),n)
62
+CONFIGURE_ARGS += \
63
+	--without-edit
64
+endif
65
+
66
+ifeq ($(CONFIG_MC_SUBSHELL),n)
67
+CONFIGURE_ARGS += \
68
+	--without-subshell
69
+endif
70
+
71
+ifeq ($(CONFIG_MC_DISABLE_VFS),y)
72
+CONFIGURE_ARGS += \
73
+	--without-vfs
74
+endif
75
+
76
+define Package/mc/install
77
+	$(INSTALL_DIR) $(1)/usr/bin
78
+	$(INSTALL_BIN) $(PKG_BUILD_DIR)/src/mc $(1)/usr/bin
79
+	$(INSTALL_DIR) $(1)/etc/mc
80
+ifeq ($(CONFIG_MC_DIFF_VIEWER),y)
81
+	ln -sf mc $(1)/usr/bin/mcdiff
82
+endif
83
+ifeq ($(CONFIG_MC_EDITOR),y)
84
+	ln -sf mc $(1)/usr/bin/mcedit
85
+endif
86
+	$(INSTALL_DATA) $(PKG_BUILD_DIR)/misc/mc.menu $(1)/etc/mc
87
+	$(INSTALL_DIR) $(1)/etc/mc/skins
88
+	$(INSTALL_DATA) $(PKG_BUILD_DIR)/misc/skins/default.ini $(1)/etc/mc/skins
89
+	$(INSTALL_DIR) $(1)/root/.mc/cedit/Syntax
90
+endef
91
+
92
+define Package/mc/conffiles
93
+/etc/mc/mc.menu
94
+/etc/mc/skins/default.ini
95
+endef
96
+
97
+$(eval $(call BuildPackage,mc))