|
@@ -1,5 +1,5 @@
|
1
|
1
|
#
|
2
|
|
-# Copyright (C) 2008-2014 OpenWrt.org
|
|
2
|
+# Copyright (C) 2008-2015 OpenWrt.org
|
3
|
3
|
#
|
4
|
4
|
# This is free software, licensed under the GNU General Public License v2.
|
5
|
5
|
# See /LICENSE for more information.
|
|
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
|
9
|
9
|
|
10
|
10
|
PKG_NAME:=pthsem
|
11
|
11
|
PKG_VERSION:=2.0.8
|
12
|
|
-PKG_RELEASE:=2
|
|
12
|
+PKG_RELEASE:=3
|
13
|
13
|
|
14
|
14
|
PKG_MAINTAINER:=Othmar Truniger <github@truniger.ch>
|
15
|
15
|
PKG_LICENSE:=LGPL-2.1+
|
|
@@ -37,26 +37,19 @@ define Package/pthsem/description
|
37
|
37
|
pthsem is an extend version, with support for semaphores added. It can be installed parallel to a normal pth.
|
38
|
38
|
endef
|
39
|
39
|
|
40
|
|
-MAKE_FLAGS += \
|
41
|
|
- OPTIM="$(TARGET_CFLAGS)" \
|
42
|
|
- CFLAGS="$(TARGET_CFLAGS)" \
|
43
|
|
- DESTDIR="$(PKG_INSTALL_DIR)"
|
44
|
|
-
|
45
|
40
|
define Build/InstallDev
|
46
|
|
- $(INSTALL_DIR) $(2)/bin
|
47
|
|
- $(INSTALL_BIN) \
|
48
|
|
- $(PKG_INSTALL_DIR)/usr/bin/pthsem-config \
|
49
|
|
- $(2)/bin/
|
50
|
|
- $(SED) \
|
51
|
|
- 's,^\(prefix\|exec_prefix\)=.*,\1=$(STAGING_DIR)/usr,g' \
|
52
|
|
- $(2)/bin/pthsem-config
|
|
41
|
+ $(INSTALL_DIR) $(1)/usr/bin
|
|
42
|
+ $(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/bin/pthsem-config $(1)/usr/bin/
|
|
43
|
+ $(SED) 's,^\(prefix\|exec_prefix\)=.*,\1=$(STAGING_DIR)/usr,g' $(1)/usr/bin/pthsem-config
|
53
|
44
|
|
54
|
45
|
$(INSTALL_DIR) $(1)/usr/include
|
55
|
|
- $(CP) $(PKG_INSTALL_DIR)/usr/include/*.h \
|
56
|
|
- $(1)/usr/include/
|
|
46
|
+ $(CP) $(PKG_INSTALL_DIR)/usr/include/*.h $(1)/usr/include/
|
57
|
47
|
$(INSTALL_DIR) $(1)/usr/lib
|
58
|
|
- $(CP) $(PKG_INSTALL_DIR)/usr/lib/libpthsem.{a,la,so*} \
|
59
|
|
- $(1)/usr/lib/
|
|
48
|
+ $(CP) $(PKG_INSTALL_DIR)/usr/lib/libpthsem.{a,la,so*} $(1)/usr/lib/
|
|
49
|
+ $(INSTALL_DIR) $(1)/usr/lib/pkgconfig
|
|
50
|
+ $(CP) $(PKG_INSTALL_DIR)/usr/lib/pkgconfig/pthsem.pc $(1)/usr/lib/pkgconfig/
|
|
51
|
+ $(INSTALL_DIR) $(2)/bin
|
|
52
|
+ $(LN) ../../usr/bin/pthsem-config $(2)/bin/
|
60
|
53
|
endef
|
61
|
54
|
|
62
|
55
|
define Package/pthsem/install
|