Parcourir la source

Merge pull request #2130 from hnyman/wget1171

wget: bump version to 1.17.1
Hannu Nyman il y a 9 ans
Parent
révision
4d5d3f3ae1

+ 3
- 3
net/wget/Makefile Voir le fichier

@@ -8,12 +8,12 @@
8 8
 include $(TOPDIR)/rules.mk
9 9
 
10 10
 PKG_NAME:=wget
11
-PKG_VERSION:=1.17
12
-PKG_RELEASE:=3
11
+PKG_VERSION:=1.17.1
12
+PKG_RELEASE:=1
13 13
 
14 14
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.xz
15 15
 PKG_SOURCE_URL:=@GNU/$(PKG_NAME)
16
-PKG_MD5SUM:=b8cff5a2f88f5ce60a2b0e361e030b46
16
+PKG_MD5SUM:=b0d58ef4963690e71effba24c105ed52
17 17
 PKG_MAINTAINER:=Maxim Storchak <m.storchak@gmail.com>
18 18
 PKG_LICENSE:=GPL-3.0+
19 19
 PKG_LICENSE_FILES:=COPYING

+ 0
- 131
net/wget/patches/100-fix-nossl-117-from-upstream.patch Voir le fichier

@@ -1,132 +0,0 @@
1
-From 1cb3af1e5b392ac2fae6d9ed8b5d7be399d9f37e Mon Sep 17 00:00:00 2001
2
-From: Ygal Blum <address@hidden>
3
-Date: Tue, 24 Nov 2015 11:24:54 +0200
4
-Subject: [PATCH] Fix compilation when without-ssl is selected
5
-
6
----
7
- src/ftp.c   |  2 ++
8
- src/main.c  | 12 ++++++++++--
9
- src/recur.c |  6 +++++-
10
- src/retr.c  | 18 +++++++++++++++---
11
- src/url.c   |  6 +++++-
12
- 5 files changed, 37 insertions(+), 7 deletions(-)
13
-
14
-diff --git a/src/ftp.c b/src/ftp.c
15
-index 80420ef..5394b71 100644
16
---- a/src/ftp.c
17
-+++ b/src/ftp.c
18
-@@ -393,7 +393,9 @@ getftp (struct url *u, wgint passed_expected_bytes, wgint *qtyread,
19
-   if (!(cmd & DO_LOGIN))
20
-     {
21
-       csock = con->csock;
22
-+#ifdef HAVE_SSL
23
-       using_data_security = con->st & DATA_CHANNEL_SECURITY;
24
-+#endif
25
-     }
26
-   else                          /* cmd & DO_LOGIN */
27
-     {
28
-diff --git a/src/main.c b/src/main.c
29
-index 61a157a..4641008 100644
30
---- a/src/main.c
31
-+++ b/src/main.c
32
-@@ -1842,13 +1842,21 @@ only if outputting to a regular file.\n"));
33
-       else
34
-         {
35
-           if ((opt.recursive || opt.page_requisites)
36
--              && ((url_scheme (*t) != SCHEME_FTP && url_scheme (*t) != SCHEME_FTPS)
37
-+              && ((url_scheme (*t) != SCHEME_FTP
38
-+#ifdef HAVE_SSL
39
-+              && url_scheme (*t) != SCHEME_FTPS
40
-+#endif
41
-+              )
42
-                   || url_uses_proxy (url_parsed)))
43
-             {
44
-               int old_follow_ftp = opt.follow_ftp;
45
- 
46
-               /* Turn opt.follow_ftp on in case of recursive FTP retrieval */
47
--              if (url_scheme (*t) == SCHEME_FTP || url_scheme (*t) == SCHEME_FTPS)
48
-+              if (url_scheme (*t) == SCHEME_FTP
49
-+#ifdef HAVE_SSL
50
-+                  || url_scheme (*t) == SCHEME_FTPS
51
-+#endif
52
-+                  )
53
-                 opt.follow_ftp = 1;
54
- 
55
-               retrieve_tree (url_parsed, NULL);
56
-diff --git a/src/recur.c b/src/recur.c
57
-index 25cdbb7..b212ec6 100644
58
---- a/src/recur.c
59
-+++ b/src/recur.c
60
-@@ -610,7 +610,11 @@ download_child (const struct urlpos *upos, struct url *parent, int depth,
61
-   u_scheme_like_http = schemes_are_similar_p (u->scheme, SCHEME_HTTP);
62
- 
63
-   /* 1. Schemes other than HTTP are normally not recursed into. */
64
--  if (!u_scheme_like_http && !((u->scheme == SCHEME_FTP || u->scheme == SCHEME_FTPS) && opt.follow_ftp))
65
-+  if (!u_scheme_like_http && !((u->scheme == SCHEME_FTP
66
-+#ifdef HAVE_SSL
67
-+      || u->scheme == SCHEME_FTPS
68
-+#endif
69
-+      ) && opt.follow_ftp))
70
-     {
71
-       DEBUGP (("Not following non-HTTP schemes.\n"));
72
-       reason = WG_RR_NONHTTP;
73
-diff --git a/src/retr.c b/src/retr.c
74
-index 318b09c..a6a9bd7 100644
75
---- a/src/retr.c
76
-+++ b/src/retr.c
77
-@@ -837,7 +837,11 @@ retrieve_url (struct url * orig_parsed, const char *origurl, char **file,
78
-          FTP.  In these cases we must decide whether the text is HTML
79
-          according to the suffix.  The HTML suffixes are `.html',
80
-          `.htm' and a few others, case-insensitive.  */
81
--      if (redirection_count && local_file && (u->scheme == SCHEME_FTP || u->scheme == SCHEME_FTPS))
82
-+      if (redirection_count && local_file && (u->scheme == SCHEME_FTP
83
-+#ifdef HAVE_SSL
84
-+          || u->scheme == SCHEME_FTPS
85
-+#endif
86
-+          ))
87
-         {
88
-           if (has_html_suffix_p (local_file))
89
-             *dt |= TEXTHTML;
90
-@@ -1099,12 +1103,20 @@ retrieve_from_file (const char *file, bool html, int *count)
91
- 
92
-       proxy = getproxy (cur_url->url);
93
-       if ((opt.recursive || opt.page_requisites)
94
--          && ((cur_url->url->scheme != SCHEME_FTP && cur_url->url->scheme != SCHEME_FTPS) || proxy))
95
-+          && ((cur_url->url->scheme != SCHEME_FTP
96
-+#ifdef HAVE_SSL
97
-+          && cur_url->url->scheme != SCHEME_FTPS
98
-+#endif
99
-+          ) || proxy))
100
-         {
101
-           int old_follow_ftp = opt.follow_ftp;
102
- 
103
-           /* Turn opt.follow_ftp on in case of recursive FTP retrieval */
104
--          if (cur_url->url->scheme == SCHEME_FTP || cur_url->url->scheme == SCHEME_FTPS)
105
-+          if (cur_url->url->scheme == SCHEME_FTP
106
-+#ifdef HAVE_SSL
107
-+              || cur_url->url->scheme == SCHEME_FTPS
108
-+#endif
109
-+              )
110
-             opt.follow_ftp = 1;
111
- 
112
-           status = retrieve_tree (parsed_url ? parsed_url : cur_url->url,
113
-diff --git a/src/url.c b/src/url.c
114
-index 56079cd..c62867f 100644
115
---- a/src/url.c
116
-+++ b/src/url.c
117
-@@ -1787,7 +1787,11 @@ path_simplify (enum url_scheme scheme, char *path)
118
-               for (--t; t > beg && t[-1] != '/'; t--)
119
-                 ;
120
-             }
121
--          else if (scheme == SCHEME_FTP || scheme == SCHEME_FTPS)
122
-+          else if (scheme == SCHEME_FTP
123
-+#ifdef HAVE_SSL
124
-+              || scheme == SCHEME_FTPS
125
-+#endif
126
-+              )
127
-             {
128
-               /* If we're at the beginning, copy the "../" literally
129
-                  and move the beginning so a later ".." doesn't remove
130
-1.9.1
131
-

+ 0
- 147
net/wget/patches/200-upstream-fix-117-with-ipv6-disabled.patch Voir le fichier

@@ -1,147 +0,0 @@
1
-From 2cfcadf5e6d5c444765aa460915ae27109a8dbce Mon Sep 17 00:00:00 2001
2
-From: Darshit Shah <darnir@gmail.com>
3
-Date: Mon, 16 Nov 2015 23:16:25 +0000
4
-Subject: Fix compile error when IPv6 is disabled
5
-
6
-* src/ftp-basic.c: The code for the new FTPS functionality was unintentionally
7
-inside a #ifdef IPV6 block. Move the code around so that it is defined even when
8
-IPV6 isn't used
9
----
10
-diff --git a/src/ftp-basic.c b/src/ftp-basic.c
11
-index bcb7847..378374c 100644
12
---- a/src/ftp-basic.c
13
-+++ b/src/ftp-basic.c
14
-@@ -429,6 +429,65 @@ ip_address_to_eprt_repr (const ip_address *addr, int port, char *buf,
15
-   buf[buflen - 1] = '\0';
16
- }
17
- 
18
-+/* Bind a port and send the appropriate PORT command to the FTP
19
-+   server.  Use acceptport after RETR, to get the socket of data
20
-+   connection.  */
21
-+uerr_t
22
-+ftp_eprt (int csock, int *local_sock)
23
-+{
24
-+  uerr_t err;
25
-+  char *request, *respline;
26
-+  ip_address addr;
27
-+  int nwritten;
28
-+  int port;
29
-+  /* Must contain the argument of EPRT (of the form |af|addr|port|).
30
-+   * 4 chars for the | separators, INET6_ADDRSTRLEN chars for addr
31
-+   * 1 char for af (1-2) and 5 chars for port (0-65535) */
32
-+  char bytes[4 + INET6_ADDRSTRLEN + 1 + 5 + 1];
33
-+
34
-+  /* Get the address of this side of the connection. */
35
-+  if (!socket_ip_address (csock, &addr, ENDPOINT_LOCAL))
36
-+    return FTPSYSERR;
37
-+
38
-+  /* Setting port to 0 lets the system choose a free port.  */
39
-+  port = 0;
40
-+
41
-+  /* Bind the port.  */
42
-+  *local_sock = bind_local (&addr, &port);
43
-+  if (*local_sock < 0)
44
-+    return FTPSYSERR;
45
-+
46
-+  /* Construct the argument of EPRT (of the form |af|addr|port|). */
47
-+  ip_address_to_eprt_repr (&addr, port, bytes, sizeof (bytes));
48
-+
49
-+  /* Send PORT request.  */
50
-+  request = ftp_request ("EPRT", bytes);
51
-+  nwritten = fd_write (csock, request, strlen (request), -1);
52
-+  if (nwritten < 0)
53
-+    {
54
-+      xfree (request);
55
-+      fd_close (*local_sock);
56
-+      return WRITEFAILED;
57
-+    }
58
-+  xfree (request);
59
-+  /* Get appropriate response.  */
60
-+  err = ftp_response (csock, &respline);
61
-+  if (err != FTPOK)
62
-+    {
63
-+      fd_close (*local_sock);
64
-+      return err;
65
-+    }
66
-+  if (*respline != '2')
67
-+    {
68
-+      xfree (respline);
69
-+      fd_close (*local_sock);
70
-+      return FTPPORTERR;
71
-+    }
72
-+  xfree (respline);
73
-+  return FTPOK;
74
-+}
75
-+#endif
76
-+
77
- #ifdef HAVE_SSL
78
- /*
79
-  * The following three functions defined into this #ifdef block
80
-@@ -542,65 +601,6 @@ bail:
81
- }
82
- #endif /* HAVE_SSL */
83
- 
84
--/* Bind a port and send the appropriate PORT command to the FTP
85
--   server.  Use acceptport after RETR, to get the socket of data
86
--   connection.  */
87
--uerr_t
88
--ftp_eprt (int csock, int *local_sock)
89
--{
90
--  uerr_t err;
91
--  char *request, *respline;
92
--  ip_address addr;
93
--  int nwritten;
94
--  int port;
95
--  /* Must contain the argument of EPRT (of the form |af|addr|port|).
96
--   * 4 chars for the | separators, INET6_ADDRSTRLEN chars for addr
97
--   * 1 char for af (1-2) and 5 chars for port (0-65535) */
98
--  char bytes[4 + INET6_ADDRSTRLEN + 1 + 5 + 1];
99
--
100
--  /* Get the address of this side of the connection. */
101
--  if (!socket_ip_address (csock, &addr, ENDPOINT_LOCAL))
102
--    return FTPSYSERR;
103
--
104
--  /* Setting port to 0 lets the system choose a free port.  */
105
--  port = 0;
106
--
107
--  /* Bind the port.  */
108
--  *local_sock = bind_local (&addr, &port);
109
--  if (*local_sock < 0)
110
--    return FTPSYSERR;
111
--
112
--  /* Construct the argument of EPRT (of the form |af|addr|port|). */
113
--  ip_address_to_eprt_repr (&addr, port, bytes, sizeof (bytes));
114
--
115
--  /* Send PORT request.  */
116
--  request = ftp_request ("EPRT", bytes);
117
--  nwritten = fd_write (csock, request, strlen (request), -1);
118
--  if (nwritten < 0)
119
--    {
120
--      xfree (request);
121
--      fd_close (*local_sock);
122
--      return WRITEFAILED;
123
--    }
124
--  xfree (request);
125
--  /* Get appropriate response.  */
126
--  err = ftp_response (csock, &respline);
127
--  if (err != FTPOK)
128
--    {
129
--      fd_close (*local_sock);
130
--      return err;
131
--    }
132
--  if (*respline != '2')
133
--    {
134
--      xfree (respline);
135
--      fd_close (*local_sock);
136
--      return FTPPORTERR;
137
--    }
138
--  xfree (respline);
139
--  return FTPOK;
140
--}
141
--#endif
142
--
143
- /* Similar to ftp_port, but uses `PASV' to initiate the passive FTP
144
-    transfer.  Reads the response from server and parses it.  Reads the
145
-    host and port addresses and returns them.  */
146
---
147
-cgit v0.9.0.2