|
@@ -1,5 +1,5 @@
|
1
|
1
|
#
|
2
|
|
-# Copyright (C) 2006-2012 OpenWrt.org
|
|
2
|
+# Copyright (C) 2006-2013 OpenWrt.org
|
3
|
3
|
#
|
4
|
4
|
# This is free software, licensed under the GNU General Public License v2.
|
5
|
5
|
# See /LICENSE for more information.
|
|
@@ -9,12 +9,15 @@ include $(TOPDIR)/rules.mk
|
9
|
9
|
|
10
|
10
|
PKG_NAME:=lighttpd
|
11
|
11
|
PKG_VERSION:=1.4.35
|
12
|
|
-PKG_RELEASE:=2
|
|
12
|
+PKG_RELEASE:=3
|
13
|
13
|
|
14
|
14
|
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.xz
|
15
|
15
|
PKG_SOURCE_URL:=http://download.lighttpd.net/lighttpd/releases-1.4.x
|
16
|
16
|
PKG_MD5SUM:=c7ae774eab4cb7ac85e41b712f4ee9ba
|
17
|
17
|
|
|
18
|
+PKG_LICENSE:=BSD-3c
|
|
19
|
+PKG_LICENSE_FILE:=COPYING
|
|
20
|
+
|
18
|
21
|
PKG_FIXUP:=autoreconf
|
19
|
22
|
PKG_INSTALL:=1
|
20
|
23
|
|
|
@@ -46,180 +49,6 @@ config LIGHTTPD_SSL
|
46
|
49
|
lighttpd confguration file.
|
47
|
50
|
endef
|
48
|
51
|
|
49
|
|
-define Package/lighttpd-mod-access
|
50
|
|
- $(call Package/lighttpd/Default)
|
51
|
|
- DEPENDS:=lighttpd
|
52
|
|
- TITLE:=Access restrictions module
|
53
|
|
-endef
|
54
|
|
-
|
55
|
|
-define Package/lighttpd-mod-accesslog
|
56
|
|
- $(call Package/lighttpd/Default)
|
57
|
|
- DEPENDS:=lighttpd
|
58
|
|
- TITLE:=Access logging module
|
59
|
|
-endef
|
60
|
|
-
|
61
|
|
-define Package/lighttpd-mod-alias
|
62
|
|
- $(call Package/lighttpd/Default)
|
63
|
|
- DEPENDS:=lighttpd
|
64
|
|
- TITLE:=Directory alias module
|
65
|
|
-endef
|
66
|
|
-
|
67
|
|
-define Package/lighttpd-mod-auth
|
68
|
|
- $(call Package/lighttpd/Default)
|
69
|
|
- DEPENDS:=lighttpd
|
70
|
|
- TITLE:=Authentication module
|
71
|
|
-endef
|
72
|
|
-
|
73
|
|
-define Package/lighttpd-mod-cgi
|
74
|
|
- $(call Package/lighttpd/Default)
|
75
|
|
- DEPENDS:=lighttpd
|
76
|
|
- TITLE:=CGI module
|
77
|
|
-endef
|
78
|
|
-
|
79
|
|
-define Package/lighttpd-mod-cml
|
80
|
|
- $(call Package/lighttpd/Default)
|
81
|
|
- DEPENDS:=lighttpd
|
82
|
|
- TITLE:=Cache Meta Language module
|
83
|
|
-endef
|
84
|
|
-
|
85
|
|
-define Package/lighttpd-mod-compress
|
86
|
|
- $(call Package/lighttpd/Default)
|
87
|
|
- DEPENDS:=lighttpd +zlib
|
88
|
|
- TITLE:=Compress output module
|
89
|
|
-endef
|
90
|
|
-
|
91
|
|
-define Package/lighttpd-mod-evasive
|
92
|
|
- $(call Package/lighttpd/Default)
|
93
|
|
- DEPENDS:=lighttpd
|
94
|
|
- TITLE:=Evasive module
|
95
|
|
-endef
|
96
|
|
-
|
97
|
|
-define Package/lighttpd-mod-evhost
|
98
|
|
- $(call Package/lighttpd/Default)
|
99
|
|
- DEPENDS:=lighttpd
|
100
|
|
- TITLE:=Exnhanced Virtual-Hosting module
|
101
|
|
-endef
|
102
|
|
-
|
103
|
|
-define Package/lighttpd-mod-expire
|
104
|
|
- $(call Package/lighttpd/Default)
|
105
|
|
- DEPENDS:=lighttpd
|
106
|
|
- TITLE:=Expire module
|
107
|
|
-endef
|
108
|
|
-
|
109
|
|
-define Package/lighttpd-mod-extforward
|
110
|
|
- $(call Package/lighttpd/Default)
|
111
|
|
- DEPENDS:=lighttpd
|
112
|
|
- TITLE:=Extract client IP module
|
113
|
|
-endef
|
114
|
|
-
|
115
|
|
-define Package/lighttpd-mod-fastcgi
|
116
|
|
- $(call Package/lighttpd/Default)
|
117
|
|
- DEPENDS:=lighttpd
|
118
|
|
- TITLE:=FastCGI module
|
119
|
|
-endef
|
120
|
|
-
|
121
|
|
-define Package/lighttpd-mod-flv-streaming
|
122
|
|
- $(call Package/lighttpd/Default)
|
123
|
|
- DEPENDS:=lighttpd
|
124
|
|
- TITLE:=flv streaming module
|
125
|
|
-endef
|
126
|
|
-
|
127
|
|
-define Package/lighttpd-mod-magnet
|
128
|
|
- $(call Package/lighttpd/Default)
|
129
|
|
- DEPENDS:=lighttpd
|
130
|
|
- TITLE:=magnet module
|
131
|
|
-endef
|
132
|
|
-
|
133
|
|
-define Package/lighttpd-mod-mysql-vhost
|
134
|
|
- $(call Package/lighttpd/Default)
|
135
|
|
- DEPENDS:=lighttpd +libmysqlclient
|
136
|
|
- TITLE:=Mysql virtual hosting module
|
137
|
|
-endef
|
138
|
|
-
|
139
|
|
-define Package/lighttpd-mod-proxy
|
140
|
|
- $(call Package/lighttpd/Default)
|
141
|
|
- DEPENDS:=lighttpd
|
142
|
|
- TITLE:=Proxy module
|
143
|
|
-endef
|
144
|
|
-
|
145
|
|
-define Package/lighttpd-mod-redirect
|
146
|
|
- $(call Package/lighttpd/Default)
|
147
|
|
- DEPENDS:=lighttpd +libpcre
|
148
|
|
- TITLE:=URL redirection module
|
149
|
|
-endef
|
150
|
|
-
|
151
|
|
-define Package/lighttpd-mod-rewrite
|
152
|
|
- $(call Package/lighttpd/Default)
|
153
|
|
- DEPENDS:=lighttpd +libpcre
|
154
|
|
- TITLE:=URL rewriting module
|
155
|
|
-endef
|
156
|
|
-
|
157
|
|
-define Package/lighttpd-mod-rrdtool
|
158
|
|
- $(call Package/lighttpd/Default)
|
159
|
|
- DEPENDS:=lighttpd
|
160
|
|
- TITLE:=rrdtool module
|
161
|
|
-endef
|
162
|
|
-
|
163
|
|
-define Package/lighttpd-mod-scgi
|
164
|
|
- $(call Package/lighttpd/Default)
|
165
|
|
- DEPENDS:=lighttpd
|
166
|
|
- TITLE:=SCGI module
|
167
|
|
-endef
|
168
|
|
-
|
169
|
|
-define Package/lighttpd-mod-secdownload
|
170
|
|
- $(call Package/lighttpd/Default)
|
171
|
|
- DEPENDS:=lighttpd
|
172
|
|
- TITLE:=Secure and fast download module
|
173
|
|
-endef
|
174
|
|
-
|
175
|
|
-define Package/lighttpd-mod-setenv
|
176
|
|
- $(call Package/lighttpd/Default)
|
177
|
|
- DEPENDS:=lighttpd
|
178
|
|
- TITLE:=Environment variable setting module
|
179
|
|
-endef
|
180
|
|
-
|
181
|
|
-define Package/lighttpd-mod-simple-vhost
|
182
|
|
- $(call Package/lighttpd/Default)
|
183
|
|
- DEPENDS:=lighttpd
|
184
|
|
- TITLE:=Simple virtual hosting module
|
185
|
|
-endef
|
186
|
|
-
|
187
|
|
-define Package/lighttpd-mod-ssi
|
188
|
|
- $(call Package/lighttpd/Default)
|
189
|
|
- DEPENDS:=lighttpd +libpcre
|
190
|
|
- TITLE:=SSI module
|
191
|
|
-endef
|
192
|
|
-
|
193
|
|
-define Package/lighttpd-mod-status
|
194
|
|
- $(call Package/lighttpd/Default)
|
195
|
|
- DEPENDS:=lighttpd
|
196
|
|
- TITLE:=Server status display module
|
197
|
|
-endef
|
198
|
|
-
|
199
|
|
-define Package/lighttpd-mod-trigger-b4-dl
|
200
|
|
- $(call Package/lighttpd/Default)
|
201
|
|
- DEPENDS:=lighttpd +libpcre
|
202
|
|
- TITLE:=Trigger before download module
|
203
|
|
-endef
|
204
|
|
-
|
205
|
|
-define Package/lighttpd-mod-userdir
|
206
|
|
- $(call Package/lighttpd/Default)
|
207
|
|
- DEPENDS:=lighttpd
|
208
|
|
- TITLE:=User directory module
|
209
|
|
-endef
|
210
|
|
-
|
211
|
|
-define Package/lighttpd-mod-usertrack
|
212
|
|
- $(call Package/lighttpd/Default)
|
213
|
|
- DEPENDS:=lighttpd
|
214
|
|
- TITLE:=User tracking module
|
215
|
|
-endef
|
216
|
|
-
|
217
|
|
-define Package/lighttpd-mod-webdav
|
218
|
|
- $(call Package/lighttpd/Default)
|
219
|
|
- DEPENDS:=lighttpd +libsqlite3 +libuuid +libxml2
|
220
|
|
- TITLE:=WebDAV module
|
221
|
|
-endef
|
222
|
|
-
|
223
|
52
|
CONFIGURE_ARGS+= \
|
224
|
53
|
--libdir=/usr/lib/lighttpd \
|
225
|
54
|
--sysconfdir=/etc/lighttpd \
|
|
@@ -233,7 +62,6 @@ CONFIGURE_ARGS+= \
|
233
|
62
|
--without-ldap \
|
234
|
63
|
--without-lua \
|
235
|
64
|
--without-memcache \
|
236
|
|
- --without-mysql \
|
237
|
65
|
--with-pcre \
|
238
|
66
|
--without-valgrind \
|
239
|
67
|
$(call autoconf_bool,CONFIG_IPV6,ipv6)
|
|
@@ -249,6 +77,14 @@ else
|
249
|
77
|
--without-openssl
|
250
|
78
|
endif
|
251
|
79
|
|
|
80
|
+ifneq ($(SDK)$(CONFIG_PACKAGE_lighttpd-mod-mysql-vhost),)
|
|
81
|
+ CONFIGURE_ARGS+= \
|
|
82
|
+ --with-mysql
|
|
83
|
+else
|
|
84
|
+ CONFIGURE_ARGS+= \
|
|
85
|
+ --without-mysql
|
|
86
|
+endif
|
|
87
|
+
|
252
|
88
|
ifneq ($(SDK)$(CONFIG_PACKAGE_lighttpd-mod-webdav),)
|
253
|
89
|
CONFIGURE_ARGS+= \
|
254
|
90
|
--with-webdav-locks \
|
|
@@ -276,6 +112,8 @@ endef
|
276
|
112
|
define Package/lighttpd/install
|
277
|
113
|
$(INSTALL_DIR) $(1)/etc/lighttpd
|
278
|
114
|
$(INSTALL_DATA) ./files/lighttpd.conf $(1)/etc/lighttpd/
|
|
115
|
+ $(INSTALL_DATA) $(PKG_BUILD_DIR)/doc/config/conf.d/mime.conf $(1)/etc/lighttpd/
|
|
116
|
+ $(INSTALL_DIR) $(1)/etc/lighttpd/conf.d
|
279
|
117
|
$(INSTALL_DIR) $(1)/etc/init.d
|
280
|
118
|
$(INSTALL_BIN) ./files/lighttpd.init $(1)/etc/init.d/lighttpd
|
281
|
119
|
$(INSTALL_DIR) $(1)/usr/lib/lighttpd
|
|
@@ -287,42 +125,57 @@ define Package/lighttpd/install
|
287
|
125
|
endef
|
288
|
126
|
|
289
|
127
|
define BuildPlugin
|
290
|
|
- define Package/$(1)/install
|
291
|
|
- [ -z "$(2)" ] || $(INSTALL_DIR) $$(1)/usr/lib/lighttpd
|
292
|
|
- for m in $(2); do \
|
293
|
|
- $(CP) $(PKG_INSTALL_DIR)/usr/lib/lighttpd/mod_$$$$$$$${m}.so $$(1)/usr/lib/lighttpd/ ; \
|
294
|
|
- done
|
|
128
|
+ define Package/lighttpd-mod-$(1)
|
|
129
|
+ $(call Package/lighttpd/Default)
|
|
130
|
+ DEPENDS:=lighttpd
|
|
131
|
+ ifneq ($(3),)
|
|
132
|
+ DEPENDS+= $(3)
|
|
133
|
+ endif
|
|
134
|
+ TITLE:=$(2) module
|
295
|
135
|
endef
|
296
|
136
|
|
297
|
|
- $$(eval $$(call BuildPackage,$(1)))
|
|
137
|
+ define Package/lighttpd-mod-$(1)/install
|
|
138
|
+ $(INSTALL_DIR) $$(1)/usr/lib/lighttpd
|
|
139
|
+ $(CP) $(PKG_INSTALL_DIR)/usr/lib/lighttpd/mod_$(1).so $$(1)/usr/lib/lighttpd
|
|
140
|
+ $(INSTALL_DIR) $$(1)/etc/lighttpd/conf.d
|
|
141
|
+ if [ -f $(PKG_BUILD_DIR)/doc/config/conf.d/$(1).conf ]; then \
|
|
142
|
+ $(CP) $(PKG_BUILD_DIR)/doc/config/conf.d/$(1).conf $$(1)/etc/lighttpd/conf.d/$(4)-$(1).conf ; \
|
|
143
|
+ else \
|
|
144
|
+ echo 'server.modules += ( "mod_$(1)" )' > $$(1)/etc/lighttpd/conf.d/$(4)-$(1).conf ; \
|
|
145
|
+ fi
|
|
146
|
+ endef
|
|
147
|
+
|
|
148
|
+ $$(eval $$(call BuildPackage,lighttpd-mod-$(1)))
|
298
|
149
|
endef
|
299
|
150
|
|
300
|
151
|
$(eval $(call BuildPackage,lighttpd))
|
301
|
|
-$(eval $(call BuildPlugin,lighttpd-mod-access,access))
|
302
|
|
-$(eval $(call BuildPlugin,lighttpd-mod-accesslog,accesslog))
|
303
|
|
-$(eval $(call BuildPlugin,lighttpd-mod-alias,alias))
|
304
|
|
-$(eval $(call BuildPlugin,lighttpd-mod-auth,auth))
|
305
|
|
-$(eval $(call BuildPlugin,lighttpd-mod-cgi,cgi))
|
306
|
|
-$(eval $(call BuildPlugin,lighttpd-mod-cml,cml))
|
307
|
|
-$(eval $(call BuildPlugin,lighttpd-mod-compress,compress))
|
308
|
|
-$(eval $(call BuildPlugin,lighttpd-mod-evasive,evasive))
|
309
|
|
-$(eval $(call BuildPlugin,lighttpd-mod-evhost,evhost))
|
310
|
|
-$(eval $(call BuildPlugin,lighttpd-mod-expire,expire))
|
311
|
|
-$(eval $(call BuildPlugin,lighttpd-mod-extforward,extforward))
|
312
|
|
-$(eval $(call BuildPlugin,lighttpd-mod-fastcgi,fastcgi))
|
313
|
|
-$(eval $(call BuildPlugin,lighttpd-mod-flv-streaming,flv_streaming))
|
314
|
|
-$(eval $(call BuildPlugin,lighttpd-mod-magnet,magnet))
|
315
|
|
-$(eval $(call BuildPlugin,lighttpd-mod-proxy,proxy))
|
316
|
|
-$(eval $(call BuildPlugin,lighttpd-mod-redirect,redirect))
|
317
|
|
-$(eval $(call BuildPlugin,lighttpd-mod-rewrite,rewrite))
|
318
|
|
-$(eval $(call BuildPlugin,lighttpd-mod-rrdtool,rrdtool))
|
319
|
|
-$(eval $(call BuildPlugin,lighttpd-mod-scgi,scgi))
|
320
|
|
-$(eval $(call BuildPlugin,lighttpd-mod-secdownload,secdownload))
|
321
|
|
-$(eval $(call BuildPlugin,lighttpd-mod-setenv,setenv))
|
322
|
|
-$(eval $(call BuildPlugin,lighttpd-mod-simple-vhost,simple_vhost))
|
323
|
|
-$(eval $(call BuildPlugin,lighttpd-mod-ssi,ssi))
|
324
|
|
-$(eval $(call BuildPlugin,lighttpd-mod-status,status))
|
325
|
|
-$(eval $(call BuildPlugin,lighttpd-mod-trigger-b4-dl,trigger_b4_dl))
|
326
|
|
-$(eval $(call BuildPlugin,lighttpd-mod-userdir,userdir))
|
327
|
|
-$(eval $(call BuildPlugin,lighttpd-mod-usertrack,usertrack))
|
328
|
|
-$(eval $(call BuildPlugin,lighttpd-mod-webdav,webdav))
|
|
152
|
+$(eval $(call BuildPlugin,access,Access restrictions,,10))
|
|
153
|
+$(eval $(call BuildPlugin,accesslog,Access logging,,10))
|
|
154
|
+$(eval $(call BuildPlugin,alias,Directory alias,,10))
|
|
155
|
+$(eval $(call BuildPlugin,auth,Authentication,,05))
|
|
156
|
+$(eval $(call BuildPlugin,cgi,CGI,,10))
|
|
157
|
+$(eval $(call BuildPlugin,cml,Cache Meta Language,,10))
|
|
158
|
+$(eval $(call BuildPlugin,compress,Compress output,+PACKAGE_lighttpd-mod-compress:zlib,10))
|
|
159
|
+$(eval $(call BuildPlugin,evasive,Evasive,,10))
|
|
160
|
+$(eval $(call BuildPlugin,evhost,Exnhanced Virtual-Hosting,,10))
|
|
161
|
+$(eval $(call BuildPlugin,expire,Expire,,10))
|
|
162
|
+$(eval $(call BuildPlugin,extforward,Extract client,,10))
|
|
163
|
+$(eval $(call BuildPlugin,fastcgi,FastCGI,,10))
|
|
164
|
+$(eval $(call BuildPlugin,flv_streaming,FLV streaming,,10))
|
|
165
|
+$(eval $(call BuildPlugin,magnet,Magnet,,10))
|
|
166
|
+$(eval $(call BuildPlugin,mysql_vhost,Mysql virtual hosting,+PACKAGE_lighttpd-mod-mysql_vhost:libmysqlclient,10))
|
|
167
|
+$(eval $(call BuildPlugin,proxy,Proxy,,10))
|
|
168
|
+$(eval $(call BuildPlugin,redirect,URL redirection,+PACKAGE_lighttpd-mod-redirect:libpcre,10))
|
|
169
|
+$(eval $(call BuildPlugin,rewrite,URL rewriting,+PACKAGE_lighttpd-mod-rewrite:libpcre,10))
|
|
170
|
+$(eval $(call BuildPlugin,rrdtool,RRDtool,,10))
|
|
171
|
+$(eval $(call BuildPlugin,scgi,SCGI,,10))
|
|
172
|
+$(eval $(call BuildPlugin,secdownload,Secure and fast download,,10))
|
|
173
|
+$(eval $(call BuildPlugin,setenv,Environment variable setting,,10))
|
|
174
|
+$(eval $(call BuildPlugin,simple_vhost,Simple virtual hosting,,10))
|
|
175
|
+$(eval $(call BuildPlugin,ssi,SSI,+libpcre,10))
|
|
176
|
+$(eval $(call BuildPlugin,status,Server status display,,10))
|
|
177
|
+$(eval $(call BuildPlugin,trigger_b4_dl,Trigger before download,+PACKAGE_lighttpd-mod-trigger_b4_dl:libpcre,10))
|
|
178
|
+$(eval $(call BuildPlugin,userdir,User directory,,10))
|
|
179
|
+$(eval $(call BuildPlugin,usertrack,User tracking,,10))
|
|
180
|
+$(eval $(call BuildPlugin,webdav,WebDAV,+PACKAGE_lighttpd-mod-webdav:libsqlite3 +PACKAGE_lighttpd-mod-webdav:libuuid +PACKAGE_lighttpd-mod-webdav:libxml2,10))
|
|
181
|
+
|