Explorar el Código

haproxy: fix from upstream

 [PATCH 4/4] BUG: config: error in http-response replace-header number

Signed-off-by: Thomas Heil <heil@terminal-consulting.de>
Thomas Heil hace 10 años
padre
commit
4eec42a248

+ 1
- 1
net/haproxy/Makefile Ver fichero

@@ -10,7 +10,7 @@ include $(TOPDIR)/rules.mk
10 10
 
11 11
 PKG_NAME:=haproxy
12 12
 PKG_VERSION:=1.5.3
13
-PKG_RELEASE:=03
13
+PKG_RELEASE:=04
14 14
 PKG_SOURCE:=haproxy-$(PKG_VERSION).tar.gz
15 15
 PKG_SOURCE_URL:=http://haproxy.1wt.eu/download/1.5/src/
16 16
 PKG_MD5SUM:=e999a547d57445d5a5ab7eb6a06df9a1

+ 34
- 0
net/haproxy/patches/0004-BUG-config-error-in-http-response-replace-header-num.patch Ver fichero

@@ -0,0 +1,34 @@
1
+From a772b945d757c25037ac58de64ccc27ceeb4b4a7 Mon Sep 17 00:00:00 2001
2
+From: Baptiste Assmann <bedis9@gmail.com>
3
+Date: Fri, 8 Aug 2014 17:29:06 +0200
4
+Subject: [PATCH 4/4] BUG: config: error in http-response replace-header number
5
+ of arguments
6
+
7
+A couple of typo fixed in 'http-response replace-header':
8
+- an error when counting the number of arguments
9
+- a typo in the alert message
10
+
11
+This should be backported to 1.5.
12
+(cherry picked from commit 12cb00b216d67468b7c4bd84abedcb4ecd1a32bc)
13
+---
14
+ src/proto_http.c | 4 ++--
15
+ 1 file changed, 2 insertions(+), 2 deletions(-)
16
+
17
+diff --git a/src/proto_http.c b/src/proto_http.c
18
+index b7ed85d..2b75b32 100644
19
+--- a/src/proto_http.c
20
++++ b/src/proto_http.c
21
+@@ -9281,8 +9281,8 @@ struct http_res_rule *parse_http_res_cond(const char **args, const char *file, i
22
+ 		cur_arg = 1;
23
+ 
24
+ 		if (!*args[cur_arg] || !*args[cur_arg+1] || !*args[cur_arg+2] ||
25
+-		    (*args[cur_arg+3] && strcmp(args[cur_arg+2], "if") != 0 && strcmp(args[cur_arg+2], "unless") != 0)) {
26
+-			Alert("parsing [%s:%d]: 'http-request %s' expects exactly 3 arguments.\n",
27
++		    (*args[cur_arg+3] && strcmp(args[cur_arg+3], "if") != 0 && strcmp(args[cur_arg+3], "unless") != 0)) {
28
++			Alert("parsing [%s:%d]: 'http-response %s' expects exactly 3 arguments.\n",
29
+ 			      file, linenum, args[0]);
30
+ 			goto out_err;
31
+ 		}
32
+-- 
33
+1.8.5.5
34
+